Jump to content
Sign in to follow this  
animats

Media on a prim testing

Recommended Posts

I've been trying different video sources with Media on a Prim. Firestorm 6.0.1, Ubuntu Linux 16.04LTS x86 64 bit. The results are amusing.

Youtube does some obfuscation to make play of embedded files hard. But the Internet Archive and the test page don't.  So those should work.

Is there any streaming format that works right, with both audio and video?

Share this post


Link to post
Share on other sites

I think you'll find that Linux audio is insanely distro-specific, and not at all limited to SL. There have been too many different competing audio packages and none of them have ever worked reliably across formats. It's one reason I lost patience with the whole debacle and relegated Linux to file-server-only use a few years back.

That said, the whole media playback thing is a horrific mess, not only for MoaP and not just on Linux. Try using PARCEL_MEDIA_COMMAND_TIME to specify the start time for playback: it works for some streams in some formats on some releases of some platforms, with no apparent pattern to what works and what doesn't, other than Linux usually doesn't.

Share this post


Link to post
Share on other sites
Posted (edited)

Now that I have thought it through I don't think your problem has anything to do with proprietary codecs or OpenAL.

Edited by hombra
I think everything I said is wrong

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...