Jump to content
Alexa Linden

Environmental Enhancement Project (aka EEP!) Feedback Thread

Recommended Posts

The sky is ruined. I get the black stars too. the clouds pass the sky in a very unrealistic direction. the horizon line is horrible. Nothing was enhanced at all. What once looked natural no looks like it was done in 1995. I can't possibly blog landscape shots now. Seriously what idiot came up with this?

Share this post


Link to post
Share on other sites
20 hours ago, Linnrenate Crosby said:

Thank you Linden Labs for breaking llGetSunDirection. Now my scripted lights that use this function are turned on right after midday PDT, before the EEP rollout they where lit from sunset to sunrise as they should. Who do i send my electrical bill to???

Mine are too. I really don't want to have to purchase lights that require me to turn them off or on manually. 

 

Share this post


Link to post
Share on other sites

I guess this means I'm going to have to rewrite my LSL port of cron so as not to assume time has a fixed direction. 

Share this post


Link to post
Share on other sites
2 hours ago, dstauffsl2 said:

The sky is ruined. I get the black stars too. the clouds pass the sky in a very unrealistic direction. the horizon line is horrible. Nothing was enhanced at all. What once looked natural no looks like it was done in 1995. I can't possibly blog landscape shots now. Seriously what idiot came up with this?

Don't know but i'm quite sure the idiots last name are Linden

Share this post


Link to post
Share on other sites

Could it be possible that the recent (March 19) roll-out of EEP be the cause to repeated disconnects from SecondLife, either on Teleports (TP) or simply travelling from region to region.

Case: I am sailing, all seems good, sims stats are near perfect, then with no warning, I see i am no longer in control: steering, gestures, chat, nothing I do is passed through to my avatar.. then I get the “You have been logged out of SecondLife / You have been disconnected from the region you were in / View IM & Chat or Quit?” Pop-up message. I log back in SL, managed to sit on my boat again, but then I am no longer skipper, but crew… my avatar ghost still sits on the boat !

Before i started to sail, i got logged off twice on TP only. Many (many) others are reporting the same disconnects, especially since the Mar 19 roll-out.

What it looks like is that there is an issue between the region sim and the login servers...as if they had lost their communication links.... so when you cross from one region to the next, the system no longer know whether you are online or offline... then the boat gets messed up as it gets a false information and get rid of the avatar, but not completely (cf. “ghost” situation described above)…

If i get it right, EEP allows you to keep the same windlight settings across regions during a session, so it creates a DISCONNECT between the region settings and your viewer's settings. Could it be possible that it create a DISCONNECT with your session beyond just the windlight settings, so that you get logged off?  

Share this post


Link to post
Share on other sites
23 minutes ago, vivipezz said:

Could it be possible that the recent (March 19) roll-out of EEP be the cause to repeated disconnects from SecondLife, either on Teleports (TP) or simply travelling from region to region.

Case: I am sailing, all seems good, sims stats are near perfect, then with no warning, I see i am no longer in control: steering, gestures, chat, nothing I do is passed through to my avatar.. then I get the “You have been logged out of SecondLife / You have been disconnected from the region you were in / View IM & Chat or Quit?” Pop-up message. I log back in SL, managed to sit on my boat again, but then I am no longer skipper, but crew… my avatar ghost still sits on the boat !

Before i started to sail, i got logged off twice on TP only. Many (many) others are reporting the same disconnects, especially since the Mar 19 roll-out.

What it looks like is that there is an issue between the region sim and the login servers...as if they had lost their communication links.... so when you cross from one region to the next, the system no longer know whether you are online or offline... then the boat gets messed up as it gets a false information and get rid of the avatar, but not completely (cf. “ghost” situation described above)…

If i get it right, EEP allows you to keep the same windlight settings across regions during a session, so it creates a DISCONNECT between the region settings and your viewer's settings. Could it be possible that it create a DISCONNECT with your session beyond just the windlight settings, so that you get logged off?  

JIRA issue: BUG-226577 - TPs (Teleports) causing Grid Disconnects and grey screen QUITS

Share this post


Link to post
Share on other sites
Posted (edited)

yes, Whirly, I have posted my comment there as well. thank you.

Edited by vivipezz

Share this post


Link to post
Share on other sites

Today I could not change back to SL default  on my sim Legolas after an event when I used a pre-made setting in Firestorm.  Lindens support gave me the information that it was only with this special viewer it was possible. It was rather a shock to see how the SL default looked like after been able change back to SL default.   I had no idea these changes were made and had to write information to tenants. How do I make it look better? - it was lovely before, now colours are very bad and unnatural - also skin and clothes looks bad. SL support said this is SL new normal and looks like this everywhere on the grid? I don't understand the GUI of environmental settings in the special viewer either,  so I don't dare experiment  to try get it better. Where can I find more information? I really want the settings that were before on my sim back.  Very frustrated as no information has been given . Hopefully this will be repaired  very soon.

 

Quote
Quote

 

 

 

Share this post


Link to post
Share on other sites

Lindens must remove this disaster to version and roll back to the version before. Why did is this version developed? I cant see anything that is an improvement - seems only as a sabotage. Maybe a big bug bugger?

Share this post


Link to post
Share on other sites
On 3/24/2019 at 3:04 PM, dstauffsl2 said:

The sky is ruined. I get the black stars too. the clouds pass the sky in a very unrealistic direction. the horizon line is horrible. Nothing was enhanced at all. What once looked natural no looks like it was done in 1995. I can't possibly blog landscape shots now. Seriously what idiot came up with this?

I agree - it was a shock see this disaster on my sim. Today after used a pre-made environment setting in Firestorm I was not able change back to SL default. Lindens support told me it would not be possible without use this special viewer. Ok - it made it possible go back to "SL default" - but yes it looks as gone back to the birth of SL. And the support said "this is new SL normal" (sic!). It looks very ugly, unnatural  (and also skin and clothes look very very bad) - and the GUI of the environment setting in this special viewer is not easy understandable (anyway not for me). No information sent out to sim owners. Had to in a rush write to the tenants on my sim this is out of my control. What are the advantages - I cant see any on my sim. I want Linden roll back to the version before. 

Share this post


Link to post
Share on other sites
13 hours ago, Midnattsdotter Fride said:

Today after used a pre-made environment setting in Firestorm I was not able change back to SL default. Lindens support told me it would not be possible without use this special viewer.

That's not actually true.

If you are using a "legacy" (ie non-EEP) viewer like Firestorm or the default LL release viewer, under World -> Region/Estate -> Environment, you cannot use the "Use Second Life default" option or you will get the following error message:

Screenshot_1.png.c8634a80116f733bda8e84981d231550.png

However, you can set any fixed sky or Day cycle to the region using the "Use the following settings" option.
To reset the region to the default day cycle, choose "Use the following settings" -> Sky/Day Cycle -> Day cycle -> From the dropdown list choose "Default" & Apply.

Screenshot_2.png.2602c71c8ce0320da0ed0d2582776dc9.png

  • Thanks 3

Share this post


Link to post
Share on other sites
1 hour ago, dstauffsl2 said:

Why should i have to look at some ugly default when i had 200 beautiful windlights that don't work anymore?

Once the bugs are worked out, this new sky system is promising to deliver far better skies. I still remember when Windlight was first introduced, SL users were up in arms demanding LL go back to the pre-windlight sky.

 Since this new system allows people to share their creations easily, a feature windlight lacks, I'm sure there will be more new day cycles than you'll know what to do with in the not so distant future.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/23/2019 at 3:38 AM, Rider Linden said:

The way time is calculated has changed between the old windlight system and the new environments. Rather than checking the current time I recommend calling llGetSunPosition and checking if the z component of the returned vector is < 0 or very small (If z is negative the sun is below the horizon.)  This method will work no matter what Environment is applied to your parcel. 

So, does this means that lighting objects purchased over the last decade will be broken? Or will you provide back compatibility to stop content loss?

And, is there a fix for black stars please?

a6d65b783023d6e0be34687e38e0f233.thumb.png.fd418aded12f827201e2134d4f9a937c.png

Edited by Shudo

Share this post


Link to post
Share on other sites

Is there any discussion or wiki content regarding the settings in Skies labeled Moisture Level, Droplet Radius, or Ice Level?

Sudane.................................

Share this post


Link to post
Share on other sites
7 hours ago, Shudo said:

So, does this means that lighting objects purchased over the last decade will be broken? Or will you provide back compatibility to stop content loss?

 And, is there a fix for black stars please?

 

No.  There will be some disagreement about when the sun rises and sets between legacy windlight and EEP, but this should become less and common as EEP viewers become more prevalent.

If you are interested in the technical reason for the discrepancy:  Windlight time did not advance at a constant rate, it would speed up as you approached midnight and slow down when it was noon.  Another way to say this would be it took longer to go from noon to 6pm than it did to go from 6pm to midnight.  EEP maintains a constant rate of time across the entire day cycle, this has the advantage that when you create a day cycle you can know that the time to go from 0% to 25% will be the same as the time it takes to go from 25% to 50%.

 

The black stars are a side effect of translating from Windlight to EEP and then back to Windlight.  They do not appear in EEP viewers. 

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Sudane Erato said:

Is there any discussion or wiki content regarding the settings in Skies labeled Moisture Level, Droplet Radius, or Ice Level?

Sudane.................................

I don't think there is a wiki addressing just those settings yet.  In brief:

  • Moisture Level is the strength of rainbow
  • Ice Level is the strength of 22 deg halo around sun
  • Droplet Radius is a physical parameter affecting the shape and distribution of colors in the rainbow

 

  • Like 1

Share this post


Link to post
Share on other sites

I have three parcels (one of them is a Linden house) and on all my parcels I have noticed that the stars have become black squares and white squares.  This started about two weeks ago.  I asked around to find out if others are having this problem and have found out that it is a widespread problem and it is being attributed to this EEP.  I would certainly like to have my beautiful night sky with regular stars back.  Any suggestions?  I use SL Viewer.

Share this post


Link to post
Share on other sites
1 hour ago, RubyB75 said:

I have three parcels (one of them is a Linden house) and on all my parcels I have noticed that the stars have become black squares and white squares.  This started about two weeks ago.  I asked around to find out if others are having this problem and have found out that it is a widespread problem and it is being attributed to this EEP.  I would certainly like to have my beautiful night sky with regular stars back.  Any suggestions?  I use SL Viewer.

 

2 hours ago, Rider Linden said:

The black stars are a side effect of translating from Windlight to EEP and then back to Windlight.  They do not appear in EEP viewers. 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

There was just a Third Party Viewer meeting. Is the viewer EEP code ready for inclusion in Firestorm yet?

Share this post


Link to post
Share on other sites

I believe firestorm wants to wait until an official SL viewer containing the new EEP code has been released.  It will come, but I'm sure it won't be for a while.

Share this post


Link to post
Share on other sites

My guess is LL will do their best to release it before (or around) SL's 16th bday, unless some new serious bug shows up or some of the big known ones are way too time consuming to fix (was that blended alphas + ALM one fixed yet? I remember seeing pictures of mesh heads with it, it was in pretty bad state by then). Makes sense to me at least. Another year, recap of the last one, plans for the upcoming one, celebrations and shinies. And what can be more shiny than environmental changes that will be visible by nearly everyone who would update their viewer in time?

Out of all known/planned features it's the one I'm waiting the most. I've seen plenty of screenshots with examples of what is/will be possible and very excited to make my own sim wide windlights (or better call them EEPs now?), but I'm gonna wait until all big bugs are fixed and Firestorm implements it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...