Jump to content

Problem Viewing Physics Shapes


Ashasekayi Ra
 Share

You are about to reply to a thread that has been inactive for 3793 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

  • 1 month later...

The Macbook Pro has an automatic graphics switcher for when you start doing higher end graphics.  Its primary adaptor is the Intel Graphics chipset (for displaying desktops, browsing the interwebs, and doing emails).  Until you start doing something really graphically intensive it won't automatically switch over to the Radeon chipset.  If you follow my posts, you'll know that I am a very strong opponent of the Intel graphics chipset because it doesn't support most shader instructions (like shadows) and will crash aaaaaaaaaaaalllllll the time.  Luckily there is a way to manually force the Macbook to use the Radeon chipset all the time, and that will likely resolve your issue, however I haven't the foggiest on how you'd make that change (since I don't own a Mac at all).

Link to comment
Share on other sites

What graphics card do you have in your MBP aside from the Intel one?

At least the newer nVidia ones should be able to show shadows. Mine has a Gforce 330M, and does shadows 'fine'

Oh, what Faynt say about choosing which graphics card is used is in the Energy saver system control panel.

- Luc -

Link to comment
Share on other sites

 


Mikki Miles wrote:

mh, this workaround doesn't work for me, since I work on a Macbook pro, it can't show shadows due to it's hardware.

I tried enabling shadows, and the viewer (232004) crashed. Can any Mac users giver a hint, please?

Since they fixed the black screen bug CTS-446, the work around doesn't work for me, too. If I try the shadow trick, and enable the Physics Shape display, only thing that happens is that the shadows disappear, but no physics shapes show up. With shadows disabled, I still get only the black screen. Strange thing is, on my standalone mode Opensim 7.1 region, the physics shape display works, as long as I have shadows "disabled".

I'm on Windows/Nvidia/and always on the latest Mesh Viewer.

Link to comment
Share on other sites

As far as I know Macbooks come with an Intel Graphics chip to keep down the heat when not doing graphically intense stuff.  Look into adjusting the video chipset as mentioned earlier and I'm sure it'll start working.  The GeForce 9600 should definitely be able to do shadows, mobile version or not.

Link to comment
Share on other sites

I agree with Feynt; The 9600M should be able to do shadows. I have also had issues with the viewer crashing when I tried to enable shadows on any viewer apart from the mesh project viewer. The latest beta, thogh, which is probably almost the same as the mesh viewer, let me enable shadows without crashing. Is this the one you have tried?

- Luc -

Link to comment
Share on other sites

I'm not exactly sure that being up to date on your OS upgrades is the same as being up to date on your graphics drivers on a Mac.  On a PC the two are decidedly separate.  But if I recall there's an upgrade center for Mac which lets you download and install the latest third party drivers if they're out of date.

Link to comment
Share on other sites

I visited the NVidia site, there's no update for the 9600M GT

and usually Apple delivers updates for hardware components with systemupdates.

but anyway, I could see physic shapes in earlier versions of the beta viewer, why do I need to enable shadows all of the sudden. I suspect it being kind of a bug, I filed a jira.

And thanks for your effort!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3793 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...