Jump to content
  • 0
Sign in to follow this  
Psizone

Second Life turns my screen to 3d? How do I stop that?

Question

#####SOLVED#####

I worked it out, needed to go to computer settings and turn off my 3D display settings. Thanks for the advice though.

 

It puts lines all through my screen like it does when 3d is turned on but not quite how the screen needs it to be so it does not quite work with the glasses. I do not really like my screens 3d mode anyway so I just want to know how to turn this off. I could not see anything in the settings, although it is a little difficult to read. I have 2 monitors and if I move the second life window to the other screen it is normal. But that is a pretty low quality screen not even hd so I do not want to use that. When I go to the monitor settings it says the 3d menu is not available with the current input source when the game is running. Whereas normally that is where I turn it on and off. I have an old LG screen do not know the model its like 8 years old. I have not had this issue with anything else for as long as I have had the monitor.

So both of my monitors are connected to the one graphics card and it is only making my main monitor weird. I am saying that it is turning on my monitors 3d mode because the colour mode switches to 3d mode and if I put my glasses on it does looks 3d except its slightly double vision (my eyes are fine ;) ). Updated my drivers a couple months ago, but can try that again. 

Edited by Psizone

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi Psizone!

Second Life does not support any 3D technologies (I mean, the sort you have to wear special glasses to experience).  Those lines you are seeing are something else.  Most likely, your graphics drivers need an update.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Psizone said:

It puts lines all through my screen like it does when 3d is turned on but not quite how the screen needs it to be so it does not quite work with the glasses. I do not really like my screens 3d mode anyway so I just want to know how to turn this off. I could not see anything in the settings, although it is a little difficult to read.

SL doesn't support that 3D Glasses stuff, at all, that's why there is no setting to turn it off, it can't be turned on...

2 hours ago, Psizone said:

I have 2 monitors and if I move the second life window to the other screen it is normal. But that is a pretty low quality screen not even hd so I do not want to use that.

So the older "non HD" screen works properly...

2 hours ago, Psizone said:

When I go to the monitor settings it says the 3d menu is not available with the current input source when the game is running.

That's because SL doesn't use 3D glasses mode... Can't turn off what isn't turned on...

...

Basically, this sounds like one of two things...

Either the drivers for the card the HD monitor is connected to, are borked, possibly by a Windon't Auto-Eff-up-date... Reinstall the drivers using the latest version off the appropriate brand website, ie nvidia or amd depending on the card...

Or...

The HD monitor is on the fritz, and needs replacing...

Try updating the drivers first, also try SWAPPING the monitor cables over, so the HD screen is connected where the non-hd screen usually goes and vice versa, That way you can see if it's the card, the port, or the monitor thats borked.



 

Share this post


Link to post
Share on other sites
  • 0

If you are using NVIDIA 3D Vision, all the settings to change are in NVIDIA.

SL Viewers, because they are OpenGL, generally work with 3D Vision. But, how well is an open question. Plus, there is a bunch of tweaking. See: https://forums.geforce.com/default/topic/682130/3d-vision/-opengl-3d-vision-wrapper-enabling-3d-vision-in-opengl-apps/72/

The viewers are not 'specifically' designed to work with 3D. However, the Z axis info needed by 3D Vision is available in the viewer from OpenGL. I have forgotten if you have to swap X and Y axis for 3D V to look right.

The screen and glasses have to sync. If you have your screen frequency at anything other than 120Hz (I think - its been a while) you'll get bad results.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...