Jump to content
Thomastead

setting up Space Navigator joystick

Recommended Posts

On the login page there is a preferences pulldown. Under Move&View there is a category for Other Devices. When selected, it gives an option to select Joystick Enabled - Space Navigator which I did. I set it to Space Navigator defaults. The problem is it doesn't seem to work after selecting OK then logging in. It worked up to about three weeks ago then quit. I have tested the joystick on 3DConnexions test website and it is functioning correctly. I'm on Mac OS.

SL login.png

Share this post


Link to post
Share on other sites

I have one of these myself.  They can be a bit flakey at times.  Here's what I generally do when mine acts up.  

 

-If you have one of the wireless ones unplug the USB dongle and plug it back in.

-If it's a wireless model you can't have it plugged into a USB port at the same time.  

-Power cycle the controller.  

-Kill the running software and restart it.  

-Toggle it on and off in the viewer and reset it to defaults.  

 

In most cases this gets mine back to life.  I have had to resort to re-installing the software on very rare occasions.  Despite the flakiness this is the single most wonderful thing you can have on SL.  I use mine exclusively to control the camera.  I don't find the avatar moving or building options useful.  

Reach out in world if you like.  I would be glad to chat with you and answer questions.  I use mine on my PC but I'm also a Mac user.  

Share this post


Link to post
Share on other sites

I have used my Space Navigator for YEARS but, now have a new computer and I, for the life of me, can't get it to work any more. I've installed a legacy version of the drivers but need to know what to assign the buttons to?  Any help would be greatly appreciated!!

Share this post


Link to post
Share on other sites

Gracie,

I would go with the latest drivers for the OS that you are using.  From there all you should have to do is use the space navigator defaults in the viewer and it should work.  

I have had problems in the past with the drivers requiring me to uninstall and reinstall the drivers.  I would not recommend using the older drivers.  Just get the new ones from the site and see if that works for you.  Sometimes it takes a little tinkering but it will eventually work for you.  

One other thing.  If you have one of the wireless ones.  Don't try to charge it and use the wireless receiver at the same time.  It tends to bork the driver.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...