Jump to content

Web profiles in V2 show wrong profile?


Darren Scorpio
 Share

You are about to reply to a thread that has been inactive for 4822 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Anybody else having this problem? When I disable the idiotic display names, clicking to view a profile from contact list, nearby list, or selecting from an avi directly results in making the viewer show my own web profile and not the person's profile I wish to see. I had not noticed this problem because I had display names enabled however in laggy areas during events having to hover over people's names to see who the hell they are got to be a PITA so I just disabled display names altogether. I wish the display names would be shown followed by <username> as it is in Phoenix, I don't know why that so hard to do.

Link to comment
Share on other sites

The one time i used V2.6 with the web based profiles i could not save changes. I could login with 1.23.5 made changes which then showed up :smileysad:

I really have enough of 2.x now since so much is seriously borked that i went back to 1.23.5. I have been using 2.4 since last  Dec but it is so borked and with awful screen cluttering.

For me all is silky smooth now with high fps and even sim crossings are not noticed at all for me. And when i change my profile they show up on the web. Excellent.

Link to comment
Share on other sites

out of curiosity, do you have usernames turned off when that's happening? IIRC that's the part that's being grabbed normally for profiles in v2, and turning it off might be inconsistent when display names are lagging in high traffic areas.

I tried inserting the old profile address into the XML, but unfortunately the control is bound and there no keyword for grabbing the UUID (which incidentally has become a PITA to get for random avatars in v2, needing to open profiles in external and rip it from the dropdown menu)

Link to comment
Share on other sites

Hi, I tried different combinations and cannot reproduce this.

I found another strange problem with TPVs that have the web profile bypass patch. If a region has broken display names, they will not show profiles at all, but standard 2.6 can on the same region. But this does not really explain the trouble you see!

Link to comment
Share on other sites

It is happening with both the latest official LL viewer and with Kirsten's Viewer. Dolphin is ok because he doesn't use web profiles. 

Here are my specs maybe it has to do with the OS?

 

Second Life 2.6.5 (227385) Apr 22 2011 01:59:28 (Second Life Beta Viewer)
Release Notes
You are at 142245.0, 252053.0, 4001.4 in Pengo City located at sim3349.agni.lindenlab.com (216.82.18.212:12035)
Second Life Server 11.04.22.227477
Release Notes
CPU: AMD Turion X2 Ultra Dual-Core Mobile ZM-80 (2100 MHz)
Memory: 2768 MB
OS Version: Linux 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Radeon HD 3200 Graphics 
OpenGL Version: 3.3.10666 Compatibility Profile Context
libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: KDU v6.4.1
Audio Driver Version: OpenAL, version 1.1 ALSOFT 1.11.753 / OpenAL Community / OpenAL Soft: PulseAudio Software
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with GCC version 40103
Packets Lost: 31/1161 (2.7%)

Second Life 2.6.5 (227385) Apr 22 2011 01:59:28 (Second Life Beta Viewer)Release Notes
You are at 142245.0, 252053.0, 4001.4 in Pengo City located at sim3349.agni.lindenlab.com (216.82.18.212:12035)Second Life Server 11.04.22.227477Release Notes
CPU: AMD Turion X2 Ultra Dual-Core Mobile ZM-80 (2100 MHz)Memory: 2768 MBOS Version: Linux 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 19:00:26 UTC 2011 i686Graphics Card Vendor: ATI Technologies Inc.Graphics Card: ATI Radeon HD 3200 Graphics 
OpenGL Version: 3.3.10666 Compatibility Profile Context
libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1J2C Decoder Version: KDU v6.4.1Audio Driver Version: OpenAL, version 1.1 ALSOFT 1.11.753 / OpenAL Community / OpenAL Soft: PulseAudio SoftwareQt Webkit Version: 4.7.1 (version number hard-coded)Voice Server Version: Not ConnectedBuilt with GCC version 40103Packets Lost: 31/1161 (2.7%)

 

Link to comment
Share on other sites

odd, because that's my normal setup (displaynames off, usernames on), although I'm running on a windows box. I have seen occasional complete failures of profiles to come up, but they've always shown the right address, never my own.

I'm going to have to wonder if this is something that wasn't ported properly for the Linux version... maybe see if any other linux version users are seeing the same?

the only other vague posibility I can imagine is an attachment/hud issue, where it turns out you're somehow cating you own attachment from the right click, but you said it's happen from other menus as well so that seems unlikely unless the layering order is completly borked and then you'd see a lot more issues than just that...

sorry, I'm kinda outta ideas at this point, perhaps Cerise has some better ones

Link to comment
Share on other sites

 


Darren Scorpio wrote:


Second Life 2.6.5 (227385) Apr 22 2011 01:59:28 (Second Life Beta Viewer)

 

OK, I can reproduce it on that last beta version.

The current release version is Second Life 2.6.3 (227447) Apr 22 2011 13:46:11 (Second Life Release) and I cannot reproduce it there. Yes the numbers went backwards a little, but 2.6.3 isw the latest.

Link to comment
Share on other sites

thanks for the tip, although I've been burned by running dev branch builds before so I'll just suffer through manual logins until the get it to production... I kinda need what limited profile functionality is in V2, to cut down on confusion (lots of non-english translations I need to do) and grab keys as neccessary (yeah I'm too lazy to make a remote key grabber. too much else to do atm, and what's a bit flaky for foriegn language agents coming through some portals)

Link to comment
Share on other sites

Just to be sure everybody knows there's a workaround, as described above:

turn on "Show Display Names" in Preferences > General and other users' Web Profiles will work again.

this is clearly just a temporary workaround until the problem is fixed.

Using outdated viewers which don't and won't support new features is not a good way to support the development and advancement of the Second Life platform and its ecosystem.

Link to comment
Share on other sites

 


Opensource Obscure wrote:

Just to be sure everybody knows there's a workaround, as described above:

turn on "Show Display Names" in
Preferences > General
and other users' Web Profiles will work again.

this is clearly just a temporary workaround until the problem is fixed.

Using outdated viewers which don't and won't support new features is not a good way to support the development and advancement of the Second Life platform and its ecosystem.

It is not a workaround if your intention is to disable display names as my OP said.

 

Link to comment
Share on other sites

 


Opensource Obscure wrote:

[...]Using outdated viewers which don't and won't support new features is not a good way to support the development and advancement of the Second Life platform and its ecosystem.

neither is using broken dev branches that obviously need to go back to QA.... not that any of that is an average users concern.... just saying

 

Link to comment
Share on other sites

 


Opensource Obscure wrote:

Using outdated viewers which don't and won't support new features is not a good way to support the development and advancement of the Second Life platform and its ecosystem.

It would be nice if TPVs would make the profile style a toggle and not just disable the web style profiles. On laggy sims the old profiles can be very slow to load or the details do not load at all, while the new style are prtty reliable for me. But that is why SL introduced web profiles in the first place, so like, yeah.

 

Link to comment
Share on other sites

Did you intend to reply to my post? It's happened a couple of times that I've replied to the wrong post when I've clicked the 'reply' button on the top of the page on page two or three in a thread. I thought perhaps that's what happened here.

Yes, that's a workaround as long as you want display names enabled. If not, you can, as I said above, simply replace your own name, in the profile window, with the name of the person who's profile you want to see.

Using outdated viewers is never a good thing. But... The fact that there are a lot of choice, I believe, have ensured that more people have stayed in SL than would have if there wasn't. Many of these are determined to use viewer 1.23.5 for as long as possible, and I've heard some say that they will leave the day they can't use it anymore. Time will show if they mean it, but viewer 1.23 is outdated, I guess, but it is also still supported by LL. By that measure SL is being advanced by the use of outdated technology, if not when it comes to development.

- Luc -

Link to comment
Share on other sites

My statement about outdated viewers was meant to be part of my signature. It was a generic statement and it wasn't specifically connected with this thread. I have removed it since then. Sorry if it caused confusion.

I added information about enabling Display names because for some people it can be useful as a temporary partial solution. Maybe you're not between those people, but hey.

Personally I know I do NOT want Display Names on my screen. However, I temporarily enabled them since being able to open profiles has a very high priority to me. Not a "workaround"? Fine - as an Italian speaker my knowledge of English language is limited, so I'm not surprised I used the wrong word.

Link to comment
Share on other sites

Ah. Right. That clears up the confusion about the viewer statement.

 

Regarding enabling display names when accessing profiles; I didn't say it was NOT a workaround - which is the correct word as I think you know - but ONE workaround. Simply a different one than the one I suggested.

 

- Luc -

Link to comment
Share on other sites

  • 2 weeks later...

Second Life 2.6.8 (229663) May 11 2011 16:35:46 (Second Life Beta Viewer) has some nice presents in it. --login does not break ZXCV edit keys, and the correct profile loads with display names off.

The viewer update service still holds out the tantalizing possibility of a pony some day, but that still has not been delivered. :matte-motes-impatient: <-- that is supposed to be an impatient face but it looks like all the other faces.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4822 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...