Jump to content
Sign in to follow this  
Ze Marabana

Linux Viewer not Starting

Recommended Posts

Viewer not starting since the lasted version was installed. I'd rather have the option then have it forced on me **Only uploaded images may be used in postings**://secondlife.i.lithium.com/i/smilies/16x16_smiley-sad.gif" border="0" alt=":smileysad:" title="Smiley Sad" /> Running just fine until the update any help is apprecited

/secondlife
64-bit Linux detected.
Running from /home/xxx/tmp/SecondLife-i686-2.6.3.2274447
Warning: Did not register secondlife:// handler with KDE: Directory /homw/xxx/.kde/share/services/ does not exist.
which: no kde4-config in (/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/ibm/c4eb/bin:/home/xxx/bin:/usr/kerberos/bin)
 - Installing menu entries in /home/xxxx/.local/share/applications
bin/do-not-directly-run-secondlife-bin: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
*** Bad shutdown. ***

You are running the Second Life Viewer on a x86_64 platform.  The
most common problems when launching the Viewer (particularly
'bin/do-not-directly-run-secondlife-bin: not found' and 'error while
loading shared libraries') may be solved by installing your Linux
distribution's 32-bit compatibility packages.

Cheers, Ze.

Share this post


Link to post
Share on other sites

Sorry I cannot be much help. Only other thing I can think of is to try to install another V2 TPV like Kirsten's, Dolphin 2, or Firestorm.

Share this post


Link to post
Share on other sites

I noticed your on 64bit. The downloaded viewer is 32bit. Did you try the "linux32" command? $ linux32 secondlife Check your distribution to make sure it has updated all of its 32bit compatability-libs.

Share this post


Link to post
Share on other sites

Yes I have all the 32 bit libraies. The linux32 ./secondlife is not working either, complains about kde4. I did not have any problems until this latest update.

Share this post


Link to post
Share on other sites

 


Ze Marabana wrote:

 
bin/do-not-directly-run-secondlife-bin:
error while loading shared libraries: libSDL-1.2.so.0:
cannot open shared object file: No such file or directory

*** Bad shutdown. ***

Well, there's your problem. You're missing some libraries, in this case the SDL library.

 

Share this post


Link to post
Share on other sites

Since the last update I too am having a problem. MY SL launches just fine, but when I try and log in I get an error:

Login Failed.

Could not resolve the host name.

Please verify that you can connect to the www.secondlife.com

web site. If you can, but continue to receive this error,

please go to the support section and report this error.

 

I got a new copy but same problem.

 

Anna

Share this post


Link to post
Share on other sites


Ze Marabana wrote:

bin/do-not-directly-run-secondlife-bin: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

There's a bug in recent linux versions of Second Life: the libSDL-1.2.so file is in the package, but under a different name than the Second Life Viewer searches for. You can get it to run as follows:

cd /home/xxx/tmp/SecondLife-i686-2.6.3.2274447/libln -s libSDL-1.2.so.0.* libSDL-1.2.so.0

 This will create a symlink, so the actual file is found when the viewer looks for the other filename. (Another option would be to just rename the file.)

Share this post


Link to post
Share on other sites

Use the singularity viewer. it just works on virtually anything. I too had  some  do-not-run-directly glibc 2.11 not found - errors. i cant start sl viewer or firestorm in my pclinuxos . but i found singularity. it just works. and it works faster then the both of them. :)

Share this post


Link to post
Share on other sites
On 8/5/2011 at 8:32 AM, Ze Marabana said:

Thanks for the update, but this did not work either!!

hello,

after battling along with this very same problem, luckily I found a working solution within the Second Life Wiki, here:

http://wiki.secondlife.com/wiki/Linux_Viewer#64-bit

apparently, what happens is that at some point Ubuntu stopped providing support for ia32-libs and thus require now a different process for installing...

I tried the terminal commands suggested, and it has indeed worked for me:

sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386
sudo apt-get install gstreamer0.10-pulseaudio:i386

hope this helps, see you in SL...

 

 

 

 

Edited by Purav Ida

Share this post


Link to post
Share on other sites
1 hour ago, Purav Ida said:

hope this helps, see you in SL...

i guess, if it helps the poster already gave up about 6 yrs ago....

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×