Jump to content
Sign in to follow this  
No Fairlady

Some vertices & Edges are missing from model after upload to SL

Recommended Posts

Hi everyone, 

I don't have pictures of my model atm but, I can provide close ups of the issue if my explanation isn't clear. I am trying to upload a mesh object that is shaped like the letter "L" from blender but, for some reason, when I get the model into SL, it doesn't look like an L any more but, distorted to a point where it appears some edges and vertices seem to be missing. Is there a way to fix this? Do I need more faces and edges on my model? I know this may be hard to determine since I don't have pictures of the model right now but, I hope someone is familiar with this problem. 

 

Thank you for your time!!

Edited by No Fairlady
heading

Share this post


Link to post
Share on other sites

I'm not sure if I understand you right but it may sound like you are trying to upload a model with concave polys.

That is, if it looks something like this:

5b7158ef8703d_Skjermbilde(1331).png.ed8a22c753cbeea2541cf628c4302661.png

and you have the triangulate button in the export options unchecked:

5b71591ff3ed3_Skjermbilde(1333).png.46c59fc1f1afae2cf5655b1bef987c4b.png

You will get  problems not unlike what you describe.

The best solution is to split the concave poly into convex quads. For an L shape single edge across is enough:

5b7159bca1c7c_Skjermbilde(1332).png.22855f44d80b17aa69d01eea97ee859d.png

The second best option is to check the triangulate button.

Edited by ChinRey
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, ChinRey said:

I'm not sure if I understand you right but it may sound like you are trying to upload a model with concave polys.

That is, if it looks something like this:

5b7158ef8703d_Skjermbilde(1331).png.ed8a22c753cbeea2541cf628c4302661.png

and you have the triangulate button in the export options unchecked:

5b71591ff3ed3_Skjermbilde(1333).png.46c59fc1f1afae2cf5655b1bef987c4b.png

You will get  problems not unlike what you describe.

The best solution is to split the concave poly into convex quads. For an L shape single edge across is enough:

5b7159bca1c7c_Skjermbilde(1332).png.22855f44d80b17aa69d01eea97ee859d.png

The second best option is to check the triangulate button.

 

 

 

Yes! Exactly that, I'll try it shortly and see if that makes a difference. I uploaded the model to test it and was surprised that the shape took a different form. What you've described looks like it would work perfectly. Also, I didn't think to triangulate at export, I am thinking if I wanted to take it into another program to paint that would come in handy as well, thanks a ton ChinRey!

 

Share this post


Link to post
Share on other sites

Keep in mind when you work that your shapes should be quadrilaterals (four sides but not necessarily even sides) which then get turned into triangles when the model is uploaded. You don't normally need to triangulate but you do need to think about building your model so that it is made up of those shapes.  

This would be a more typical way an L shaped could be made.  Just another example.  This one has more vertices of course; I recognize that. 

image.png.9247a3c09aafc5830ca3075b82ce590c.png

  • Like 1

Share this post


Link to post
Share on other sites
53 minutes ago, Chic Aeon said:

Keep in mind when you work that your shapes should be quadrilaterals (four sides but not necessarily even sides) which then get turned into triangles when the model is uploaded. You don't normally need to triangulate but you do need to think about building your model so that it is made up of those shapes.  

This would be a more typical way an L shaped could be made.  Just another example.  This one has more vertices of course; I recognize that. 

 

Thank you!! That brings to mind another puzzle I have been absentmindedly tackling in blender. How do I add edges to faces within a model that do not have vertices? When I use the CRTL + R method, nothing happens to the face of the object but, other subdivided parts are affected. I have resorted to using the knife tool which doesn't seem to be the best possible option in some instances since I cannot subdivide that edge anyway.

I hope my description of this makes sense, thank you for any advice offered, I really appreciate it!

Share this post


Link to post
Share on other sites
32 minutes ago, No Fairlady said:

Thank you!! That brings to mind another puzzle I have been absentmindedly tackling in blender. How do I add edges to faces within a model that do not have vertices?

The triangulation tool (Crl+T) is - as the name says) the common way to triangulate polys in Blender but to spilt into quads (which is what you usualy want for SL uploads), the knife tool might be just as quick. It depends on the circumstances. The knife tool is fundamentally slower to use of course but the triangulation tool often requires quite a bit of cleanup afterwards.

In the end either method works just as well, it's jsut a question which is the fastest for the specific task.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Chic Aeon said:

This would be a more typical way an L shaped could be made.  Just another example.  This one has more vertices of course; I recognize that.

It wouldn't actually surprise me if you are right. Seems some SL content creators are addicted to lag and think any excuse to add extra complexity is a good one. :P

Edited by ChinRey
  • Like 2

Share this post


Link to post
Share on other sites

Just wanted to update

I decided to give the upload one more try, so I reuploaded the model and clicked "generate normals" and that seemed to fix the issue. I will still add at least one or two edges to the model just incase I don't get the same luck the third time around.

 

Thank you!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...