Jump to content
  • 0
Vin Soulstar

Firestorm crashing

Question

Quick question.

Does anyone know why Firestorm would crash when taking pictures on ultra setting?

It only seems to happen when i click the snapshot button and it has never done it in the past, I have tried clearing my cache's, reinstalling Firestorm and trying to take pictures on different sims and it still crashes.

Any help would be appreciated as I can no longer do one of my hobbies which is SL photography.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Hi Vin!

I expect our Firestorm uber expert Whirly Fizzle will have something to say about this.  It would help if you'll give us information about which Firestorm version you are using, what operating system you are using, and what graphics card and drivers you are using.  You can get the relevant information from the viewer, Help/About Firestorm.  Copy the system information, edit your original post and paste it in.

Share this post


Link to post
Share on other sites
  • 0
47 minutes ago, Vin Soulstar said:

Quick question.

Does anyone know why Firestorm would crash when taking pictures on ultra setting?

It only seems to happen when i click the snapshot button and it has never done it in the past, I have tried clearing my cache's, reinstalling Firestorm and trying to take pictures on different sims and it still crashes.

Any help would be appreciated as I can no longer do one of my hobbies which is SL photography.

IF photos on ultra were fine before and not now, and if it happens in various sims (hence level of details and possibly heavy mesh and textures) then I SUSPECT that it has something to do with your operating system?   I am in Win10 Pro and I have lately (maybe a month) had crashes when using depth of field while  having one or more other avatars on. IF I reboot my computer and only have ME on then I am OK. This has not been the story in the past.

So, I am guessing that there has been a change in Windows (could certainly be true with other operating systems to) that are causing the problem. 

My Windows updates automatically when I sleep and SOMETIMES it isn't a positive thing (not new news).   I doubt seriously it is Firestorm, but it could be a specific software conflict.  It might be painful, but I suggest taking some trial shots on ultra with the Linden viewer or another and see if the issue persists. 

Meanwhile the only fix I have found is to only have one viewer running. That translates into "simplify" in whatever way you can. Even turning down your draw distance might solve your issue. Think of things that you really don't HAVE to have for your photo and change those settings in Preferences. 

 

Good luck. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, Chic Aeon said:

IF photos on ultra were fine before and not now, and if it happens in various sims (hence level of details and possibly heavy mesh and textures) then I SUSPECT that it has something to do with your operating system?   I am in Win10 Pro and I have lately (maybe a month) had crashes when using depth of field while  having one or more other avatars on. IF I reboot my computer and only have ME on then I am OK. This has not been the story in the past.

So, I am guessing that there has been a change in Windows (could certainly be true with other operating systems to) that are causing the problem. 

My Windows updates automatically when I sleep and SOMETIMES it isn't a positive thing (not new news).   I doubt seriously it is Firestorm, but it could be a specific software conflict.  It might be painful, but I suggest taking some trial shots on ultra with the Linden viewer or another and see if the issue persists. 

Meanwhile the only fix I have found is to only have one viewer running. That translates into "simplify" in whatever way you can. Even turning down your draw distance might solve your issue. Think of things that you really don't HAVE to have for your photo and change those settings in Preferences. 

 

Good luck. 

Thank you so much for replying Chic.

I just tried using a different WL setting and it didn't crash on me this time, I was using the Phototools WL settings and just used the TOR ones then and it was fine.

I am using Windows 8.1 but I will try a few things as you suggested.

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, Vin Soulstar said:

Thank you so much for replying Chic.

I just tried using a different WL setting and it didn't crash on me this time, I was using the Phototools WL settings and just used the TOR ones then and it was fine.

I am using Windows 8.1 but I will try a few things as you suggested.

Interesting!  I wouldn't have thought a Windlight setting could cause a crash. MINE are the ones called "Places". Made LONG LONG ago. We will have new Windlight opportunities to bond with or conquer soon. All good. 

Well I am guessing that they still update Win 8 now and then too. I have had "issues" with updates, most I have been able to fix or work around. Lots of people in the world using lots of different programs. Difficult to test for everything. Good luck. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Have you raised the "Quality of Shadows" setting above default?
Preferences -> Graphics -> Rendering -> Quality of the Shadows.

The default setting is 1.0.
Raising this setting too high can crash the viewer when taking a large sized snapshot.
If you have a good system, you may get away with setting it at 2, 3 is iffy, 4 will crash a Titan  ;)

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
On 08/07/2018 at 2:42 AM, Whirly Fizzle said:

Have you raised the "Quality of Shadows" setting above default?
Preferences -> Graphics -> Rendering -> Quality of the Shadows.

The default setting is 1.0.
Raising this setting too high can crash the viewer when taking a large sized snapshot.
If you have a good system, you may get away with setting it at 2, 3 is iffy, 4 will crash a Titan  ;)

Thanks Whirly, I will give your suggestion a go now. I just tried taking another picture and it's crashing on me again, Different sim though so I'm wondering if the sim I am on has something to do with it maybe.

On 07/07/2018 at 12:07 PM, Chic Aeon said:

Interesting!  I wouldn't have thought a Windlight setting could cause a crash. MINE are the ones called "Places". Made LONG LONG ago. We will have new Windlight opportunities to bond with or conquer soon. All good. 

Well I am guessing that they still update Win 8 now and then too. I have had "issues" with updates, most I have been able to fix or work around. Lots of people in the world using lots of different programs. Difficult to test for everything. Good luck. 

Thanks Chic. :)

Share this post


Link to post
Share on other sites
  • 0
On 08/07/2018 at 2:42 AM, Whirly Fizzle said:

Have you raised the "Quality of Shadows" setting above default?
Preferences -> Graphics -> Rendering -> Quality of the Shadows.

The default setting is 1.0.
Raising this setting too high can crash the viewer when taking a large sized snapshot.
If you have a good system, you may get away with setting it at 2, 3 is iffy, 4 will crash a Titan  ;)

Wow turned settings to ultra and checked my shadows setting and they were on 4....

Turning them down to around 2 and that seems to of stopped the crashing, thank you so so much. <3

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Vin Soulstar said:

Thanks Whirly, I will give your suggestion a go now. I just tried taking another picture and it's crashing on me again, Different sim though so I'm wondering if the sim I am on has something to do with it maybe.

Thanks Chic. :)

As a TEST you might zip over to LEA6 which is the Machinima Open Studio Project. I designed it to be photography friendly and while there ARE some heavy textures in the sim (not mine :D) they are on decor items and mostly inside. It "should" make picture taking easier with no crashing. There are many levels and you can find a landmark giver here: http://maps.secondlife.com/secondlife/LEA6/131/128/23

Before I bought my current machine a couple of years ago, there were several sims that I couldn't use (let alone take photos in) because of the heavy mesh and textures.  AND, things have become worse since then, not better. So your favorite photography sims while OhSoPretty may be the underlying cause of your issues. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Chic Aeon said:

As a TEST you might zip over to LEA6 which is the Machinima Open Studio Project. I designed it to be photography friendly and while there ARE some heavy textures in the sim (not mine :D) they are on decor items and mostly inside. It "should" make picture taking easier with no crashing. There are many levels and you can find a landmark giver here: http://maps.secondlife.com/secondlife/LEA6/131/128/23

Before I bought my current machine a couple of years ago, there were several sims that I couldn't use (let alone take photos in) because of the heavy mesh and textures.  AND, things have become worse since then, not better. So your favorite photography sims while OhSoPretty may be the underlying cause of your issues. 

Thanks Chic, is the sim Adult?

I am trying to get an arty black and white at the moment so had to ask. :)

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, Vin Soulstar said:

Wow turned settings to ultra and checked my shadows setting and they were on 4....

Turning them down to around 2 and that seems to of stopped the crashing, thank you so so much. <3

Oh yes, shadow settings can be LETHAL!  I always take a shot before fiddling with them because they can cause a crash on most any machine. You didn't TELL USE you were fiddling around in the PhotoTools!   LOL.    That was likely your issue although the other thoughts can certainly come into play.  

Edited by Chic Aeon
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Vin Soulstar said:

Thanks Chic, is the sim Adult?

No sorry not Adult rated. M

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Chic Aeon said:

Oh yes, shadow settings can be LETHAL!  I always take a shot before fiddling with them because they can cause a crash on most any machine. You didn't TELL USE you were fiddling around in the PhotoTools!   LOL.    That was likely your issue although the other thoughts can certainly come into play.  

I promise to be more informative with my next question. :P

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Chic Aeon said:

No sorry not Adult rated. M

Well that's OK, I have it landmarked now for the more moderate picture. :)

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Vin Soulstar said:

I am trying to get an arty black and white at the moment so had to ask.

Try Lea 18 too

 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

So had I been more PERCEPTIVE, the comment about a different Windlight would have made more sense. Some Windlights of course have no shadows. If there are no shadows then the "shadow resolution" setting doesn't come into play (or not much). Hence, no issue. Depth of Field can be a killer too depending on the settings  and of course if it is paired with shadows.  Just adding that for folks finding this thread. 

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, Chic Aeon said:

So had I been more PERCEPTIVE, the comment about a different Windlight would have made more sense. Some Windlights of course have no shadows. If there are no shadows then the "shadow resolution" setting doesn't come into play (or not much). Hence, no issue. Depth of Field can be a killer too depending on the settings  and of course if it is paired with shadows.  Just adding that for folks finding this thread. 

It's nothing to do with the windlight setting.
The windlight setting will change how apparent the shadows are or at what angle they render, but when Shadows are enabled in graphics preferences, they are always present & the system has to deal with rendering them, even if you don't notice them that much because of the windlight setting.
The Shadow Quality setting is very hard hitting on the system if you raise it above default.
A good system won't have too much trouble with a performance decrease when raising the shadow quality setting, but it's a whole different ballgame when you take a large size snapshot.
Snapshots taken at a size greater then the current viewer window size used to be made up of a bunch of smaller sized images which were stitched together - however this often caused seams in the stitched images - the "tiling bug" - VWR-21917 & FIRE-4725

Since the fix for the tiling bug on high res snapshots went into the viewers (this was the bug that caused ugly "stitch lines" to show up on high res snaps when the snapshot size was higher then current window size), an unfortunate, though somewhat expected, side effect to this fix is that your graphics driver will crash much more easily when taking super-sized snapshots with shadows enabled. This is basically because, instead of high res shots being made up of lots of smaller shots stiched together, the snapshot is saved at the actual size you choose to take it, which puts much more stress on the graphics card and can easily crash the graphics driver.

  • Thanks 2

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Whirly Fizzle said:

It's nothing to do with the windlight setting.

Got it; so "why" do you suspect the Windlight made a difference?  Or was that just an "accident" of the sim itself.  

I do vaguely remember that stitching bug. I wasn't taking large photos at the time so it didn't affect me.  And I DEFINITELY remember how many folks crashed with the shadow settings appeared for use LOL>  If I am careful I can crank them up and not crash but I always keep my fingers crossed and a "default" shot saved in case I do crash. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...