Jump to content
  • 0
CrazySam Sorrowsong

second life update loop

You are about to reply to a thread that has been inactive for 761 days.

Please take a moment to consider if this thread is worth bumping.

Question

Hi i seem to be having a problem with the viewer maintenance 31/05/2018 it does the deleting then the extracting then closes like it normally does then tries opening again just to go back to wanting to do maintenance again. its a never ending loop.

Just to add ive tried un-installing and re-installing the viewer and its doing the same. if someone can help me fix this id be happy

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 3

Augustus, and CrazySam...

Kyle Linden posted a solution in another thread.  If your system has the same characteristics, try installing the 32 bit viewer, as he suggests here: https://community.secondlife.com/forums/topic/423135-how-do-i-stop-the-sl-viewer-from-constantly-uninstalling-and-re-downloading-whenever-i-try-to-run-it/#comment-1756406

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

This is likely caused by your desktop link to the viewer. You have probably been upgraded from 32 to 64 bit. The 32 & 64 viewers install in different directories. Your shortcut link is pointing to the wrong one. So, each time it runs the old version and thinks it needs to update.

Look to see if there is a new icon on your desktop. Delete the old one, and use the new one. Unpin any icons you have in your tool bar. Once you have an icon that doesn't loop-install, pin it to the tool bar.

As an alternate, delete all the icons for the viewer then reinstall it over the top of the previous install to get a new icon.

Edited by Nalates Urriah
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Nalates Urriah said:

This is likely caused by your desktop link to the viewer. You have probably been upgraded from 32 to 64 bit. The 32 & 64 viewers install in different directories. Your shortcut link is pointing to the wrong one. So, each time it runs the old version and thinks it needs to update.

Look to see if there is a new icon on your desktop. Delete the old one, and use the new one. Unpin any icons you have in your tool bar. Once you have an icon that doesn't loop-install, pin it to the tool bar.

As an alternate, delete all the icons for the viewer then reinstall it over the top of the previous install to get a new icon.

tried everything but seems only firestorm will work idk how to get my viewer from secondlife.com to work

Share this post


Link to post
Share on other sites
  • 0

Nalates has the correct answer, and the easy solution. Check to see which directory your new download of the SL viewer is in: Programs or Programs32. The new download of a 64 bit viewer will not replace the start icon of the old 32 bit viewer.

Share this post


Link to post
Share on other sites
  • 0

I only have 64 bit version installed, and I am having the same problem. I have even uninstalled SL completely and reinstalled. Same thing: an infinite update loop.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, AugustusKing said:

I only have 64 bit version installed, and I am having the same problem. I have even uninstalled SL completely and reinstalled. Same thing: an infinite update loop.

There is the reality of what is on the computer and what you THINK is on the computer. So, look in the icon's properties (right-click the icon then right click the app-icon in the list popup to get to Properties) that you use to open the viewer and see what program it is launching.

If you run with Allow RC's enabled this can get a bit confusing. But, this looping is always caused by starting an out of date version of the viewer. The RC's and 32/64 bit versions all use different program install folders.

Plus, if I remember correctly, some of the RC's  install over the main default viewer when RC's are enabled. 

My point is look carefully at the icon. Because every case of looping that I have seen or heard of the launch icon is the problem. The viewer's launcher knows what version it is and it checks the server to see what is available. There isn't much of any place for things to go wrong. And if things do go sideways... we'll have about 40k people complaining.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm having the same installation loop problem, an endless sequence, I already did everything that was suggested here and nothing solves the problem, I've used a test version because the official version has this terrible error.

  • Like 1

Share this post


Link to post
Share on other sites
  • -1
18 hours ago, Aisllynn said:

I'm having the same installation loop problem, an endless sequence, I already did everything that was suggested here and nothing solves the problem, I've used a test version because the official version has this terrible error.

Lindal posted the Linden solution above. It is currently bumped to the top as I write this. So, if you have done the 32-64 bit dance and downloaded a new version of the viewer, you should be good.

HOWEVER... if you have tried that, you need to open a viewer that will launch, you don't have to login, and use HELP->ABOUT... to capture your system information and paste it in here. Otherwise, we can't help. All we can do is guess and then you get to try all our bad guesses. Frustrating for both sides.

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 761 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...