Jump to content
Sign in to follow this  
PointlessName

No idea how to rig for SL (Blender)

Recommended Posts

I'll make this quick so you don't have to read all day.

Got a custom avatar, it contains many different meshes. When trying to rig with "original collision bones" (http://wiki.secondlife.com/wiki/Mesh/Rigging_Fitted_Mesh) the model doesn't work at all.

I've tried overlapping a default model ontop of mine and rigging off of it, just ends up becoming a hot mess, even after fixing the weight, and uploading it, the model is just broken sideways and deformed, besides it not looking like that in any render of blender.

So what do I do. I've tried looking everywhere. all I can find on the forums and youtube videos for rigging basic cloths, for default shaped avatars, or rigging models that also use the default shape, or very close to it.

My avatar is small and bulky with a lot of grouped mesh.

So what do I do? How do I do it, and is it better off just rigging the mesh alone, or the whole model.

I've done rigging in other programs, but SL is strict.

Model example.png

Edited by PointlessName

Share this post


Link to post
Share on other sites
42 minutes ago, Kyrah Abattoir said:

Avastar or stock blender dae exporter?

 

Also why did you blot out the parent object name?

avastar.

Cause its named after me.

This is the outcome of trying to follow this (https://www.youtube(((DOT)))com/watch?v=0Mh7Yxbbp_4) and this (https://www.youtube(((DOT)))com/watch?v=enjFJcn45wY)

Also that and I normally either get the error "Material of Model is not a subset of reference material" or "heat weighting: failed to find solution for one or more bones"

Mind you this is a Maya FBX export and I had done the fixes in this thead (https://community.secondlife(((DOT)))com/forums/topic/420730-from-maya-to-blender/?tab=comments#comment-1737756)

(Not sure if theres a way to link websites without overflowing)

I've tried the model combined into one mesh, or separated into 100's

I just about given up all hope.

5b0a474e642d8_Modelbroken.png.755428f0a102c6495788caf504cf2d02.png

Edited by PointlessName

Share this post


Link to post
Share on other sites

I was exporting as standard DAE file, after exporting to the avastar export, all my problems were fixed.

Figures it would be something as simple as that.

Share this post


Link to post
Share on other sites

It looks like you have some Empty object in your character's skeleton hierarchy? This might have been included in the bind pose and, obviously, not recognized by SL, resulting in "heat weighting: failed to find solution for one or more bones". Moreover, SL wants the avatar facing the +X axis: Avastar handles most of that for you but the stock Collada exporter doesn't, therefore supplying a rotated avatar misplaces all joints inworld when the uploader isn't complaining about the heatmap solution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...