Jump to content

No idea how to rig for SL (Blender)


You are about to reply to a thread that has been inactive for 745 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'll make this quick so you don't have to read all day.

Got a custom avatar, it contains many different meshes. When trying to rig with "original collision bones" (http://wiki.secondlife.com/wiki/Mesh/Rigging_Fitted_Mesh) the model doesn't work at all.

I've tried overlapping a default model ontop of mine and rigging off of it, just ends up becoming a hot mess, even after fixing the weight, and uploading it, the model is just broken sideways and deformed, besides it not looking like that in any render of blender.

So what do I do. I've tried looking everywhere. all I can find on the forums and youtube videos for rigging basic cloths, for default shaped avatars, or rigging models that also use the default shape, or very close to it.

My avatar is small and bulky with a lot of grouped mesh.

So what do I do? How do I do it, and is it better off just rigging the mesh alone, or the whole model.

I've done rigging in other programs, but SL is strict.

Model example.png

Edited by PointlessName
Link to post
Share on other sites
42 minutes ago, Kyrah Abattoir said:

Avastar or stock blender dae exporter?

 

Also why did you blot out the parent object name?

avastar.

Cause its named after me.

This is the outcome of trying to follow this (https://www.youtube(((DOT)))com/watch?v=0Mh7Yxbbp_4) and this (https://www.youtube(((DOT)))com/watch?v=enjFJcn45wY)

Also that and I normally either get the error "Material of Model is not a subset of reference material" or "heat weighting: failed to find solution for one or more bones"

Mind you this is a Maya FBX export and I had done the fixes in this thead (https://community.secondlife(((DOT)))com/forums/topic/420730-from-maya-to-blender/?tab=comments#comment-1737756)

(Not sure if theres a way to link websites without overflowing)

I've tried the model combined into one mesh, or separated into 100's

I just about given up all hope.

5b0a474e642d8_Modelbroken.png.755428f0a102c6495788caf504cf2d02.png

Edited by PointlessName
Link to post
Share on other sites

It looks like you have some Empty object in your character's skeleton hierarchy? This might have been included in the bind pose and, obviously, not recognized by SL, resulting in "heat weighting: failed to find solution for one or more bones". Moreover, SL wants the avatar facing the +X axis: Avastar handles most of that for you but the stock Collada exporter doesn't, therefore supplying a rotated avatar misplaces all joints inworld when the uploader isn't complaining about the heatmap solution.

Link to post
Share on other sites
  • 1 year later...
You are about to reply to a thread that has been inactive for 745 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...