Jump to content
Blaze Nielsen

sl streaming video problem

Recommended Posts

just became aware that several video formats no longer work in sl. m4v and mp4 formats no longer work. In my testing, seems like only the .mov format is the only one currently working.  I guess they weren't licensing the decoders properly. who knows . this breaks a lot of content I have had inworld for some time now.

Share this post


Link to post
Share on other sites

mp4 works.
Going by my logs, mp4 plays using the viewer libVLC plugin.
Test video: http://clips.vorwaerts-gmbh.de/VfE_html5.mp4 from http://camendesign.co.uk/code/video_for_everybody/test.html

m4v is working too, using the LibVLC plugin.
Test video: https://sites.lafayette.edu/newquisk/files/2011/08/ken-video.m4v?_=1

I tested on both the LL viewer & Firestorm, Windows 64bit.

Which viewer are you using?
In the top menu bar of the viewer, go to Help -> About Second Life/viewer name.
Click the copy to clipboard button & paste all your system information here.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi whirly, both of your mp4 andm4v files work just fine. the mystery is why arent the files Ive been using in sl for years NOT working now in both firestorm and sl viewer? I was alerted to this problem by a customer who owns a skybox that uses my video files and no longer works. This is an example of a file that has always worked in sl and no longer works. https://s3.amazonaws.com/skyboxvideo/Foggy+Stream.mp4. heres my system/firestorm info:    

Firestorm 5.0.11 (53634) Jan 12 2018 10:29:27 (Firestorm-Releasex64) with Havok support
Release Notes

CPU: Intel(R) Core(TM) i7-4771 CPU @ 3.50GHz (3500 MHz)
Memory: 16384 MB
OS Version: Mac OS X 10.13.4 Darwin 17.5.0 Darwin Kernel Version 17.5.0: Fri Apr 13 19:32:32 PDT 2018; root:xnu-4570.51.2~1/RELEASE_X86_64 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: NVIDIA GeForce GTX 780M OpenGL Engine

OpenGL Version: 2.1 NVIDIA-10.30.25 355.11.10.10.30.120

RestrainedLove API: (disabled)
libcurl Version: libcurl/7.47.0 OpenSSL/1.0.1i zlib/1.2.8
J2C Decoder Version: KDU v7.9
Audio Driver Version: FMOD Ex 4.44.61
LLCEFLib/CEF Version: 1.5.3-(CEF-OSX-3.2171.2069-32)
LibVLC Version: Undefined
Voice Server Version: Not Connected
Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Window size: 2458x1356 px
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0.5 pt
UI Scaling: 1.475
Draw distance: 248 m
Bandwidth: 1500 kbit/s
LOD factor: 4
Render quality: Medium (3/7)
Advanced Lighting Model: No
Texture memory: 1024 MB (1)
VFS (cache) creation time (UTC): unknown
Built with Clang version 4.2.1 Compatible Apple LLVM 8.1.0 (clang-802.0.42)
May 13 2018 19:43:43 SLT

Edited by Blaze Nielsen

Share this post


Link to post
Share on other sites

Huh interesting.

That mp4 link will play in Firefox web browser but I can't get it to play on Chrome - it insists on downloading the file instead.
Are you seeing the same thing?

The SL viewers media integration uses CEF (Chromium Embedded Framework) so generally if something is broken in Chrome web browser, it will be broken in the SL viewers too.

Share this post


Link to post
Share on other sites

I can say that since linden lab switched to CEF and i dumped the obsolote flash and quicktime software. Video not always works. Not figured ut whst lt how. Not use it enough.

Share this post


Link to post
Share on other sites

Ok further testing...

Your MP4 video will play in Firestorm & the LL viewer for me using the viewer's LibVLC plugin on my Windows 64bit system.

I don't have a Mac to test on.
Was the user who reported the problem also on Mac?
 

Share this post


Link to post
Share on other sites
Posted (edited)

that https://s3.amazonaws.com/skyboxvideo/Foggy+Stream.mp4 file will play on my mac version of firefox, will NOT work in chrome and downloads the file in safari. It will also not work in sl viewer or firefox even though it has worked consistently in sl for a couple of years. Not sure about customers platform, will check it. Also, I will offer the video url to some pc users to try out.

Edited by Blaze Nielsen
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Blaze Nielsen said:

that https://s3.amazonaws.com/skyboxvideo/Foggy+Stream.mp4 file will play on my mac version of firefox, will NOT work in chrome and downloads the file in safari.

That link returns the MIME type 'application/octet-stream', which is why some things download it.  If you configure the bucket to return the correct MIME type it might do better.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Oz, the problem here for me is that content I've been selling for years is now BROKEN in sl for the most part. I'll have a year of customers complaining about crappy products and redelivering fixed products to them. I can convert the non working formats into .mov files and reconfigure my products inworld. But having this change in sl causes a very big hardship for me and I suspect other video products sold in sl. 

 

ps. just learned the customer who complained videos not working was on an older mac os.

Edited by Blaze Nielsen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×