Jump to content

GTX 460 and Anti Aliasing


Eros Eternal
 Share

You are about to reply to a thread that has been inactive for 3835 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hey everyone, I have an Nvidia Geforce GTX 460 1GB GPU. I noticed that when I try to set the anti aliasing beyond 4X, that it does not seem to do anything (I have tried using the in viewer settings and the Nvidia control panel settings). I wanted to turn it up to 8X but it seems that nothing happens when I do (in fact the jagged edges get worse than when I have it set to 4X). I was wondering if there was some sort of fix for this issue. Thanks in advance! :smileyhappy:

Link to comment
Share on other sites

Hi Eros, I have the same problem everytime I do a clean install of a Viewer 2 update.

I can think of two possible causes, but there may be more.

Firstly, have a look at the settings for your card in your nvidia control panel and make sure it is set to allow the 3D application to decide...   3D settings / adjust image settings with preview / let the 3D application decide.  If you do not want SL to decide, because you have your card set to your own preferences, then ensure it is not in this control panel you have limited to 4x as a max.

Second thing to check is in Viewer 2 itself, you must have Framebuffer Objects (FBO) allowed for antialiasing to display.

Go to Develop on the menu bar (ctrl+alt+Q to enable it, if you can't see it)...  Develop / Rendering / Framebuffer objects.  Once you click on FBO it should have a tick next to it.

Once you have done both of the above, return to preferences and try out 4x, 8x etc.  If it's still not working, relog the Viewer, check FBO is still ticked, then try fiddling with antialiasing again.

I have an older nvidia than yours, and this is how I enabled antialiasing.  I have no more jagged edges at all and only need to have it set at 4x

Link to comment
Share on other sites

if you have any desire to use shadows, set the viewer to turn off AA and anistropric, and set the to the overrides suggested in the nvidia control panel for programs that can't handle AA when HDR is enabled... then restart.... I found my own settings wouldn't take on the fly, but worked normally afterward. (different card though, ymmv)

Link to comment
Share on other sites

 


Charolotte Caxton wrote:

Hi Magnus, Void, and Leliel.

Is that true? Anti aliasing won't work without FBO enabled? 

 

Sort of. There are some technical limitations with using deferred rendering and AA at the same time due to how the GPU works. However the hardware venders have added a lot of work arounds and special modes to do AA almost as well with a deferred renderer as with a forward renderer. But unfortunately the viewer doesn't make good use of them yet.

So if you enable AA in the viewer then in your video card driver's control panel tell it to enhance the program's AA settings things should come out looking good enough, tho not always. YMMV

Link to comment
Share on other sites

Hey guys, thanks for all the responses! I currently use the Phoenix Viewer because for some reason I get poor performance on viewer 2. With this card should I be able to play on Ultra? Do the things you all reccomended still apply to this viewer as well? I did a clean install of Windows 7 64 Bit last night and made sure I installed the latest drivers. Should I enable AA and AF in the viewer itself or in the Nvidia control panel? I can see AA working up until 4X then once I set it to 8X the lines become jagged again. I have an AMD Athlon II X2 215 (2.70 GHz) CPU, and was wondering if that could be bottlenecking the card at all. BTW the pictures that were posted earlier were great! What settings do you use if I may ask. Sorry about all the questions in one post. I forgot to check the forums until just now :smileyindifferent: lol

Link to comment
Share on other sites

I found the Framebuffer Objects (FBO) option in the Phoenix viewer and checked it off. Sure enough this enabled the 8X AA option! Thank you so much Magnus! :smileyvery-happy: I was just wondering if everyone thinks its better to use the AA in the viewer or if the one in the Nvidia control Panel is better, as I had asked in the previous post.

Link to comment
Share on other sites

Glad to hear it's working for you Eros.

You asked, "I was just wondering if everyone thinks its better to use the AA in the viewer or if the one in the Nvidia control Panel is better", and I'd say you should try both.  Currently I have the nvidea control panel set to let the 3D application (SL) decide as I find I get better fps when running SL.  My card however (an 8800GTS) is older than yours, so you might want to try both and see what works best for you.  Make sure you have CTRL+SHFT+1 window open and watch the FPS as you make changes and don't keep any change which cause it to drop.  It's something everyone should do, as seemingly unimportant changes in the viewer's settings can have quite an impact on how well the viewer runs (or fps) and it will be different for everyone.

You also asked about Phoenix and yes, the advice, in regard to this, is the same as Viewer 2.  I tend to use Kirstens Viewer mostly, which is designed for high end graphics cards (so it will run better with yours than mine!)... http://www.kirstensviewer.com/

With your card, as your comp spec is considerably better than the SL recommended comp spec, you can definitely run Phoenix on ultra.  I do, even with my older card, and generally get around 20-30 fps.  I have everything, except terrain and sky, set to ultra.

You mentioned about bottlenecking your cpu and there are two things you can try there to see which works best for you.  I can't remember where it is in Phoenix (somewhere in the advanced tab) but look for an option to tick which mentions threading as this will cause Phoenix to try it's best to utilise all your cores.  However, some have said SL runs better for them when they "force" SL to run on one specific core, which you can do but you must set this every time you start running Phoenix, by starting task manager, right clicking on Phoenix in the Processes tab, select Set Affinity, then leave a tick in the box of one core only.  Phoenix will now run using that core only, until you close it.

Good to hear AA is now working for you, have a fiddle around with your settings, whilst watching your fps and you should be astounded at what your card will handle.  As an example of how well fiddling with things can turn out, my rl friend could not understand how my SL ran much faster and better than his, despite my comp and card being older and less powerful, until he had a fiddle and now manages fps in the 30s to 40s compared to my 20s.

If you're still not happy with how SL is running, IM me and I can talk you through some settings in voice.

Good luck :)

Link to comment
Share on other sites

Thank you so much for everything Magnus! It's nice to have someone who's willing to be so helpful. I will try to mess around with my settings when I get home from class later. I will also send you a friend request, only if that's ok of course! :smileyhappy: I'll report back after I try playing around with the settings as well.

Link to comment
Share on other sites

that why I prefaced the original with "if you want to use shadows", because shadows use the deferred pipeline (and push most of that onto the CPU instead of the GPU =/ ), skipping the normal AA pass sequence. They could eventually support it properly, but we'd probably be looking at a new render engine... again (although I honestly don't see much improvement in this one over the old one).

for people not looking to use shadows, it's probably overkill, since the viewer does handle AA when it's not using the deferred pipeline.

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3835 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...