Jump to content
Chic Aeon

ENVIRONMENT ENHANCEMENT PROJECT (EEP) and current Windlight (R) settings at altitudes

Recommended Posts

I know that the ability to further define the day with Windlight(R) settings will be coming along in the future (EEP), but lately I have noted that my Windlight(R) settings that used to be fine at higher altitudes (1000-4000 meters) seem to have changed although "I" haven't made any changes in the region settings. Ground level seems stable and "as set" back in January. Wondering if this is all my imagination or if something has changed servers side for the upcoming project.  This is on LEA6.  

Yes I am picky about my settings :D.   Thanks for any techie info. Plan on changing as needed so that up in the air is reasonable again (it has turned much darker than originally intended and tested ) and still be OK down on the ground.  

 

Share this post


Link to post
Share on other sites

EEP isn't out yet is it? O_O  (If it is ignore all the stuff below and hide my catnip)

So, as far as I know any parcel based windlight is only done through the TPV parcel-windlight method where you put the environment (and heights) into the parcel description - being TPV only, LL viewer people don't see them.

A change in windlight would most likely be your side.

Since January we have had a new Firestorm Release, but looking at the list of patches there doesn't seem to be anything there related to windlight/atmospheric changes. It is pretty easy to go back to the older version to verify.

If it's darker, then things to consider could also be physical - new monitor, change of desk so you now SL on a different monitor, bumping the contrast knob, changing gamma to suit some new software. (sorry stating such obvious, things I am sure you have checked, please don't kick me :D )

 

Share this post


Link to post
Share on other sites
2 hours ago, Callum Meriman said:

EEP isn't out yet is it? O_O  (If it is ignore all the stuff below and hide my catnip)

So, as far as I know any parcel based windlight is only done through the TPV parcel-windlight method where you put the environment (and heights) into the parcel description - being TPV only, LL viewer people don't see them.

A change in windlight would most likely be your side.

Since January we have had a new Firestorm Release, but looking at the list of patches there doesn't seem to be anything there related to windlight/atmospheric changes. It is pretty easy to go back to the older version to verify.

If it's darker, then things to consider could also be physical - new monitor, change of desk so you now SL on a different monitor, bumping the contrast knob, changing gamma to suit some new software. (sorry stating such obvious, things I am sure you have checked, please don't kick me :D )

 

Yes, none are the issue. Note my tag line in the forums *wink*.  There IS a new issue with DOF (presumable a Firestorm problem). Someone wrote about it a week ago and I have been having the same problems lately (it seems fine and then a minute or so in it just quits and you have NO DOF at all. Very odd and "sometimes" it is fine. No clue there. 

And NO, EEP isn't out yet and no real date as to when. Just seems odd that they are "working on that" and my Windlight settings (region default -- not any of MY settings) seems to be very different at higher altitudes than when I first set it up. It is kind of like the light isn't getting through.  I can make things fine PERSONALLY but  not for everyone and that has been an issue. 

So it is the REGION DEFAULT WINDLIGHT that I am concerned with -- if I wasn't clear. I could check on the Linden viewer but I really hate how the windlight works there so I doubt I could get PAST that angst.   I will just see if I can find something that will work for on the ground and up in the air.  Assuming no one knows what is going on. These are not huge changes but I fiddle with Windlights daily -- sometimes many times -- so I am very sensitive to the subtleties. 

Also note if any of your suggestions were the answer then the GROUND LEVEL Windlight would also be darker -- and it is not; it is fine. 

But thanks for thinking on it!!!!!

:D

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Chic Aeon said:

So it is the REGION DEFAULT WINDLIGHT that I am concerned with

OK! Weird thing, my partner made the same comment, that our regions' day-cycle Windlight looked darker than normal. I didn't see a change though.

There could be something to it.

Share this post


Link to post
Share on other sites

I went to have a look at Lea6.
No parcel windlight is set, so using the custom region windlight set on that region.
I see no difference in the windlight between Firestorm 5.0.7 & Firestorm 5.0.11 - either at ground level or at 4000 M.

On the top platform at 4000 M:

index.png

  • Like 1

Share this post


Link to post
Share on other sites

The only thing I can think of is there's some sky platforms on Lea6.
If you have a low draw distance & shadows enabled, it's possible you are seeing shadows cast by the sky clutter only at certain altitudes.

Callum, can you give me a SLURL to your problem location?

There is one bug that FS had in 5.0.7 that was fixed in 5.0.11 that could affect how windlight looked, but the 5.0.7 viewer was the buggy one.
Details here: FIRE-21306 - Firestorm 5.0.7 (52912) broken windlight using advanced lighting

Edited by Whirly Fizzle
typo

Share this post


Link to post
Share on other sites

OK but would be good if you deleted that photo as it isn't supposed to be public LOL.

Not sure really what is going on. I made some changes to the higher elevations today.  I didn't actually think it was a VIEWER thing -- as noted I was wondering if it was a SERVER thing. Callum brought in the FS part of the equation :D. Thanks for checking.  I do think there was a change from when I set things up as I tested and added lighting FOR the default lighting. Had to add more now. 

But what is -- is. 

:D

 

@Whirly Fizzle

 

Edited by Chic Aeon

Share this post


Link to post
Share on other sites
On 3/9/2018 at 1:04 AM, Whirly Fizzle said:

The only thing I can think of is there's some sky platforms on Lea6.
If you have a low draw distance & shadows enabled, it's possible you are seeing shadows cast by the sky clutter only at certain altitudes.

Callum, can you give me a SLURL to your problem location?

There is one bug that FS had in 5.0.7 that was fixed in 5.0.11 that could affect how windlight looked, but the 5.0.7 viewer was the buggy one.
Details here: FIRE-21306 - Firestorm 5.0.7 (52912) broken windlight using advanced lighting

I do have sky platforms but I had them at the beginning (January) when I set things up including the windlight(R) and all was good then.  I keep my draw distance about 128 meters most of the time and the megaprims are at least 500 meters apart in distance. I CAN see shadows and they are not the shadows of a megaprim (I remember that puzzling issue a decade ago LOL). 

 

MEANWHILE - I wanted to note that I redid the Skies this morning so that it looks better more places and added outdoor lighting to the the night city. Need to make some new street lights and will do that today hopefully. Then I will be set again. 

Still very strange and with no answers :(    My bet is that something changed on the servers. I never thought it was a viewer issue. I guess I better log in on the Linden Viewer though and check the default skies. On my list. 

Edit:

I checked the default days on the Linden veiwer and the skies seemed very similar, but LOOK what happened on the Firestorm viewer to the water. 

Linden Viewer

5aa533c8529d0_waterlindenviewer.thumb.JPG.67368e74ec79f6b2f90f38acccd274c5.JPG

Firestorm viewer :(

So maybe something IS up with the viewer. 

5aa533c963d17_waterfirestormviewer.thumb.JPG.13e2319cd1f662e9a76d2f51ee75ed17.JPG

Edited by Chic Aeon

Share this post


Link to post
Share on other sites

Just an update for anyone withe the same problems.

I had a RL friend check the water at LEA6 using the same version of FS and HE sees the light blue water as it should be. So MY issue is viewer side it seems.

 

Also I noted today that the Windlight I typically use for vendor photos no longer works. This is at LEAST a four month old Windlight setting and I have made no changes. This is on Mainland. It looks from testing that the ANGLES have changed. The light colors are fine and if I change the lighting angles then I can get the same setting that I had up until a month or so ago.  Not sure when it changed but I do remembering having issues with gacha key photos last month so not  a new thing there either.

And its time to move on. Windlights are changed again and hopefully will be OK for awhile. 

 

  • Confused 1

Share this post


Link to post
Share on other sites

EEP is not out yet, but I am typing as quickly as I can. I am nailing down a few last minute changes in the settings asset format. I want to avoid making changes after people begin creating settings in their inventories since that would result in broken skies, settings that do nothing but throw errors, and angry mobs at my window with torches and pitchforks.

As far as I know there have been no changes to the rendering on the release viewer that would change how the windlight settings are displayed. All windlight rendering is done viewer side (the simulator simply tracks the values and sends them down to the viewers.) This will not change once EEP is in your hands, the viewer will still be responsible for rendering. 

(I do think the "black sea" look in the second picture is quite dramatic, by the way.)

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
52 minutes ago, Rider Linden said:

EEP is not out yet, but I am typing as quickly as I can. I am nailing down a few last minute changes in the settings asset format. I want to avoid making changes after people begin creating settings in their inventories since that would result in broken skies, settings that do nothing but throw errors, and angry mobs at my window with torches and pitchforks.

As far as I know there have been no changes to the rendering on the release viewer that would change how the windlight settings are displayed. All windlight rendering is done viewer side (the simulator simply tracks the values and sends them down to the viewers.) This will not change once EEP is in your hands, the viewer will still be responsible for rendering. 

(I do think the "black sea" look in the second picture is quite dramatic, by the way.)

Thanks for the update. Have no clue why I don't see the same water as others, but I have changed all my Windlight(R) settings now and they all work as they "used to". No clue as to why things were different; the skies were dark for other avatars on other machines also as they mentioned it.  It could simply be some viewer conflict with a Windows Update. I have lost the ability to use hot keys in one of my graphics programs so all sorts of things change with we get Windows "improvements".

But we will have NEW things to play with soon. Thanks for that. 

And no, we don't want mobs with pitchforks :D.  Appreciate the official reply. 

 

 

Share this post


Link to post
Share on other sites
On 3/8/2018 at 10:02 PM, Chic Aeon said:

So it is the REGION DEFAULT WINDLIGHT that I am concerned with.

I noticed something like that, too. The region default windlight seems more boring everywhere I go - dull overcast, no clouds, no blue sky. Not talking about New Babbage, either. All the windlight customization works if I set something myself, but default to region settings seems totally blah.

It's a Firestorm thing. If I log in with Alchemy, I see clouds again.

  • Alchemy 5.0.7 (41341) (x64) Nov  9 2017 12:46:34 (Alchemy Release) (B) - clouds and blue sky
  • Firestorm 5.0.11 (53634) Jan 12 2018 11:55:03 (Firestorm-Releasex64) with OpenSimulator support - no clouds.
  • Firestorm 5.0.7 (52912) Jun 13 2017 10:58:03 (Firestorm-Releasex64) with OpenSimulator support - no clouds
  • Firestorm 5.0.12 (53149) Feb 15 2018 22:01:30 (Firestorm-private-john-All-Series) with OpenSimulator support (self-compiled) - no clouds

Share this post


Link to post
Share on other sites
10 minutes ago, animats said:

I noticed something like that, too. The region default windlight seems more boring everywhere I go - dull overcast, no clouds, no blue sky. Not talking about New Babbage, either. All the windlight customization works if I set something myself, but default to region settings seems totally blah.

It's a Firestorm thing. If I log in with Alchemy, I see clouds again.

  • Alchemy 5.0.7 (41341) (x64) Nov  9 2017 12:46:34 (Alchemy Release) (B) - clouds and blue sky
  • Firestorm 5.0.11 (53634) Jan 12 2018 11:55:03 (Firestorm-Releasex64) with OpenSimulator support - no clouds.
  • Firestorm 5.0.7 (52912) Jun 13 2017 10:58:03 (Firestorm-Releasex64) with OpenSimulator support - no clouds
  • Firestorm 5.0.12 (53149) Feb 15 2018 22:01:30 (Firestorm-private-john-All-Series) with OpenSimulator support (self-compiled) - no clouds

Well as I said I see clouds and colors as they should be (not counting the weird water problem) but it is like the East and Time of Day sliders have changed. If I move those around on settings I have made all is OK. 

But whatever we will have a slighting different system soon so we can see what happens then. STICKING is a good thing. Not good to make custom Windlights and then have them morph into something different :D. 

Share this post


Link to post
Share on other sites

Since angle of altitude/azimuth ("time of day"/"angle from east") came up I feel like I should give you a preview on the interface. I'm changing the way these values are set.  I have never been a fan of having two controls that influence a single value. 

The goal is to position either the sun or the moon somewhere on the celestial sphere. An intuitive way to perform this action would a "track ball" with a marker for the sun or moon's position in the sky. Spin the ball and the heavenly body's location above changes.  My hope is this will be easier to use than trying to figure out how many degrees you want to rotate the sun around the sky (and trying to figure out on what axis the rotations will occur.)

 

vtrackball.png

2000px-Azimuth-Altitude_schematic.svg.png

  • Like 4
  • Thanks 3

Share this post


Link to post
Share on other sites
1 hour ago, Jopsy Pendragon said:

Will EEP! be available to mainland parcel owners?  =)

Jopsy, 

Short answer: Yes, EEP will be available on mainland parcels.

Long answer: Land owners will have the option to disallow parcel based environment settings if they desire.  However, I do not believe that Governor Linden will restrict mainland regions in this way.

  • Like 4
  • Thanks 2

Share this post


Link to post
Share on other sites
On 3/15/2018 at 1:01 PM, Rider Linden said:

 My hope is this will be easier to use than trying to figure out how many degrees you want to rotate the sun around the sky (and trying to figure out on what axis the rotations will occur.)

 

vtrackball.png

2000px-Azimuth-Altitude_schematic.svg.png

So if you adjust the position of the moon just right, maybe it will..

5F1C6EB3-18E8-43CA-AD56-2648BF5E52AD.jpeg

  • Thanks 1
  • Haha 3

Share this post


Link to post
Share on other sites

Not to far off from the truth! 

Since you'll be able to change the moon texture in the environments I will be on the lookout for this somewhere:

 

Blog photo 1-2.png

  • Like 2
  • Thanks 1
  • Haha 2

Share this post


Link to post
Share on other sites
1 hour ago, Rider Linden said:

Not to far off from the truth! 

Since you'll be able to change the moon texture in the environments I will be on the lookout for this somewhere:

 

Blog photo 1-2.png

That's too tempting! So many things I could do with that ... maybe a picture of a beneficent landlord so his renters can gaze up at him. ;)

But seriously ... I hope EEP is out soon, and not just for the joke possibilities.

  • Haha 1

Share this post


Link to post
Share on other sites

I have noticed similar issues... when teleporting into, or out of regions using custom windlight settings... I get a "black sky".  Clicking the "Land" button immediately corrects it to the default region setting, but will not change it to a custom altitude setting until I cross the threshold.  Also happening to others I know with the same symptoms.

This is happening on firestorm 5.0.11... have not tried it on the LL viewer.  And it only started last week.

Edited by Aimee Sellers

Share this post


Link to post
Share on other sites
On 3/11/2018 at 1:26 PM, Chic Aeon said:

I do have sky platforms but I had them at the beginning (January) when I set things up including the windlight(R) and all was good then.  I keep my draw distance about 128 meters most of the time and the megaprims are at least 500 meters apart in distance. I CAN see shadows and they are not the shadows of a megaprim (I remember that puzzling issue a decade ago LOL). 

 

MEANWHILE - I wanted to note that I redid the Skies this morning so that it looks better more places and added outdoor lighting to the the night city. Need to make some new street lights and will do that today hopefully. Then I will be set again. 

Still very strange and with no answers :(    My bet is that something changed on the servers. I never thought it was a viewer issue. I guess I better log in on the Linden Viewer though and check the default skies. On my list. 

Edit:

I checked the default days on the Linden veiwer and the skies seemed very similar, but LOOK what happened on the Firestorm viewer to the water. 

Linden Viewer

5aa533c8529d0_waterlindenviewer.thumb.JPG.67368e74ec79f6b2f90f38acccd274c5.JPG

Firestorm viewer :(

So maybe something IS up with the viewer. 

5aa533c963d17_waterfirestormviewer.thumb.JPG.13e2319cd1f662e9a76d2f51ee75ed17.JPG

Hmmm... I just went to your Appoco set and then back to the ground (At the Docks) and the water remained as it was before going up — no darkness.

Running Firestorm 5.0.11 (53634) Jan  9 2018 18:51:07 (Firestorm-Releasex64) with Havok support and...

Graphics Card: GeForce GTX 660/PCIe/SSE2
Windows Graphics Driver Version: 24.21.13.9811
OpenGL Version: 4.6.0 NVIDIA 398.11
Draw distance: 256 m
Bandwidth: 1500 kbit/s
LOD factor: 4
Render quality: High-Ultra (6/7)
Advanced Lighting Model: Yes (shadows enabled)
Texture memory: 1024 MB (1)
Packets Lost: 0/21,423 (0.0%)
June 12 2018 03:34:45 SLT

[EDIT] But... the water isn't blue on Firestorm, as you see it with the official viewer, it's kinda clear crystal.

Edited by MBeatrix
note added

Share this post


Link to post
Share on other sites
1 hour ago, MBeatrix said:

Hmmm... I just went to your Appoco set and then back to the ground (At the Docks) and the water remained as it was before going up — no darkness.

This did go away for me eventually. I changed the settings in the land tab and that "fixed it". As far as I know I was the only one with the issue. Clearing cache didn't help in this case. All very odd. Thanks for the note!   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...