Jump to content
  • 0
Sign in to follow this  
staredsky

PROBLEM WITH AUDIO (MUSIC STREAMING) IN LINUX-UBUNTU

Question

  • 0

If possible try to get the URL for a music stream you cannot hear in SL (but others can) and play it outside of SL on your browser or iTunes (or whatever the Linux equivilant is) to make sure that it its not something with your computer setup as opposed to an SL problem.

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0

If possible try to get the URL for a music stream you cannot hear in SL (but others can) and play it outside of SL on your browser or iTunes (or whatever the Linux equivilant is) to make sure that it its not something with your computer setup as opposed to an SL problem.

Share this post


Link to post
Share on other sites
  • 0

Did you install the proper drivers for your soundcard? I have yet to get my sound working 100% in Ubuntu (10.10) as my soundcard is not fully supported. I installed ALSA and that worked for me I can now hear all sound. Also do me a favor and do this test. Grab the radio URL from the land tab and plug that url on Rythmbox, if you can hear the music there and still listen to SL sounds then you have an identical problem as I did and by installing ALSA it will then work (somewhat).

Share this post


Link to post
Share on other sites
  • 0

Btw chances are that ALSA is already installed in your system. To check this open a terminal and type sudo alsamixer and a volume control interface should open on the terminal and your soundcard should be selected. If this occurs then it means that your driver is preperly installed and also ALSA is installed.

Share this post


Link to post
Share on other sites
  • 0

I did the sudo alsamixer, and as you stated a volume control interface was opened.

I still have troubles with radio url, maybe because my SL internface is in italian. I went to the About land window, but i didn't find any Media tab there.

I found on the audio tab 2 adress:

https://sites.google.com/site/wetwilliesrocks/ I can access it, it is the club webiste, and i can hear from the browser the environment sound. I cannot open the url form rythmandbox

https://66.71.249.242:8016/ i cannot acces in any way to this url.

Maybe may you give me a radio url to do the test?

Thanks for your patient and supporting

Share this post


Link to post
Share on other sites
  • 0

Where you can choose the device is only for voice chat.

When you can't hear music, you should check, if you can hear music with an other player outside of SL.

But reasons can be: When you click the "Play" button and it stays "on" - check the Volume Slider in Linux. It is possible, you have PulseAudio (Ubuntu uses that as "standart" when i am right). There must show up the SL Voice and the SL Viewer itself. Both must be turned up (mabe there appears a slider for the stream too, but i can't remember, this must be up too then). You also can select the output device there.

If the "Play" button turns off again, then your Soundcard is busy with the SL and Voice. Then your Linux should not have the PulseAudio in the system nor ESD. Or ESD isn't loaded. You can start it by typing esd in a xterm. If its start, restart SL and see what happens. If you still have the problem, close SL and look in the startscript where it says: #export LL_BAD_OPENAL_DRIVER=x. Delete the # in front of it. Restart SL. Then it should work.

If you don't have PulseAudio nor ESD, i would install esd (esound-common and esound or similar name), start it by esd in the xterm and make the changes above.

Share this post


Link to post
Share on other sites
  • 0

If you have land where you can change the stream URLs try the one Peewee suggested. Try opening it first from SL (presumably it will not work) and then try it on Rythmbox

Share this post


Link to post
Share on other sites
  • 0

Ok then now what you have to do is what sven already stated below. To get there you have to open the seconlife installation folder and the one file called "secondlife" (this is the file that makes secondlife run similar to window's .exe) when you double click it you will get a popup window and select "display" it will open up a text editor. Delete the # from the line that reads export LL_BAD_OPENAL_DRIVER=x and restart secondlife. It will make your media play from secondlife.

 

ETA: In my case because my soundcard is not supported although this fix does make the the media sound play the sound is distorted. Hopefuly you don't have this problem otherwise you'll have to make sure that Pulseaudio is not active and ALSA is.

Share this post


Link to post
Share on other sites
  • 0

IT WORKS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Thanks to all the people here that patiently addressed me to the solution of the problem.

I really appreciated your help and skill !

 

Share this post


Link to post
Share on other sites
  • 0

First question: are you running 64-bit Linux, or 32-bit?

The Linux SL client uses gstreamer for streaming audio; make sure you have the gstreamer codec libraries installed.

Linden Lab has yet to produce a 64-bit native version of the client; ia32-libs is great as far as it goes, but doesn't help for streaming audio. From archived forum messages, apparently Fedora has packages that will let you install 32-bit gstreamer libraries on a 64-bit system so 32-bit programs can get to them. I as an Ubuntu user am apparently out of luck until LL or a third-party does a real 64-bit client for Linux; Imprudence does, and streaming audio works great on it--but it's 1.x based, and thus is very lacking in graphics capabilities that one may be accustomed to (deferred rendering aka shadows, for one).

Share this post


Link to post
Share on other sites
  • 0

hi,

this simple command line helps without fiddling around with broken libraries and foreign packages - just enter it in a terminal before starting the second life client:

tail -f ~/.xsession-errors|gawk '/Starting internet stream:/ {system("vlc "$7" & ")}'


this simply opens media in external player (vlc, which u have set in option to allow only single instance, but this is default afaik), when second life client tries to play it unsucessfully ...

 

cu!

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with Ubuntu. when i teleport somewhere for ex. Cloud nine i cannot hear the music there. i have to copy the url and play it in a seperate player.

tried allmost everything without any results.

could somebody tell me how to get this fixed, and dont forget im pc blond nearly zero plan.

Share this post


Link to post
Share on other sites
  • 0

I run the 64 bit version of openSUSE 11.4 with GNOME and have the same issue. Everything works accept steaming music. I have all of the 32 bit Gstreamer libraries installed. The only viewer that allows me to hear streaming music is the 64 bit version of Imprudence, which is a true 64 bit viewer (currently the only 64 bit viewer available).

Hey Linden Research, if you are listening, please develop 64-bit versions of your viewers, starting with the Linux viewer! It is time!

 

My basic configuration:

Second Life 3.0.0 (238864) Aug 18 2011 19:32:37 (Second Life Release)
Release Notes

CPU: AMD Phenom II X4 810 Processor (800 MHz)
Memory: 8001 MB
OS Version: Linux 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 285/PCI/SSE2

OpenGL Version: 3.3.0 NVIDIA 275.21

libcurl Version: libcurl/7.21.1 OpenSSL/1.0.0d zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: KDU v6.4.1
Audio Driver Version: OpenAL, version 1.1 ALSOFT 1.11.753 / OpenAL Community / OpenAL Soft: PulseAudio Software
Qt Webkit Version: 4.7.1 (version number hard-coded)
Voice Server Version: Not Connected
Built with GCC version 40103

Share this post


Link to post
Share on other sites
  • 0

I'm running 64big Fedora 17, and the suggestion about tailing the session error log was almost perfect.  The only thing that would've made it better is if it could kill the previous stream... and not pop up the window, so I made a slight change to the command:

tail -f ~/.session-errors | gawk '/Starting internet stream:/{system("killall -KILL vlc ; cvlc "$7" &")}'

 

cvlc doesn't use a UI and killall uses the name to kill rather than having to know the PID.


The only thing it doesn't do, and I'm not sure how in-world behavior is, but as soon as it opens the stream, it's at a set volume.  It's not quieter farther away.


Hope this helps everyone from the future that comes looking for this information. :)  Hi Future People! *wave*

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...