Jump to content
Venompapa

512mb texture limit in the 64bit SL Viewer? 5.1.0(511732)

You are about to reply to a thread that has been inactive for 251 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Do im missing something here?

nShcmAB1TmWmExuXkCMvpg.png

Ive tried also change it from the debug settings but its keep jumping back to 512 -_- its like come on, im only at my skybox and textures keep blurring out like mad. 512 mb is not enough for anything if Advanced Lighting Model enabled becuase all the extra normal map/specular map on mostly everything by now.

So im just wondering if they will raise this later? Couldnt find any jira post about this.

Share this post


Link to post
Share on other sites

Yeah, I tried the LL 64-bit viewer with high hopes, but also discovered that they hadn't yet increased that limit.  I had just assumed the 512 cap was specific to their 32-bit version and that they would expand it when they created the 64-bit one.  I prefer Firestorm due to other features, but was checking out the LL viewer as a possible alternative for when I wanted two viewers logged in at the same time - I think the LL one is a bit lighter on system resource usage.  However, the texture cache limit killed that for me. 

Share this post


Link to post
Share on other sites

Looks as though people are confused.

The viewer all use some of the RAM on the graphics card for storing textures, the rest gets used for image generation. There days the top end graphics cards have huge amounts of RAM, I see some have 6GB, and Firestorm, long since, increased the maximum possible to use for texture storage. It's a trade-off.

It would be nice to have the choice, but if your graphics card has less that 1GB of RAM this old limit isn't your problem.

Share this post


Link to post
Share on other sites
5 hours ago, cykarushb said:

this, i could really use that extra 256mb of vram

Untitled.png.935fd5e6d6c03c0cd1316c59a4d3bcdd.png

Yes, my graphics card has 1GB VRAM as well and the extra 256MB makes a lot of difference when using Firestorm. I rarely experience any texture thrashing. I haven't really noticed it with the 64bit SL Viewer yet, but I also don't run it for any length of time, usually just long enough to test something and switch back and forth. 

I imagine it's on the roadmap but perhaps wasn't a priority. Getting the new SL Launcher to behave has been and continues to be a challenge. 

Just as a general comment, one thing that most certainly helps to cut back on texture thrashing is less HUDs. Particularly mesh body HUDs. Certain brands *coughs* use a horrendous amount of oversized textures.  If using Firestorm, go to the Developer Menu (Ctrl Alt Q to open) - Render Metadata - Texture Size. If you're seeing a lot of 1024x1024 and even 512x512 sized textures on tiny little buttons, just imagine all those eating up your memory and holding on to it until you logout. 

 

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, LittleMe Jewell said:

Yeah, I tried the LL 64-bit viewer with high hopes, but also discovered that they hadn't yet increased that limit.  I had just assumed the 512 cap was specific to their 32-bit version and that they would expand it when they created the 64-bit one.  I prefer Firestorm due to other features, but was checking out the LL viewer as a possible alternative for when I wanted two viewers logged in at the same time - I think the LL one is a bit lighter on system resource usage.  However, the texture cache limit killed that for me. 

I do usually oinly keep an eye on the LL viewer because a bunch of my friend finds the firestorm too complicated for their use, although i always kept telling them use the 64 bit firestorm because can use higher texture memory settings unless their graphics card not have enough VRAM.

My graphics card has 4gb memory and i has the texture memory setting up all the way at 2048mb, usually at a crowded club its eats up around 1200-1400mb memory, so even just 1024 not really enough in some case, and even just sitting at my empty space station skybox its eating up around 700mb of texture memory because all the extra specular and normal map textures on everything, if i turn off the advanced lighting model at my skybox its only using like 250mb or so. If i log my alt in at my home from the LL viewer all i see is random textures keep blurring out all the time and its cant manage to keep everything loaded unless i turn off the advanced lighting model, okay not everyone can use ALM because older computer but if someone can they should not have bad experience by the all blurry textures. Ive tested most of this without any huds attached, but thats another reason why i has the texture memory up to 2048 so i dont have to worry about my huds :D

So i just dont get the LL logic, they should have knew bringing in the materials update eventually will multiply the textures on the most scene by 3 which means more texture memory is required to render everything correctly, but ah well, hope they change this soon.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/28/2018 at 5:52 PM, Willow Wilder said:

Yes, my graphics card has 1GB VRAM as well and the extra 256MB makes a lot of difference when using Firestorm. I rarely experience any texture thrashing. I haven't really noticed it with the 64bit SL Viewer yet, but I also don't run it for any length of time, usually just long enough to test something and switch back and forth.

3GB

780new.jpg

Edited by iceing Braveheart
  • Confused 1

Share this post


Link to post
Share on other sites

1080 Ti with 11 Gb vid memory here. I always have to keep the limit to around 1 Gb for textures, though, or the viewer will just crash. Is there any chance that the SL viewers will support higher mem settings in the near future?

Share this post


Link to post
Share on other sites

I hope this clears some confusion going on

Viewer Texture Memory Buffer (MB): This is the amount of graphics memory the viewer will use. By default, it is set to the size of your graphics card's memory.

32bit versions only. This setting is hard limited to a maximum of 512MB. Lowering this value may resolve certain texture corruption and performance issues, but under normal circumstances you should not need to alter this setting.

64bit versions only. This setting is hard limited based on the VRAM available with your graphics card. It is recommended you increase the slider to use the maximum available to prevent texture thrashing.

GPU 1GB = up to 768MB

GPU 2GB+ = up to 1024MB

GPU 4GB+ = up to 2048MB

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 251 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...