Jump to content

The in-game web browser is very slow or doesn't load any URLs


NJMike
 Share

You are about to reply to a thread that has been inactive for 3830 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Some SL-URLs that I open up within the in-game browser either take an extremely long time to load, or never load at all. Sometimes too if it does load, after a minute or so all the content from the website just disappears in the browser and I have to refresh the page to get everything back up again. I can access these SL-URLs in Google Chrome just fine, but the in-game brower is just awfully slow sometimes.

Also, the marketplace never loads on the in-game browser or Google Chome, but it loads in FireFox fine -- any help?

Link to comment
Share on other sites

several of those pages require javascript, cookies, AND plugins to be enabled... search and the home tab both require all three now... so if you have any of those disabled in preferences, that's why they don't work.

even without that though I agree it's still rather slow and the webkit parser doesn't obey some standards (like defer attributes in script tags)

Link to comment
Share on other sites

I don't know that anyone that I know in SL uses it. Even for the brief time that I gave Viewer 2 a try, I couldn't rely on it to bring up web profiles, and so opened them up in Firefox instead.

This isn't a problem that only SLs in-game browser has. EVE Online, which I've played while on hiatus from SL, had the same kinds of issues. Noone there used that one, either. :smileyvery-happy:

Link to comment
Share on other sites

Hi, I get much better performance from the internal browsers if I reduce the debug setting PluginInstancesCPULimit to about 0.5, I think the default is 0.9. This tells SLPlugin to run at a lower priority, so that the viewer gets an opportunity to communicate with it. I have seen this change help on Windows and Mac, I don't know if it would have the same effect on Linux but I suspect it could.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 3830 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...