Jump to content
Sign in to follow this  
Raystorm Aeon

Exporting with Avastar fails

Recommended Posts

I have this detailed character that i've cut into parts to fit the vertexes limit. Only the head and the left chest got exported. The rest of the parts gives me errors like:

"HandPinky0Left" not into the list

"HandThumb0Left" not into the list

"HandMiddle0Left" not into the list

1 specific error per 1 part

Then there are the right side errors which are the same errors only "Left" is replaced with "Right".

Share this post


Link to post
Share on other sites

Check the vertex groups. I don't know for sure, but Avastar might be telling you that you have extraneous vertex groups that would prevent the mesh from uploading as skinned. First of all, vertex groups for regular joints should always begin with "m", so in your case

On 1/16/2018 at 12:00 AM, Raystorm Aeon said:

"HandPinky0Left" not into the list

should be like mHandPinky0Left, BUT there's no zero joint in the bento skeleton, the first joint in that chain is mHandPinky1Left. So that's what i think you should be hunting down:

check whether you have these vertex groups in the same format as this mHandPinky1Left;

if you do have these, delete the ones that earlier got you the error

if you do NOT have those, but it looks like it's a naming mistake, just rename accordingly.

Share this post


Link to post
Share on other sites
1 hour ago, OptimoMaximo said:

Check the vertex groups. I don't know for sure, but Avastar might be telling you that you have extraneous vertex groups that would prevent the mesh from uploading as skinned. First of all, vertex groups for regular joints should always begin with "m", so in your case

should be like mHandPinky0Left, BUT there's no zero joint in the bento skeleton, the first joint in that chain is mHandPinky1Left. So that's what i think you should be hunting down:

check whether you have these vertex groups in the same format as this mHandPinky1Left;

if you do have these, delete the ones that earlier got you the error

if you do NOT have those, but it looks like it's a naming mistake, just rename accordingly.

Thank you. I deleted the vertexes shown. It works now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...