Jump to content
Snodge Snoodle

How do I stop my invisible avatar casting shadows?

You are about to reply to a thread that has been inactive for 971 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

So I have a full alpha layer hiding my avatar but there is still a shadow being cast on the floor showing a human outline. Am I able to hide the shadow somehow without using an animation to stuff my transparent carcass under ground?  I don't really want to use an animation because its not really stopping the shadow being cast when I fly or jump.

Share this post


Link to post
Share on other sites
14 minutes ago, Snodge Snoodle said:

Am I able to hide the shadow somehow without using an animation to stuff my transparent carcass under ground?

Only go out at night...
 

  • Haha 1

Share this post


Link to post
Share on other sites
50 minutes ago, Snodge Snoodle said:

So I have a full alpha layer hiding my avatar but there is still a shadow being cast on the floor showing a human outline. Am I able to hide the shadow somehow without using an animation to stuff my transparent carcass under ground?  I don't really want to use an animation because its not really stopping the shadow being cast when I fly or jump.

Create a new alpha. Instead of dragging textures into the texture slots, click the small check boxes next to the  texture slots so that they're all selected. The check box will completely shut off rendering for those parts of the avatar and you'll cast no shadow.

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, Theresa Tennyson said:

Create a new alpha. Instead of dragging textures into the texture slots, click the small check boxes next to the  texture slots so that they're all selected. The check box will completely shut off rendering for those parts of the avatar and you'll cast no shadow.

Thanks, but my shadow is still showing :(

Still have a shadow.JPG

  • Sad 1

Share this post


Link to post
Share on other sites
2 minutes ago, Snodge Snoodle said:

I'm using Firestorm. I have re-worn the alpha layer and the shadow is still there.  

I'm stumped.

Check your shadow settings. I know Firestorm has various settings for avatar shadows that were meant to reduce the performance hit caused by rigged mesh avatars and the one you're using may be bypassing the code that makes a full-body alpha work.

  • Like 1

Share this post


Link to post
Share on other sites

Theresa gave you the correct solution above.

But the avatar shadow will still show if you have Avatar Shadows set to "Simplified" under Preferences -> Graphics -> General

9847a8a44054791855f6dfdeaf44310b.gif

 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Snodge Snoodle said:

Thanks for the video, but The whole idea of having an invisible avatar will never work because I cant control other peoples settings.

no and thats a good thing... a totally invisible avatar would be the best tool there is for griefers and others with nasty plans.

Perhaps a bit unconvenient for you.. but a good thing.

Share this post


Link to post
Share on other sites

I cant hide my name tag so greifing would not be anonymous anyway. 

I was planning on wearing a small object connected to my avatar center and just hide my avatar. If you can still see my human shaped shadow then it defeats the purpose and ruins the effect.

So I am forced to give up.

Thanks everyone

Share this post


Link to post
Share on other sites

I've dropped an alpha to your profile.  This one is not showing my shadows when I wear it.

 

ETA - Nevermind.  As Whirly said, if I chance my "Avatar Shadows" setting from Optimized to Simplified, the shadow does indeed show.

 

 

Edited by LittleMe Jewell

Share this post


Link to post
Share on other sites
2 hours ago, Snodge Snoodle said:

I was planning on wearing a small object connected to my avatar center and just hide my avatar. If you can still see my human shaped shadow then it defeats the purpose and ruins the effect.

 

May be i'm wrong, but for what i experimented myself if you're wearing an object then you'll get the shadow of this object.

I guess the viewer absolutely needs something to display when shadows are activated, so during your tests if you're wearing nothing then viewer uses the default human shape to reflect a shadow.

 

 

A friend wearing my robot avatar, you can see the shadow, it's clearly not a human shape ;)

5a2d7866dcce6_Ke-CubeRobot.png.95d54997d5f255db5ea5b9d07272ec01.png

 

Share this post


Link to post
Share on other sites

/me facepalms...

I'm stunned at how many people who should know better, actually think that ANY setting in THEIR graphics preferences will have ANY effect on what other people's viewers display.

As for the suggestion that you can control what other people see by choosing a specific viewer, and more especially, one of the WORST viewers, Frankenviewer...

Dark Gods of the Grid give me strength!

Like I said, if you want to sneak around as a shadowless spooky invisible person, ONLY GO OUT AT NIGHT. :) 



 

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, Klytyna said:

Like I said, if you want to sneak around as a shadowless spooky invisible person, ONLY GO OUT AT NIGHT. :) 

Not to forget to rent your own parcel/sim, where you can force the windlight settings for all visitors.

  • Haha 1

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 971 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...