Jump to content
Sign in to follow this  
Sciuriadi

My physics mesh is tiny!

Recommended Posts

I am currently in the process of building myself a house. All is going nicely apart from the physics. I modelled a simplified version of my building that was simply the floor plan extruded up with as many faces killed from it as possible, leaving only openings for doors. Scale seems to be applied to everything however the physics mesh is showing as a tiny model in the far corner which is rather bizarre. Basically it is about 1/50th of the size it needs to be. 

Well I got it to the right size, looks perfect on preview, but still doesn't work properly. I set to prim but there's loads of random bits blocking my path. Also a lot of times the physics mesh simply doesn't register and I have no option to set physics as prim. Is there something I am missing???? From what I can tell I am doing everything correctly. So far am in the early stages of the build and testing as I go, but at this rate I am so tempted to simply give up. This seems impossible to figure out....

 

Edited by Sciuriadi

Share this post


Link to post
Share on other sites

Hi :)

There are two rules you must comply with when creating a Physics mesh model for your Visual mesh.

Rule N°1:  Each mesh object has to have its own Physics mesh.

Rule N°2 : The bounding box of the Physics model ( X, Y, and Z dimensions ) must equal the bounding box dimensions of the visual model.   If it doesn't then the mesh uploader will stretch or squish the Physics model untill it does fit the visual model. 

 

Are you sure that you have followed rule N°1 ?

In the image below  I have created a building. It is a collection of 16 mesh objects. (each coloured differently)

The Physics mesh is a single mesh object.

59d3d114b2a2e_16objects1Physmodel.thumb.png.b0c74ba0e3d2e7cd6f61e55894c9cc10.png

 

I have selected all 16 objects that make up the building and exported as a.dae file.

I have exported the Physics mesh again as a .dae file.

In the mesh uploader I upload the building and then load up the Physics model.

59d3d1e648bd2_Uploaderpreviewwidow.thumb.png.585d8d3ca9caa95108cfc29f5c70e2d3.png

The Uploader only finds a single Physics object and assigns it to one of the visual mesh objcts. Notice how the Physics model has been squished to fit the bounding box size of that particular object.

If your preview window looks like this then you have several options.

1:  In your 3D modelling programme join all (or some) of those objects together so that they are single mesh object then create a Physics model that fits that single object. Export and upload like that.

2: Create a seperate Physics model for each of the objects that make up your building and upload each object one at a time.

3: Same a 2 but upload all the visual objects and all of the physics models together. To do that you need to follow a strict naming convention.

      example:

        Visual mesh objects                      Physics models

                Object1                                    Object1_PHYS

                Object2                                    Object2_PHYS

                Object3                                    Object3_ PHYS

 

https://community.secondlife.com/knowledgebase/english/uploading-a-mesh-model-r274/Section_.4.1

 

For a building as in the example above I would join all 16 objects into a single mesh object and export like that.

 

Edited to add:

I just noticed that you said, " Well I got it to the right size, looks perfect on preview, but still doesn't work properly. I set to prim but there's loads of random bits blocking my path. "

Could it be that you are Analyzing a Physics model when it doesn't need to be analyzed ?

See this thread from yesterday 

 

 

 

Edited by Aquila Kytori
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

Wow, that's a nice and detailed explanation. Found that my problem was separate objects within the collada file. Once they were all joined together it worked like a dream. Thank you so much :). 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...