Jump to content
Blaze Nielsen

The new Mac High Sierra TOS problem

Recommended Posts

Ive been running the new  Mac OS High Sierra in SL and all seems to work just fine. except for one glitch. In logging in an old alt I was required to click acceptance for the TOS. This does NOT work in either the sl viewer or firestorm viewer. So you can't activate your avatar without pushing the accept TOS button ( which doesnt work). A workaround is to log into secondlife.com and click the TOS button there, which works.

 

  • Thanks 3

Share this post


Link to post
Share on other sites

If you are experiencing this problem and haven't yet logged into Second Life since accepting the Terms of Service on the website, I'd like to ask for some help in finding the cause of this bug. We need the community's help in tracking this bug because it is rare and has not reproduced for us on demand.

1) Please file a bug in jira.secondlife.com and title it [Mac] TOS not loading

2) Please zip up your viewer logs folder and attach it to the jira issue using More Actions -> Attach files. This page tells you where to find the logs folder: http://community.secondlife.com/t5/English-Knowledge-Base/How-to-report-a-bug/ta-p/733545#Section_.3

3) Note which Antivirus you are currently using.

Thank you!

  • Like 1

Share this post


Link to post
Share on other sites

I just updated, unfortunately, to High Sierra, and my SL won't load, doesn't rezz things, is basically a mess.  But one or two times, it has acted normally.  I'm so discouraged as I've been told to revert to the old OS would be like murdering my Mac, so I think that's off the table.  :( 

betsybb/Bubble

Share this post


Link to post
Share on other sites

I asked for help and generally got instructions about redoing my inventory?  She called it a "Flat Inventory."  But I have no issue with my inventory loading!  I'm crashing and can't rezz blah blah, but my inventory comes right on, and is loaded right away.  But having large numbers of folders located directly beneath the root folder causes issues?  I have no idea... She wants to disassemble my whole inventory and have me rezz certain things in a sandbox somewhere....... I'll just stay off SL till somebody fixes something.....

Share this post


Link to post
Share on other sites
10 hours ago, betsybb said:

But having large numbers of folders located directly beneath the root folder causes issues? 

Yes it can.
Was it Linden Lab support who asked your permission to run inventory fixes to de-flatten your inventory?  If so, give them permission.
Support have tools that can check if your problems are likely to be caused by a flat inventory structure. They can easily fix this. If this IS the problem, nothing is going to get fixed unless you give them permission to run the fixes.
You will not lose any inventory - all that will happen is folders with too many items in will have the content split up into several sub-folders.

If your problem is caused by having a flat inventory, your login time will be so slow that it times out. It will usually appear that you got successfully logged in but you won't be able to move your avatar (apart from turn it) & within a couple of minutes at most you will be disconnected with a message similar to "You have been logged out of Second Life. View IM/Quit".

One way to test if a flat  inventory structure IS the problem is to clear cache & see if that gives you a successful  login. If you don't have any problems logging in on a clean cache then it's pretty much certain to be a flat inventory issue.

Your inventory may not be the problem, maybe it is caused by the High Sierra update, but if support told you your inventory needs de-flattening, then let them do it & see how things are after that.

 

Share this post


Link to post
Share on other sites

Thanks Whirly!  I just don't know why that the instant I put High Sierra on my Mac, the problem began.... so If I have a flat inventory, why hasn't it caused problems in 7 years?  I took my inventory down to half of what it used to be, and everything was fine until I "upgraded" to High Sierra, which I should have checked, but I didn't, and it has major problems with being compatible with SL..  :(  What are your thoughts on the trouble only beginning at the exact moment I upgraded?  Thanks for you insight!

 

Bubble

 

Share this post


Link to post
Share on other sites

It may be High Sierra causing the problem & not your inventory, I don't know.
Was it Linden Lab support who told you that you needed to get your inventory deflattened?

Share this post


Link to post
Share on other sites

I am having the same trouble as you betsybb - I'm thinking the 'upgrade' to High Sierra was a big mistake - and all my problems began at that moment - a low frame rate, incredibly slow rezz times, crashing all the time, plus my avatar looks so much worse than it did before. 

Share this post


Link to post
Share on other sites

UPDATE: 

A friend suggested I should re-install Firestorm and after doing this I've experienced a significant improvement to my previous experience with High Sierra. Whether it's just a coincidence or not remains to be seen, but so far so good - fingers crossed :)

  • Like 1

Share this post


Link to post
Share on other sites

I'm also having the same problem since installing High Sierra. I have reinstalled (clean install) Firestorm twice. Out of desperation, I installed the latest LL viewer and had the same problem. I am really discouraged ATM.

 

Share this post


Link to post
Share on other sites
On 08/12/2017 at 1:07 PM, Ansel Artful said:

I'm also having the same problem since installing High Sierra. I have reinstalled (clean install) Firestorm twice. Out of desperation, I installed the latest LL viewer and had the same problem. I am really discouraged ATM.

 

Hi Ansel. For Firestorm, did your clean install include deleting settings and cache, as well as a new installation of the viewer?

If not, try that next. Full Clean Install

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...