Jump to content

Physics mesh not working


Mavia Hian
 Share

You are about to reply to a thread that has been inactive for 1420 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'm trying to create a room with doorways and walls and have it behave as you'd expect.  I have a separate very simple physics model.  It looks great in the preview window: the yellow collision areas are right where they should be.  When I upload it, SL seems not to use this physics model, but to create its own that envelops the object.  Since it's a room, this means it makes a big cube you can't enter.

I attach pictures of the room (in SL) and the physics model (in Blender).  

The room is in two parts-- floor and walls.  The floor part is OK.  

The physics model shown is just planes, but I've tried cubes and they don't work either.  When I had the walls and floors together, same thing. 

Is there any way to tell SL to really, really use the physics model I provide?

 

 

 

room-1.png

room-2.png

Link to comment
Share on other sites

Also you seem to be missing all the curved area in your physics model. If that is a one piece building you will need to include THAT also.  Actually looking  closely your physics model doesn't seem to mirror your building upload. That too could be part of your issue.

Remember to apply location, rotation and scale to BOTH building and physics.

 

Good luck!

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1420 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...