Sign in to follow this  
Mavia Hian

Physics mesh not working

Recommended Posts

Mavia Hian    0

I'm trying to create a room with doorways and walls and have it behave as you'd expect.  I have a separate very simple physics model.  It looks great in the preview window: the yellow collision areas are right where they should be.  When I upload it, SL seems not to use this physics model, but to create its own that envelops the object.  Since it's a room, this means it makes a big cube you can't enter.

I attach pictures of the room (in SL) and the physics model (in Blender).  

The room is in two parts-- floor and walls.  The floor part is OK.  

The physics model shown is just planes, but I've tried cubes and they don't work either.  When I had the walls and floors together, same thing. 

Is there any way to tell SL to really, really use the physics model I provide?

 

 

 

room-1.png

room-2.png

Share this post


Link to post
Share on other sites
arton Rotaru    545

You will have to set the Physics shape type: Prim under the features tab of the build floater. By default each mesh is set to Physics shape type: Convex hull.

Share this post


Link to post
Share on other sites
Chic Aeon    1,460

Also you seem to be missing all the curved area in your physics model. If that is a one piece building you will need to include THAT also.  Actually looking  closely your physics model doesn't seem to mirror your building upload. That too could be part of your issue.

Remember to apply location, rotation and scale to BOTH building and physics.

 

Good luck!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this