Jump to content
  • 0
Sign in to follow this  
Guest

Is there a way to play a sound file louder? I have a script to play the file, but its quiet...

Question

  • 0

The volume on a sound file is always loudest when you (or your camera position, actually) are closest to the source.  It drops off with distance, just as it does in RL.  You can only increase the maximum volume to the limit set by LSL in the llPlaySound function.  If it's already set to 1.0, your only option is to re-record or readjust the volume level in the original sound file and upload a fresh copy.  Assuming that you have full permissions for the sound file, or that it's already on your computer, you can do that editing with any standard sound editing program.

If th volume already OK when you are standing next to the source, you can also try rewriting your script to make the source prim a master sound source (using llLoopSoundMaster) and then set up extra sound sources that use llLoopSoundSlave to sync with the master prim.  That's like having auxiliary wireless speakers in your living room to pipe the sound to you from several directions at once.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

The volume on a sound file is always loudest when you (or your camera position, actually) are closest to the source.  It drops off with distance, just as it does in RL.  You can only increase the maximum volume to the limit set by LSL in the llPlaySound function.  If it's already set to 1.0, your only option is to re-record or readjust the volume level in the original sound file and upload a fresh copy.  Assuming that you have full permissions for the sound file, or that it's already on your computer, you can do that editing with any standard sound editing program.

If th volume already OK when you are standing next to the source, you can also try rewriting your script to make the source prim a master sound source (using llLoopSoundMaster) and then set up extra sound sources that use llLoopSoundSlave to sync with the master prim.  That's like having auxiliary wireless speakers in your living room to pipe the sound to you from several directions at once.

Share this post


Link to post
Share on other sites
  • 0

If you have the volume at 1.0, then it's at the highest it'll go. If not, then set the volume at 1.0. You may also consider increasing the volume on the sound file. Download Audacity (it's free and open-source), install it, open up Audacity, import the sound file, then set the volume slider for the sound track slightly to the right. Save the file as WAV. Upload to Second Life then play it in-world. The sound should be louder.

Share this post


Link to post
Share on other sites
  • 0

There is an unpublished mod to sound files. If you change the name of the sound file to add a + or a ++ it increases the sound inworld. Also adding a - or a -- will decrease the sound. Try it! It works.

Share this post


Link to post
Share on other sites
  • 0

The wrong answer is to make your gesture or script play the same sound multiple times in a row.  People suffering from network lag will hear it echo loudly instead of hearing it louder.  That said, please be considerate of other people's eardrums; louder isn't always better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...