Jump to content

Rigging T-Pose Skeleton to SL-Avatar Mesh - Problems (please help)


Refja
 Share

You are about to reply to a thread that has been inactive for 1567 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Dear Animators,

I want to use some bvh animations, apply them to a SL-Avatar with skeleton and upload them.

To retarget the bvh files I use Ikinema Webanimate. If I retarget my bvh file to the Standard T-Pose skeleton from SL (bvh file) it works fine. I can load the exported file into Bvhacker crop&knit, set the T-Pose again and upload the file with no problems.
But I don`t want to just see the skeleton, I need to see a character doing the pose as I need to make some adjustments in Ikinema (want to use two avatars so I need to see if I need to adjust hands, etc).

To do that I took the .blend file from "Second Life Avatar Skeleton", removed the skeleton that came with it (as it does not work (like with my rigged avatar) and has lots of points I do not need, the standard t-Pose SL skeleton is good enough for me), then applied the Skeleton from the SL T-Pose file (ctrl-p -> apply with automatic weights). So far this works in Ikinema: I can retarget the file and see it animated correctly but when I load it into Bvhacker and crop&knit and apply the T-Pose again the T-Pose is totally deformed. The same in SL, also with the Ikinema file if I try to upload it with the T-Pose it has from the beginning/as default.

What am I doing wrong? What am I missing?

Attached three pictures with the problem, one from Bvhacker, second how it looks in SL and third how my setup looks in Ikinema (blue avatar is the SL-Avatar with the T-Stand skeleton / working).

Before you point me to Avastar, I have bought Avastar but for different reasons (retargeting a bunch of bvh files, easy making adjustments in Ikinema, fbx (bvh) files for blender needs to be converted) I need to use Ikinema.

Could someone help me, or as ultima ratio send me two correctly rigged avatars (male & female as fbx) with the (old) T-Pose Skeleton?

 

wrong-t-pose_01.jpg

sl_wrong_01.jpg

ik_avatar.jpg

Edited by Refja
Link to comment
Share on other sites

Hi,

and thank you for your reply!

This is because I want to save me the step to bring them over to another program again. It works with the skeleton only without problems, but when I rig (ctrl+p -> automatic weights within blender) it to the mesh model and export it as fbx to use it in Ikinema it does give me the error shown in the pictures above. So I figured it has something to do with the mergin of the avatar-mesh and the skeleton file and it maybe is something really simple that I do oversee.. Also to see an avatar deformed like that maybe means something, that it may is a known error people make, like something with orientation, or so..

No ideas at all what it could be?

p.s.: bringing the "faulty t-pose" export to avastar and exporting it from there as final does work.

Edited by Refja
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1567 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...