Jump to content

Clearing Cache SECOND LIFE VIEWER


Chic Aeon
 Share

You are about to reply to a thread that has been inactive for 1463 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Well this is embarrassing!  

I got a note back from support just now about the corrupted inventory files (another post).  It said I needed to log in with the Linden Viewer, clear cache. Log out and in again in Debug1 or 2 (I am in 2 ^^) and stay there for 20 minutes. 

Maybe some magic will happen :D

BUT

I went into preferences and cleared my viewer cache. I didn't see any way in there to clear my inventory cache like in Firestorm. The support note didn't explain HOW or which cache to clear since of course I am OLD and should "know how". And I do, just not in the official viewer. Searching Google and knowledge base gives me no answers for the Linden viewer, only for Firestorm even when I type in Linden Viewer LOL.

So do I need to manually go in and clear my cache through the Windows Explorer like you would do with a clean install in FS?   Imma thinking maybe yes.

Meanwhile I will go do some real life stuff.  

Thanks of Linden Viewer folks :D

 

Link to comment
Share on other sites

I never heard of a special inventory cache. Probably Firestorm has a button to delete just the inv.gz file from the regular cache location.

In the official viewer Clear Cache will delete that file as well. If you want to clean out the cache folder manually, just copy the path from the window where you cleared your cache, and paste the path in the address line in Windows Explorer.

  • Like 1
Link to comment
Share on other sites

7 minutes ago, arton Rotaru said:

I never heard of a special inventory cache. Probably Firestorm has a button to delete just the inv.gz file from the regular cache location.

In the official viewer Clear Cache will delete that file as well. If you want to clean out the cache folder manually, just copy the path from the window where you cleared your cache, and paste the path in the address line in Windows Explorer.

OK. I used the "clear cache" button but it didn't seem to clear my cache so I JUST (you weren't fast enough LOL) went in an deleted it all manually in theory causing it to rebuild. I am NOT sure what I am looking to happen though. The olden days of waiting for your inventory to reload are gone. So far I am not seeing any obvious changes in my inventory so it either worked or didn't I guess. Will stand around for awhile AGAIN just to make sure :D

But what can be done is apparently done and maybe a few things came back. 

Thanks!

 

PS a couple minutes later.

I did go and check on a corrupted texture that I found the other day and it was working again. Not a big deal, but that is the only thing that I actually knew was bad. So "something" apparently got fixed. How much I have no clue :D.   

 

Edited by Chic Aeon
Link to comment
Share on other sites

1 minute ago, Chic Aeon said:

OK. I used the "clear cache" button but it didn't seem to clear my cache

But you did logout after clicking the button right? :SwingingFriends: It's clearing the cache on the next viewer start. But manually deleting the files is the fast and easy way anyway.

Good luck getting back the missing stuff.

Link to comment
Share on other sites

Just now, arton Rotaru said:

But you did logout after clicking the button right? :SwingingFriends: It's clearing the cache on the next viewer start. But manually deleting the files is the fast and easy way anyway.

Good luck getting back the missing stuff.

Yes, as a gooooood girl I followed the instructions in the email perfectly (even going to Debug2 where there IS by the way an avatar fixing kit == good to know).

I also while in the Linden viewer figure out how to increase the UI size (thank goodness as I have a high resolution monitor). So that was a plus. But Aquila has (tried) to teach me planes physics so perhaps I won't need to be in the Linden viewer again LOL.  

Thanks again.    What comes back or gets fixed does. It is what it will be. Most of my important stuff is rezzed (the BEST plan IMHO).

 

 

 

  • Like 1
Link to comment
Share on other sites

1 hour ago, Chic Aeon said:

Well this is embarrassing!

I got a note back from support just now about the corrupted inventory files (another post).  It said I needed to log in with the Linden Viewer, clear cache. Log out and in again in Debug1 or 2 (I am in 2 ^^) and stay there for 20 minutes.

Maybe some magic will happen :D

BUT

I went into preferences and cleared my viewer cache. I didn't see any way in there to clear my inventory cache like in Firestorm. The support note didn't explain HOW or which cache to clear since of course I am OLD and should "know how". And I do, just not in the official viewer. Searching Google and knowledge base gives me no answers for the Linden viewer, only for Firestorm even when I type in Linden Viewer LOL.

So do I need to manually go in and clear my cache through the Windows Explorer like you would do with a clean install in FS?   Imma thinking maybe yes.

Meanwhile I will go do some real life stuff.  

Thanks of Linden Viewer folks :D


 

Yeah, well, its LL Support, they always say "You have to use the LL Virtual Inferiority Viewer, nothing else will do!"

As for clearing 'inventory cache', this is a classic example why smart people use TPV's for that richer flavour and a better SL.

The 'cache' contains different things, textures & downloaded meshes (for rendering other peoples clothes etc) in one section, client side inventory lists in another, and viewer history, where you tp'd for the tp histoy tab and all that in another section , and so on.

In FS, you can 'clear inventory cache' to fix CLIENT SIDE inventory problems, in Catznip, you 'clear viewer history' after unticking the non inventory related history options..

The LL Virtual Inferiority Viewer doesn't have any of this, thats why we use TPV's.

What worries me more is from what I remember of your thread on your inventry problems, it was 'corrupted inv items ON THE ASSET SERVER, and clearing cache on any viewer wont do squat to fix the damn asset server.

So, three options present themselves...

Either the LL Support Monkey who contacted you was some tech illiterate call centre staff reading from an out of date tech-support knowledge base entry  the advice is wrong, or...

They are real tech support, and they fixed your server side inventory problems and it's just a matter of clearing inv-cache on whatever viewer you intend to use so it updates with the fixed list, so you'll have to clear in FS too, or...

They are yan king your chain, just for Gits and Shiggles, which some of them will do from time to time because they get bored at work too, and spoofing the customers is a traditional remedy for this.

Ultimately, you are the only one who can find out which, so keep us posted...
 

Link to comment
Share on other sites

38 minutes ago, Klytyna said:

Yeah, well, its LL Support, they always say "You have to use the LL Virtual Inferiority Viewer, nothing else will do!"

As for clearing 'inventory cache', this is a classic example why smart people use TPV's for that richer flavour and a better SL.

The 'cache' contains different things, textures & downloaded meshes (for rendering other peoples clothes etc) in one section, client side inventory lists in another, and viewer history, where you tp'd for the tp histoy tab and all that in another section , and so on.

In FS, you can 'clear inventory cache' to fix CLIENT SIDE inventory problems, in Catznip, you 'clear viewer history' after unticking the non inventory related history options..

The LL Virtual Inferiority Viewer doesn't have any of this, thats why we use TPV's.

What worries me more is from what I remember of your thread on your inventry problems, it was 'corrupted inv items ON THE ASSET SERVER, and clearing cache on any viewer wont do squat to fix the damn asset server.

So, three options present themselves...

Either the LL Support Monkey who contacted you was some tech illiterate call centre staff reading from an out of date tech-support knowledge base entry  the advice is wrong, or...

They are real tech support, and they fixed your server side inventory problems and it's just a matter of clearing inv-cache on whatever viewer you intend to use so it updates with the fixed list, so you'll have to clear in FS too, or...

They are yan king your chain, just for Gits and Shiggles, which some of them will do from time to time because they get bored at work too, and spoofing the customers is a traditional remedy for this.

Ultimately, you are the only one who can find out which, so keep us posted...
 

Actually I don't remember any info being mentioned about the asset server. I actually went back to my initial contact from a Linden and NO mention of asset server, only 300 corrupted files.

The support message said that they had "run a script" to fix things.  Have no clue except that ONE texture that WAS bad a few days ago (happily I remembered its name) is no longer "beyond lossy".  Since I really don't know WHAT was wrong and since these things appear to happen to me more often than others (OR, I am just paying attention and no my inventory well -- there is that) I don't imagine that I'll ever know what was wrong or what may have been fixed. 

And the initial "corrupted" message might possibly have been from another time. I am not sure we will know that. I had, when I was going back and forth to Opensim a lot a couple of years ago, a lot of "white textures" which happens going between the different platforms. They were all MY textures that I had uploaded so it wasn't a big deal (and free) to upload again. Just a pain. But that wasn't an SL issue as far as I know; seemed to be a viewer problem. Clearing cache didn't help.  I did have one occurrence that I noted of that a month or so ago. Someone else could see the texture but not me. So I switched out the kitty tent for another version that I COULD see the texture on. :D

 

 

 

 

Link to comment
Share on other sites

 

13 minutes ago, Chic Aeon said:

Actually I don't remember any info being mentioned about the asset server. I actually went back to my initial contact from a Linden and NO mention of asset server, only 300 corrupted files.

That's why I assumed 'server side, LL can't tell how many corrupted entries there are in the client side files, only on the asset server. so when they told you "300 corrupted items, we did something to fix it", that does sound like server side problems and clearing cache didn't fix that because, it couldn't...

If your stuff is back in SLV, then maybe they did the server side fix, and clearing cache is just resynching viewer with server, so you'll probably have to do it again when you switch back to your regular FS viewer.
 

Link to comment
Share on other sites

1 hour ago, Klytyna said:

Yeah, well, its LL Support, they always say "You have to use the LL Virtual Inferiority Viewer, nothing else will do!"

No they don't actually. They're quite happy to have the third party viewers around - saves them a lot of necessary work like Liunx support, developing a (barely) functional snapshot function and stuff.

But they do not generally provide technical support for third party viewers and really, you can't expect them to.

This reminds me of one of the last meetings in the old content creator user group. Somebody asked why LL didn't accept bug reports for Firestorm and Nyx Linden's answer was simply that it was better to send bug reports to somebody who could actually do something about them.

Edited by ChinRey
Link to comment
Share on other sites

The inventory fix scripts LL support use fix problems like folders & items  without parents, folders & items with bad parents, items with null asset UUID, multiple system folders etc. If inventory item,s & folders are corrupted in a certain way, they are visible in your inventory at the back end but won't show up in the viewer inventory.  The fixes will recover those items.
Support always ask you to clean inventory cache after they run those fixes.  I've no idea if it's really necessary or not.
 

  • Like 2
Link to comment
Share on other sites

Well it didn't hurt to clear the Linden Viewer cache and while I was three I changed some preferences so that it is a bit more friendly. Still can't get my Windlight settings to "stick" though, I have to make a new one each time which is a pain OR just hurry hurry and shut my eyes. 

I didn't notice any issues logging back into FS. I DID late this afternoon see a couple of textures that were in that blurry range (on items not in inventory). A texture refresh fixed them. Not sure if that had anything at all to do with the inventory issues or just a tough day :D.

I did something VERY weird with a keystroke and all my Gs are now bold and highlighted. Posting this anyway as guessing it is just ME :D

 

Link to comment
Share on other sites

22 minutes ago, Whirly Fizzle said:

The inventory fix scripts LL support use fix problems like folders & items  without parents, folders & items with bad parents, items with null asset UUID, multiple system folders etc. If inventory item,s & folders are corrupted in a certain way, they are visible in your inventory at the back end but won't show up in the viewer inventory.  The fixes will recover those items.
Support always ask you to clean inventory cache after they run those fixes.  I've no idea if it's really necessary or not.

 

It's probably a good idea, clearing inv cache after a server side 'back end' cleanup, just to re-synch the client side list with the server side, just remember to do it in all the viewers you use.
 

  • Like 2
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1463 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...