Jump to content

Trying to get this texture to work help please


You are about to reply to a thread that has been inactive for 1443 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

So i have a gif i turned to a texture but i cant figure out how to make it animate on the object im working with.

If some one could help out I would be grateful Please and thank you

 

I have attached the texture im trying to animate to help out 

Also i should say im using a script that is kinda working 

default
{
 state_entry()
 {
  llSetTexture("giphy.anim;6;4;10", ALL_SIDES);
  llSetTextureAnim(ANIM_ON | LOOP, ALL_SIDES, 6, 4, 0, 0, 3.0);
 }
}

this would be 100% fine but it wont let me size the texture to the size i need 

giphy.anim;6;4;10.jpg

Edited by Kryptic68112
Link to post
Share on other sites
2 hours ago, Rolig Loon said:

Right. You cannot change the scale of an image that you animate with llSetTextureAnim.

That's not quite true. It is possible to scale textrues with smooth animation. Not textuses with frame animation though and that's what you have here.

  • Like 1
Link to post
Share on other sites

The regular lsl command to apply a scaled texture to a prim face can scale and offset, and there are 'fast ' versions not limited to 0.2 seconds delay?

So you could manually scale and offset the texture for a frame animation, with small sleep delays between the texture statements to make your 25 fps animation...
 

Link to post
Share on other sites
23 minutes ago, Klytyna said:

The regular lsl command to apply a scaled texture to a prim face can scale and offset, and there are 'fast ' versions not limited to 0.2 seconds delay?

Yes but the timer event has a built in delay - about 0.1 seconds if I remember correctly.

So... an endless while loop putting the script to sleep and waking it up again 25 times a second and every time the script will have to recalculate or look up the new values for the variables. This is beginning to sound like a very heavy script. There is bound to be several very noticeable glitches since the server will skip the script every now and then.

Then of course, unlike llSetTextureAnim, llSetLinkPrimitiveParmsFast is handled server side so the updated data will have to be transferred too. There is a reason why texture animations are done client side.

  • Like 1
Link to post
Share on other sites
  • 4 weeks later...
You are about to reply to a thread that has been inactive for 1443 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...