Jump to content
Lexii Lane

Physics upload issue! Please help before I lose my mind

Recommended Posts

Okay, I am uploading a mesh. Pretty common stuff. However, when I go to customize the physics with a model .dae from 3ds max, I end up with the physics mesh seeming to be WARPED.


The shape I am uploading is basically a super optimized version of the base mesh, so I am not sure why its doing it like this. I have tried it with simple shapes too, like a box, and it ends up super stretched like this...

 

 

ddcead7773e848f849b84be203391335.png

Share this post


Link to post
Share on other sites

Are you sure there are no loose vertices in any of the models? All LoD models and the physics model will always be automatically scaled to the same overall size at the main model but if there are some stray vertices, the uploader will include those in the size calculation.

 

5 minutes ago, Lexii Lane said:

The shape I am uploading is basically a super optimized version of the base mesh,

I'm not absolutely sure what kind of object you have made but I would guess you can actually simplify the physics even further and use just a cube. Remember, the physics model is only used for collisions with avatars and physical objects so unless people are supposed to walk all voer it, a cube is enough.

Share this post


Link to post
Share on other sites
12 minutes ago, ChinRey said:

Are you sure there are no loose vertices in any of the models? All LoD models and the physics model will always be automatically scaled to the same overall size at the main model but if there are some stray vertices, the uploader will include those in the size calculation.

 

I'm not absolutely sure what kind of object you have made but I would guess you can actually simplify the physics even further and use just a cube. Remember, the physics model is only used for collisions with avatars and physical objects so unless people are supposed to walk all voer it, a cube is enough.

Yes and yes. I also used a cube, Ill upload a picture here.

C2apture.JPG

Share this post


Link to post
Share on other sites
14 minutes ago, Lexii Lane said:

Yes and yes. I also used a cube, Ill upload a picture here.

C2apture.JPG

That can happen if your model has too many vertices (I think it is around 22,000 plus a bit ) but I can't imagine your model being that dense.  So I am going to guess that isn't it.

Did you apply, location, rotation and scale and move the Origin to the middle of the model? (Origin to Geometry in Blender) I sometime have this issue when I forget to do that.  

Those two things and the wayward vertices (which I did NOT have when I had this continuing issue -- it was a heavy mesh problem for me and since I rarely go there I didn't even think) are the only three things I can think of that will cause this issue. 

I use Blender so not sure how you would do the location, rotation etc bit. 

 

PS. BOTH your model and the physic model need to have those things applied :D.

 

 

 

Edited by Chic Aeon
adding info

Share this post


Link to post
Share on other sites
1 minute ago, Chic Aeon said:

That can happen if your model has too many vertices (I think it is around 22,000 plus a bit ) but I can't imagine your model being that dense.  So I am going to guess that isn't it.

Did you apply, location, rotation and scale and move the Origin to the middle of the model?  I sometime have this issue when I forget to do that.  

Those two things and the wayward vertices (which I did NOT have when I had this continuing issue -- it was a heavy mesh problem for me and since I rarely go there I didn't even think) are the only three things I can think of that will cause this issue. 

I use Blender so not sure how you would do the location, rotation etc bit. 

 

PS. BOTH your model and the physic model need to have those things applied :D.

 

 

 

Thank you, yes, I am checking for isolated verts right now, it might be a glitch somewhere, and I will set ALL of the individual pieces to have the same axis. The mesh is around 22000 verts (blame the handles and top light)

Share this post


Link to post
Share on other sites
8 minutes ago, Lexii Lane said:

Thank you, yes, I am checking for isolated verts right now, it might be a glitch somewhere, and I will set ALL of the individual pieces to have the same axis. The mesh is around 22000 verts (blame the handles and top light)

If it is really that heavy I would take a LONG AND HARD look on reducing some geometry. It took me four years to come up against that issue (smile) and your box will be way too dense (and likely "primy").   I am pretty sure that while ChinRey and I don't always agree LOL, she will concur on the vertex count of your model. I suspect she didn't even think of that because there was no reason for your model to have that many vertices (wink).    Lose some edgeloops :D.

The sub-surf modifier or whatever that function is called in your software is NOT your friend. Whenever I use it I then go back and get rid of all the edgeloops it made that I didn't really need to be there. 

Good luck! I am glad that I had a similar issue (well documented somewhere here in the archives from January I would guess) and knew the end conclusion. 

 

 

Edited by Chic Aeon

Share this post


Link to post
Share on other sites
1 minute ago, Chic Aeon said:

If it is really that heavy I would take a LONG AND HARD look on reducing some geometry. It took me four years to come up against that issue (smile) and your box will be way too dense (and likely "primy").   I am pretty sure that while ChinRey and I don't always agree LOL, she will concur on the vertex count of your model. I suspect she didn't even think of that because there was no reason for your model to have that many vertices (smile).    Lose some edgeloops :D.

The sub-surf modifier or whatever that function is called in your software is NOT your friend. Whenever I use it I then go back and get rid of all the edgeloops it made that I didn't really need to be there. 

Good luck! I am glad that I had a similar issue (well documented somewhere here in the archives from January I would guess) and knew the end conclusion. 

 

 

Well its not really primmy, its reading 4 LI, and the only reason for that is I have the windows, police box and doors on separate "prims" because they need to be animated independently. I had a mesh with about 94,000 verts upload without this issue last week, Ive never seen it :( Ill take a look at reducing the verts.

Share this post


Link to post
Share on other sites
4 minutes ago, Lexii Lane said:

Thank you, yes, I am checking for isolated verts right now, it might be a glitch somewhere, and I will set ALL of the individual pieces to have the same axis. The mesh is around 22000 verts (blame the handles and top light)

Oh. Trust me, you really, really, really do not want to upload this as a single mesh. Mixing small and big triangles in the same mesh is the absolutely worst thing you can do if you want reasonable LoD and land impact. The golden rule is that the number of parts you split a build into should be twice the land impact, maybe a bit less.

But even so, high poly meshes don't really belong in a dynamic virtual reality and I avsolutely agree with Chic you should try to reduce the total polycount. I would estimate about 1000 should be about right for this. The way SL handles mesh, that means about 2000-3000 vertices.

You do use smooth normals for the curved surfaces, don't you?

 

Just now, Lexii Lane said:

Well its not really primmy, its reading 4 LI

How is the LoD? It should be possible to get it down to 2 even with good LoD.

Also remember, there this thing called lag. A good rule of thumb is to keep the number of active triangles in a scene below about 300,000. That is all the details rendered on a computer screen at the same time, not just a single item.

Share this post


Link to post
Share on other sites
1 minute ago, ChinRey said:

Oh. Trust me, you really, really, really do not want to upload this as a single mesh. Mixing small and big triangles in the same mesh is the absolutely worst thing you can do if you want reasonable LoD and land impact. The golden rule is that the number of parts you split a build into should be twice the land impact, maybe a bit less.

But even so, high poly meshes don't really belong in a dynamic virtual reality and I avsolutely agree with Chic you should try to reduce the total polycount. I would estimate about 1000 should be about right for this. The way SL handles mesh, that means about 2000-3000 vertices.

You do use smooth normals for the curved surfaces, don't you?

 

How is the LoD? It should be possible to get it down to 2 even with good LoD.

Also remember, there this thing called lag. A good rule of thumb is to keep the number of active triangles in a scene below about 300,000. That is all the details rendered on a computer screen at the same time, not just a single item.

Well I can say for certain its not my verts and polygons, I just tried to upload a box shape, and used the same mesh as a physics LOD from the dae file. The physics model is stretched for some reason. That cant be good.

Share this post


Link to post
Share on other sites
1 hour ago, Lexii Lane said:

Well its not really primmy, its reading 4 LI, and the only reason for that is I have the windows, police box and doors on separate "prims" because they need to be animated independently.

:D. Well there are of course different definitions (chucking a bit) to "primmy". As ChinRey said, four is really too much. 2 because you need all the parts, so 2 would be your minimum (if I read that correctly as I am just quitting for the day and tired). At 2 you should be able to get good LODs. 

 

OK. Here is another thing as you didn't specify that this was a linkset in your OP. Did you make the linkset pieces all correspond in naming to your model pieces. So "box" "box_phys" etc?    If not here is a post that explains that. Doesn't mean that 22,000 is good, but may not be the ONLY issue. And if you did already know how this works, the post may help someone else again .

And I do agree with ChinRey that this would be better uploaded in pieces for various reasons so you might want to try both ways to get a feel for the differences --- if you haven't done that before of course. We don't really know what you have done -- except perhaps swear a time or two. Been there :D. 

 

 

Share this post


Link to post
Share on other sites

Yeah, if it's multiple meshes in a single DAE you need for each mesh a physics shape in the physics DAE as well. Apply Rotation & Scale is Reset XForms in Max. And last but not least, use the official Second Life viewer to upload mesh models. Firestorm has still the bugged version 5.0.1.52150 as it's current viewer.

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Lexii Lane said:

Well I can say for certain its not my verts and polygons, I just tried to upload a box shape, and used the same mesh as a physics LOD from the dae file. The physics model is stretched for some reason. That cant be good.

No, that can't be good. But a lot of info for the future. Good luck. 

Share this post


Link to post
Share on other sites

  Hi :)

21 hours ago, Lexii Lane said:

Thank you all for your help, I am going to look into reinstalling my plugins, there may be an issue there. Thanks again!!

I came across a rotating Tardis on one of the Aditi sand boxes today :D

The probable reason you are having problems getting the physics to work properly is that the model is made up of 10 different mesh obects.

When making a physics mesh there are a couple of rules that have to be complied with.

  • 1:  Each visual mesh object has to have its own physics mesh object. If you are uploading all 10 parts together but with only 1 physics object then …. the result is something like you are experiencing.

  • 2: The bounding box size of the physics mesh must be the same as the bounding box of the visual mesh. As Arton has already said, if the Physics mesh’s bounding box is different from the visual mesh’s bb then it will be stretched or squished to fit. Which will result in collision surfaces not aligned to the visual mesh.

Unless you have good reason not to I would suggest that you join up all the parts of the visual mesh in 3D Max so that they are all one object. Then make a Physics mesh for that single object.

If you need a part to be separate, for example for animating, then upload it separately with its own Physics shape.  Doing this will almost guarantee having correct collision surfaces.

Note: In the example below the physics mesh is designed Not to be Analyzed in the mesh uploader.

593c631860c53_Physicsmodel.thumb.png.e412033135aa1b517a869d5c7d19d913.png

The reason the vertice count is higher than Chic or Rey approve of is not because your model is too detailed or dense but because you have a lot or edge loops that would not be there if you had modeled the side panels as separate, (but part of the same object) unconnected to the rest of the structure.

For comparison, the model in the image above is very similar to yours but the panels are separated from the rest, the vertice count in Blender is around 1450 and 3500 in the SL mesh Uploader. (Sharp edges,  UV islands and 6materials etc).

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Aquila Kytori said:

  Hi :)

I came across a rotating Tardis on one of the Aditi sand boxes today :D

 

The probable reason you are having problems getting the physics to work properly is that the model is made up of 10 different mesh obects.

 

When making a physics mesh there are a couple of rules that have to be complied with.

 

  • 1:  Each visual mesh object has to have its own physics mesh object. If you are uploading all 10 parts together but with only 1 physics object then …. the result is something like you are experiencing.

     

  • 2: The bounding box size of the physics mesh must be the same as the bounding box of the visual mesh. As Arton has already said, if the Physics mesh’s bounding box is different from the visual mesh’s bb then it will be stretched or squished to fit. Which will result in collision surfaces not aligned to the visual mesh.

     

Unless you have good reason not to I would suggest that you join up all the parts of the visual mesh in 3D Max so that they are all one object. Then make a Physics mesh for that single object.

 

If you need a part to be separate, for example for animating, then upload it separately with its own Physics shape.  Doing this will almost guarantee having correct collision surfaces.

 

Note: In the example below the physics mesh is designed Not to be Analyzed in the mesh uploader.

593c631860c53_Physicsmodel.thumb.png.e412033135aa1b517a869d5c7d19d913.png

The reason the vertice count is higher than Chic or Rey approve of is not because your model is too detailed or dense but because you have a lot or edge loops that would not be there if you had modeled the side panels as separate, (but part of the same object) unconnected to the rest of the structure.

For comparison, the model in the image above is very similar to yours but the panels are separated from the rest, the vertice count in Blender is around 1450 and 3500 in the SL mesh Uploader. (Sharp edges,  UV islands and 6materials etc).

 

Ok I took into practice what you said, started bringing the models in in parts, and realized that I can start this again from the ground up keeping these things in mind. Bringing the walls in as their own objects helped with the bounding boxes, and going further into it, if I can get it all on one mesh that would be great, the problem is I need to be able to choose separate faces to let them illuminate. I read on help forums and stuff that the separate faces can be up to nine, however when I bring this into SL, it only allows me to do a max of two separate facings. I am wondering if its some knowledge I am lacking in MAX regarding mapping channels or something.

If I break the mesh up into parts, it makes it assued that each will be its own face.

Share this post


Link to post
Share on other sites
2 hours ago, Lexii Lane said:

I need to be able to choose separate faces to let them illuminate. I read on help forums and stuff that the separate faces can be up to nine, however when I bring this into SL, it only allows me to do a max of two separate facings.

You CAN illuminate individual faces of a single mesh object using a script so if that was the only issue (I thought you were going to open the door too maybe?) then you don't need separate parts for that. You need to DEFINE each face you want to be separate in your modeling program (in Blender we assign a different  MATERIAL to each set of faces (or vertices if that makes more sense) we want to act in the same way. (So it could be one face defined by four vertices as in a table top or it could be many faces all meant to act together when brought in world; frequently this is to define texture areas -- some which you might want to add materials to like shine, others that you would not). 

And it is EIGHT material faces, not nine  for SL. The uploader will upload a model with more than eight but you REALLY don't want to do that. Won't explain why but you can look that up in the forum archives if you want. Basically the uploader breaks the model up "for" you since you didn't pay attention the the rules. MUCH chatter over this new feature when it appeared.  

I know it is confusing when we use terms that aren't your 3D software terms. Sorry.  Maybe this makes a little bit of sense.  

Edit: Rereading your last post maybe you don't need the lights to turn on and off which is what I was thinking. THAT would need a script. Just to make some glow yellow and some glow blue for example could be done in the build menu. 

Edited by Chic Aeon

Share this post


Link to post
Share on other sites

Here is an image of a mesh with 8 materials assigned in Max. There is a different Material ID set to each set of selected polygons. Assigning a Multi/Sub Material with 8 Standard Materials to the object. Naming the Materials alphabetically will keep the order in SL the same as they are in Max. Only SL starts numbering at 0 instead of 1.
MaxMaterials01.thumb.jpg.a22546843ffe00c01192f2a78e6382d3.jpg

Share this post


Link to post
Share on other sites

So with that I can take one mesh object and give it up to eight textures, and light those surfaces individually? I use multi materials, I wonder why its not working properly. Ill have to give the naming thing a shot next after I get done remeshing this TARDIS. You all are awesome :)

Share this post


Link to post
Share on other sites
3 hours ago, arton Rotaru said:

Indeed!

One last question: Say I have one editable poly, for instance the side wall as you have shown in the diagram. I want to have the wall and the window SILL on one UV map, and the GLASS of the window on another UV map... How the heck can I do that with one editable poly? The windows will be animated.

Share this post


Link to post
Share on other sites

You can UV map the polygons from each material on their own. So with 8 Mats like in the example, I could map each colored square to the entire 0 - 1 UV space on their own. Or I could map the polygons of multiple "materials" in the same 0 -1 UV space as well.

If you have done that, and select all polygons at once, and open the UV Editor, it will look like a total mess, because the UVs are all stacked onto each other. But since they are on different materials, they will work properly.

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, arton Rotaru said:

You can UV map the polygons from each material on their own. So with 8 Mats like in the example, I could map each colored square to the entire 0 - 1 UV space on their own. Or I could map the polygons of multiple "materials" in the same 0 -1 UV space as well.

If you have done that, and select all polygons at once, and open the UV Editor, it will look like a total mess, because the UVs are all stacked onto each other. But since they are on different materials, they will work properly.

So I'd have to break them off, map them, then attach and weld after the UV maps were done on the broken parts. But before I re-attach, I have to render the textures out, right?

Share this post


Link to post
Share on other sites

If you select only the polys of a single material, you can map one by one as well. For baking maps I do detach the polys, and attach them later on again, yes.

Share this post


Link to post
Share on other sites
2 minutes ago, arton Rotaru said:

If you select only the polys of a single material, you can map one by one as well. For baking maps I do detach the polys, and attach them later on again, yes.

TY! The material naming and merging of the mesh is helping 100%

Share this post


Link to post
Share on other sites

Importing mesh will be easier indeed. But since we have to deal with land impact as well, I would keep some things still as a seperate object. Like the Beacon lamp on the top. As ChinRey mentioned, all these little triangles will count at the size of the entire object, which will increase the LI propably. If you keep it as the small lamp though, the tris will just count at the size of the lamp. It's a balancing act indeed.

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...