Jump to content
Interregnums

Permissions changing on transfer

Recommended Posts

I have a building I am wanting to sell, made of bought full perm mesh and my own original mesh. 

I have set all permissions to full perm in order to send it to my store account. However when I get it in my inventory in my store account, the permissions have changed. Whether its, no copy,mo mod. Or no tranfer, no copy. Or all three. I just can't seem to send it full perms. 

I have checked all door scripts, and made sure they are set to copy/trans/no mod as per the script writers request.
I have detached all doors and sent just the structure, to no avail. 

Does anyone have any ideas on what might be going on?

 

Cheers

Share this post


Link to post
Share on other sites

Did you change the permissions while the house was in your inventory? If so: don't ever do that. Rez the item, change permissions and take it back into inventory.

  • Like 1

Share this post


Link to post
Share on other sites

OK. I am leaving what I wrote first below as it may be relevant.

With a no mod script, I suspect that you  know what SHOULD happen is that the building "looks" no modify because of the script inside, but the structure itself should be modify for size, texture etc.  The fact that it changed on transfer is pretty much what happened to me yesterday (see below). I see ChinRey has maybe replied to this thread (that's kinda spooky - knowing while you are typing LOL) so perhaps there are some answers there. I WILL say that what you describe is very much like what happened to me. 

***********

Well I can't say I know what is going on, but I had a similar issue yesterday with a couch. It was my mesh, my textures and my texture change script. I even made the animations and they were all set to mod-copy.  The only thing that wasn't mine was the sitter scripts which I use in all furniture with sits. Like you, I checked and rechecked permissions, but when I sent to my alt who doesn't have permission to edit my objects, the couch became no mod. This is NOT my norm and I had to change my venue text advertising and make new with a BIG sign saying the couch is copy only. This was not what I wanted to do. 

So it does seem that there is an issue. I haven't seen this in many years but long ago it happened fairly often. 

Edited by Chic Aeon

Share this post


Link to post
Share on other sites
6 minutes ago, ChinRey said:

Did you change the permissions while the house was in your inventory? If so: don't ever do that. Rez the item, change permissions and take it back into inventory.

In MY case I did not. Always change permissions it in world. I was SO hoping you had an answer :D. 

Share this post


Link to post
Share on other sites

So the good news is that I went back to my couch and sent to my alt again this morning and things worked as they should. So, perhaps it was a short time issue that is fixed. I suggest giving it another try. 

Meanwhile I will send the MOD versions to the people that purchased yesterday. So thanks for this post as I probably wouldn't have rechecked :D. 

Share this post


Link to post
Share on other sites
4 hours ago, Chic Aeon said:

In MY case I did not. Always change permissions it in world. I was SO hoping you had an answer :D. 

If permission changes to rezzed objects or other modifications to them don't stick, it's probably a connection glitch. Even the best connection will have a small glitch every now and then so it can happen to anybody.

Share this post


Link to post
Share on other sites
33 minutes ago, ChinRey said:

If permission changes to rezzed objects or other modifications to them don't stick, it's probably a connection glitch. Even the best connection will have a small glitch every now and then so it can happen to anybody.

Well it happened many times on many testings over a few hours. That's all I know. 

Share this post


Link to post
Share on other sites

Hi all, thank you very much for your replies. 

18 hours ago, ChinRey said:

Did you change the permissions while the house was in your inventory? If so: don't ever do that. Rez the item, change permissions and take it back into inventory.

17 hours ago, Chic Aeon said:

OK. I am leaving what I wrote first below as it may be relevant.

With a no mod script, I suspect that you  know what SHOULD happen is that the building "looks" no modify because of the script inside, but the structure itself should be modify for size, texture etc.  The fact that it changed on transfer is pretty much what happened to me yesterday (see below). I see ChinRey has maybe replied to this thread (that's kinda spooky - knowing while you are typing LOL) so perhaps there are some answers there. I WILL say that what you describe is very much like what happened to me. 

***********

Well I can't say I know what is going on, but I had a similar issue yesterday with a couch. It was my mesh, my textures and my texture change script. I even made the animations and they were all set to mod-copy.  The only thing that wasn't mine was the sitter scripts which I use in all furniture with sits. Like you, I checked and rechecked permissions, but when I sent to my alt who doesn't have permission to edit my objects, the couch became no mod. This is NOT my norm and I had to change my venue text advertising and make new with a BIG sign saying the couch is copy only. This was not what I wanted to do. 

So it does seem that there is an issue. I haven't seen this in many years but long ago it happened fairly often. 

4

I do indeed know about that, thank you. It was the first thing I checked when I realised something was off.

I also changed the permissions in and out of the inventory, it would appear neither will stick on transfer.

12 hours ago, ChinRey said:

If permission changes to rezzed objects or other modifications to them don't stick, it's probably a connection glitch. Even the best connection will have a small glitch every now and then so it can happen to anybody.

Unfortunately, the issue is persisting, I asked a friend who bought a copy of the house from me directly (I transferred it to him) a few weeks ago and he said the permissions were wrong on his copy of the house too. I have tried transferring it again today to no avail. It's copying with all sorts of different permission changes, the most recent being having none at all.

 

EDIT : I have also just noticed that the permissions for the next owner change when I take the object back into my inventory. It goes from full permissions, to only copy.

 

 

Edited by Interregnums
Found out some new information

Share this post


Link to post
Share on other sites

Once I had a house and a chair that went no mod for no reason, back in 2008. Then about 2011 I had a house that would become no mod if any prim was unlinked -- turned out (after several hours of investigation) there was a corrupted floor prim. I replaced that prim, all was well. 

Also had a house go no mod because there was a no mod texture on one tiny prim.

Edited by Pamela Galli
  • Like 1

Share this post


Link to post
Share on other sites
16 minutes ago, Pamela Galli said:

Once I had a house and a chair that went no mod for no reason, back in 2008. Then about 2011 I had a house that would become no mod if any prim was unlinked -- turned out (after several hours of investigation) there was a corrupted floor prim. I replaced that prim, all was well. 

Also had a house go no mod because there was a no mod texture on one tiny prim.

This is what it turned out to be! I had forgotten to change the permissions on ALL my textures. Having changed the permissions as needed, the house has transfered over perfectly. 
Thank you everyone for your help and advice.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×