Jump to content
Tourmaline Falken

Sitting and standing hover problem

Recommended Posts

Hi all

I'm by no means a newbie (born 2006!) but I don't know how to fix this long-standing problem.  The issue is that when I sit on any seat my avatar sinks into the chair or seat.  I have to use the hover to raise my av so it looks like I'm sitting normally.  However, when I stand up, I am hovering about a foot above the ground and have to re-adjust the hover down again.  Is there an obvious fix I am missing?  I have a Slink Physique body and my av is not tall or particularly short (2m tall according to Appearance).  I'm using Vista Rachel AO - both the regular and short av versions create the same problem with sitting/standing.  

I'll be very grateful for any help anyone can offer. :)

Share this post


Link to post
Share on other sites

In most MODERN chairs you have the option of adjusting the animation via a menu. You can then save that setting so when you sit again it will be correct. 

The problem is that your avatar isn't the same size as the avatar used when setting up the sits. I am guessing you are a pretty tall or big or both gal. I am 2 meters tall and I test my animations with a friend who is a fairly large guy (not sure how tall but much taller than I am) and he sinks down. 

Quick edit: I missed the part where you are the same height as I am. So height doesn't seem to be the answer, BUT the fix should still work. I rarely have to change anything on other people's furniture so far as placement. So a bit puzzled unless you are using really OLD furniture that doesn't have a menu. 

The popular sitters (one is more popular but won't name names) have been around for YEARS so you should be able to find a good selection of furniture and props using these. Maybe it is simply time to do some furniture shopping *wink*.

Edited by Chic Aeon
  • Like 1

Share this post


Link to post
Share on other sites

Hey Chic - thanks for your reply!

My av is also 2m tall - and actually I'm short compared to many.  This issue happens not with just some furniture or my own furniture but *every time* I sit anywhere, when exploring for example. Even the modern chairs with menus mean I've got to fiddle with the menu and + and -.  Other friends just don't have this problem.  I feel there must be something I can change or fix about my av - perhaps my legs are too short or I'm out of proportion in some way ...

  • Like 1

Share this post


Link to post
Share on other sites

You can check yourself via a proportion guideline. Your legs should take up half your height, so rez a cube. Color it (I use red), make it partially transparent, drag it onto yourself, and position and stretch it so it reaches from the very top of your (hairless) head, down to your crotch. Duplicate this cube (shift and drag the position arrows, I believe),color it something else (I use blue), and position it so the top touches but doesn't overlap the bottom of the first. It should reach down to the soles of your (flat and shoe-less) feet. You should not have to resize the second object; they should be the same size. If, in order to reach from the soles of your feet to the top of your head, one cube has to be much different in size from the other, you're out of proportion. 

An easier way to test if your shape is the issue, of course, is to simply change something about it and try sitting on a piece of furniture you know causes issues. If the situation improves (or worsens), there's the problem. If not, change it back and try changing something else. 

  • Like 1

Share this post


Link to post
Share on other sites

I deal with this almost all the time, i just leave my hover adjustment slider open all the time and adjust as needed, after a while you just get used to it being a part of life in SL.

  • Like 1

Share this post


Link to post
Share on other sites

In some seats the sinking happens if your AO is on. When you sit down on a scripted seat, turn your AO off and see what happens then. For me that always fixes the sinking issue. Some AO sit animations might cause that the seat animation doesn't play properly and you sink.

  • Like 3

Share this post


Link to post
Share on other sites

This is very common in SL and can't be avoided, as the furniture can't "read" the avatars measurements and place him/her correct. Hm, that would be some feature!

I do the same as the OP for furniture I don't own and will sit in a short time. And I keep the appearance window open, but minimized, this way it is faster to adjust back to normal when I stand up.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for all the help, everyone.  

I thought Ariel's suggestion was really interesting - I have made my av more like RL - my legs are shorter than my body - so I thought this was bound to be the problem, but when I followed her advice rezzing the blocks and comparing, my legs were actually slightly longer than my body!  They were only at 11 % on the leg length scale tho - curiouser and curiouser ... However, even adjusting this down to 4 % so my av was totally in proportion, it made no difference to the sinking problem when sitting.

Talligurl - I've been putting up with this for a very long time and it doesn't happen to my friends, so that's why I finally posted on the forum to ask.  Was hoping I was missing something obvious to fix it so I didn't have to fiddle with the hover every time I sit and stand up.

Coby - Tried the AO thing, and didn't help.  That used to help years ago I remember but not this time :(

Thanks Marianne - I use Firestorm where there is the hover option in Quick Prefs on screen but it still annoys me having to fiddle with it.

After trying Ariel's blocks idea, I also fiddled with making my av tall  at 100 % and shorter at 50% (I am usually set to 80% on the body scale) nothing fixed the problem.  Sigh.  Guess I'm going to have to just continue like this.  I do feel sure there is a reason/answer out there somewhere though ...

Share this post


Link to post
Share on other sites
54 minutes ago, Tourmaline Falken said:

I use Firestorm where there is the hover option in Quick Prefs on screen but it still annoys me having to fiddle with it.

 

This tiny little slider IS annoying, but in Firestorm if you right click your avatar, then chose "appearance" and then "hover height" from the context menus, you'll get a standalone slider that is much bigger and easier to use. You can leave it on screen or minimize it. Much better option than the Quick prefs IMO. 

  • Like 1

Share this post


Link to post
Share on other sites

I did a little bit of digging around and located someone having the opposite problem that you're having: their avatar always hovered above seats.

It turned out that their settings were corrupted. They deleted their settings folder, so that a new one was generated, but a full clean reinstall of your viewer might fix the problem. Try using a different viewer first, and - if the problem goes away with that viewer - you'll know it's your settings that are causing the issue.

Edited by Skell Dagger
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Sagadin said:

This tiny little slider IS annoying, but in Firestorm if you right click your avatar, then chose "appearance" and then "hover height" from the context menus, you'll get a standalone slider that is much bigger and easier to use.

The hover height slider is standard issue for SL viewers today, not unique to Firestorm.

 

23 hours ago, Coby Foden said:

In some seats the sinking happens if your AO is on.

That happens if your AO uses sit animations with too high priority. Unfortunately, most mdoern AOs seem to do that. :(

 

3 hours ago, Tourmaline Falken said:

...

nothing fixed the problem.  Sigh.  Guess I'm going to have to just continue like this.  I do feel sure there is a reason/answer out there somewhere though ...

There is at least two more things to test: Your shoe bases also affect elevation when you sit and that can sometimes have unexpected results. And did you remember to check the old hover height function too? The one in the shape edit window that is. That is not the same one as the one you get in those sliders.

Edited by ChinRey
typo
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 6/1/2017 at 10:22 AM, Tourmaline Falken said:

Hey Chic - thanks for your reply!

My av is also 2m tall - and actually I'm short compared to many.

The average height in SL has actually been going down over the years.

When I first made myself "to-scale" I was a rarity. Now I would say about 40-50% of people are in my height range, and an equal number are in the older scale. That puts you in the middle.

That aside...

Furniture is made mostly for the old 00's scale. Get used to using that adjust button. For furniture at home... save your changes.

If you want to go advanced... get the AVSit system (about to go open source:

And use that system to make your own notecards for all the animations in your furniture. That is what I do, but it takes a LOT of work.

For the simple solution; use furniture with a pose adjust button that also lets you SAVE your adjustment. Most modern stuff, as noted above, has this, as it is a core feature of AVsitter and a few other engines.

 

PS: If you are serious about working on your proportions (which is unrelated to the issue you're having), I have a guide for that: https://catnapkitty.wordpress.com/2011/06/15/getting-good-body-proportions-in-second-life/

- Which is written to help you regardless of what scale you have.

 

Edited by Pussycat Catnap
  • Like 1

Share this post


Link to post
Share on other sites

Thanks again to everyone for your comments! :)

Update is I took Skell's advice first and tried using another viewer.  I only had Singularity installed but actually that was the viewer my friend was using when he said my hover looked wrong.  After some fiddling with the hover in Singularity to get it right there, I found relogging into Firestorm that my hover seems to be fixed ... so far.  We'll see over the next few days of exploring and trying different stuff if it remains a fix.

Thanks particularly also to Sagadin - very helpful to have the big hover slider on screen in case I need to fine tune again.

I have noticed that too, Pussycat - since they introduced Viewer 2/3 about 7 years ago now, with the actual height listed in appearance, and newbie avatars of a normal/RL height, generally people have got smaller, so as my av was closer to RL height ( tho still tall) I have always remained the same height but now am not as small as I used to be compared to others (when guys were over 7 foot tall generally).

Thanks to Chin for pointing out the foot shape thing - it's good to be reminded of that, but I'm not wearing a foot shape with my slink feet (I never seem to need one now even tho shoes come with one in the folder).  How does the old Appearance hover function work/differ from the one in the sliders?  I'm loathe to tweak anything right now, now that things appear to be working!

 

Share this post


Link to post
Share on other sites
1 hour ago, Tourmaline Falken said:

How does the old Appearance hover function work/differ from the one in the sliders?  I'm loathe to tweak anything right now, now that things appear to be working!

They are completely different settings. Both move the entire avatar up or down but they work independently of each other.

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, Tourmaline Falken said:

 How does the old Appearance hover function work/differ from the one in the sliders?  I'm loathe to tweak anything right now, now that things appear to be working!

Slider Hover Height, the original hover height so to speak, neutral setting is 0, tends to work in meters.

Shape Hover Height, in the appearance editor, introduced with server side baking, neutral value is 50, each point on this is approximately 0.05 meters.

Use Shape Hover for 'permanent adjustments' for example if you are wearing a Pandoran avatar, you might want to raise the shape hover so your shoes dont sink in the ground, use Slider Gover for on the fly adjustments, remembering 1 point of Shape Hover - 0.05 on the slider hover.
 

  • Like 2

Share this post


Link to post
Share on other sites
On 2.6.2017 at 11:30 PM, ChinRey said:

There is at least two more things to test: Your shoe bases also affect elevation when you sit and that can sometimes have unexpected results. And did you remember to check the old hover height function too? The one in the shape edit window that is. That is not the same one as the one you get in those sliders.

 VERY IMPORTANT INFORMATION!! thank you!! that fixed my problem!! 

I had exactly the same issue, everytime I sit somewhere, no matter where it was, i was stuck into the object or ground, and when i adjusted the hover height then i was much too high. I remembered that i not always had this problem.. but a few months ago i must have adjusted my shape, and played with the slider. 

Now i´ve seen that it was just a bit too high, on 57, i set it back to 50, saved my shape, got out of the ground with the standard hover height slider and tadaaa!!! every pose now fits!! 

 

thanks a lot for your help!

Share this post


Link to post
Share on other sites
On 2/11/2018 at 5:00 PM, Susan Sandell said:

 VERY IMPORTANT INFORMATION!! thank you!! that fixed my problem!! 

I had exactly the same issue, everytime I sit somewhere, no matter where it was, i was stuck into the object or ground, and when i adjusted the hover height then i was much too high. I remembered that i not always had this problem.. but a few months ago i must have adjusted my shape, and played with the slider. 

Now i´ve seen that it was just a bit too high, on 57, i set it back to 50, saved my shape, got out of the ground with the standard hover height slider and tadaaa!!! every pose now fits!! 

 

thanks a lot for your help!

Hi Susan - It's been a while, but are your hover settings still good?  I've had this hover problem for just over a year now. None of the suggestions give apply.
You said you set your "slider back to 50". What slider do you have that measures to 50?  Both my Appearance and my Preferences sliders go from -2.00 to 2.00. In order for me to stand directly on the floor or ground, they both have to be set to -0.484.  And I have to use one of the sliders to raise myself up out of furniture. This is a pain an I can't find the answer.
So, what slider did you use that goes to 50?

Share this post


Link to post
Share on other sites
7 hours ago, JudiLynn India said:

Hi Susan - It's been a while, but are your hover settings still good?  I've had this hover problem for just over a year now. None of the suggestions give apply.
You said you set your "slider back to 50". What slider do you have that measures to 50?  Both my Appearance and my Preferences sliders go from -2.00 to 2.00. In order for me to stand directly on the floor or ground, they both have to be set to -0.484.  And I have to use one of the sliders to raise myself up out of furniture. This is a pain an I can't find the answer.
So, what slider did you use that goes to 50?

The slider she is referencing is in your edit shape section, should be in there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...