Jump to content

"esc" to reset cameras adds a rotation?


You are about to reply to a thread that has been inactive for 3652 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello,

Thanks for opening my post!

I'm using the viewer for Mac. Thanks to help received from the forum, I now have a reliable way for restoring accurate camera placements (using debug values).

There is one parameter I can't seem to handle. After taking pictures, I hit "esc" to return to normal view. Seems that "esc" adds a slight rotation factor to the default camera placement. Hitting "esc" a couple dozen times will make that default placement to perform a full rotation. It also affects the other pre-defined camera placements (which I've altered using debug values).

Do you have the same behavior with your viewers? Maybe is there a debug value to affect this one too? I've upgraded my viewer to the last version (2.6 or something).

Thanks for your time!

Link to post
Share on other sites

Hey,

I just noticed this behavior only happens when I'm standing on a "pose stand" that contains the following script. However, the change made to the camera is permanent and I cant seem to find what to do to reset the camera.

Any help will be welcome!

 

//Note: this code was adapted from someone.//key mkLoungingAgentKey = NULL_KEY;integer miPermissionsAcquired = FALSE;default{    state_entry()    {        //overriden sit target        //lower them a bit        vector vLoungeTarget = <0.00, 0.00, 1.15>;// *Note* Change the Last value        //to make your Avatar Stand Higher or Lower                rotation rX;        rotation rY;        rotation rZ;        rotation r;                //build rotations        //Note: this is broken out like this to simplify the        //        process of finding the correct sit angle.  I         //        use the following form until I have the rotation         //        that I want perfect, and then I simply         //        hardcode the perfected quaterion and remove           //        this mess.        //        rX = llAxisAngle2Rot( <1,0,0>, 0 * DEG_TO_RAD);         //cartwheel        rY = llAxisAngle2Rot( <0,1,0>, 0 * DEG_TO_RAD);       //sumersault        rZ = llAxisAngle2Rot( <0,0,1>, 0 * DEG_TO_RAD);       //turn in place                //combine rotations        r = rX * rY * rZ;                //override 'sit' on pie menu        llSetSitText( "Stand" );        //override default sit target and rotation on prim        llSitTarget( vLoungeTarget, r );    }        changed(integer change)     {        if (change & CHANGED_LINK)        {            key agent = llAvatarOnSitTarget();            if ( mkLoungingAgentKey == NULL_KEY && agent != NULL_KEY )             {                //changed user                //cache new user key and request their permissions                mkLoungingAgentKey = agent;                 llRequestPermissions(mkLoungingAgentKey,PERMISSION_TRIGGER_ANIMATION);            }            else if ( mkLoungingAgentKey != NULL_KEY && agent == NULL_KEY)             {                                //user is getting up                if ( miPermissionsAcquired )                 {                                        //restore anims                    llStopAnimation("turn_180");                                               }                                //reset the script to release permissions                llResetScript();            }        }            }        run_time_permissions(integer parm)     {        if(parm == PERMISSION_TRIGGER_ANIMATION)         {                        //set permission flag            miPermissionsAcquired = TRUE;                        //cancel the sit anim            llStopAnimation("sit");                        llStartAnimation("turn_180");        }    }    }

 

 

Link to post
Share on other sites

I can't tell you what is going on, it sounds very odd.:smileysurprised:
I think I have a work around for you though.
Use the shortcut: Snapshot to Disk: Ctrl-`
With this your screen won't even blink and you don't have to use Esc

Note: If you have national characters on your keyboard the shortcut looks different.
I have this: Ctrl-æ on my Danish keyboard.
The key to use is where the "`" is on the English keyboard layout, next to letter "L"

More Shortcut Keys

  • Like 1
Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 3652 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...