Jump to content
  • 0
storcker Binder

Random crashes in places with lots of people (30+ people)

Question

Hello,

 

I recently came back to Second Life around 5 days ago after a break of a year or so.

I've never had any issues in Second Life when I used to play with where I used to go or do it would all work fine. I came back and downloaded the SL Viewer from the Second Life website and when going to locations such as Big Daddy's 80's Club, I noticed I would crash if I moved or moved my camera. I went through making changes in the settings from turning my settings form ultra to high and changing VBO to disabled and more and still the same.

 

I have tried the following viewers - SL Viewer, Firestorm, Cool, Singularity and now using Catznip as it seems to be a little more stable at times.

I do not have issues with my setup or speeds of my connection as I will place this below.

Download Speed - 350MBps

Upload Speed - 50MBps

Ram - 64GB

Graphics Card - Gefroce GTX 1080

CPU - i7-3960X

HardDrives 4 x 500GB SSD's - I am running second life on a SSD

Motherboard - Rampage IV Extreme

 

I have checked my firewall and network and see no issues with anything causing blocks within my setup and just looking for some guidance.

I have also attached an image of my settings - Please note I have made multiple changes to them all and it still has issues.

 

 

Capture.PNG

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 1

I know you say that you have experimented with some of the settings, but you have still shoved some important sliders to maximum, so I suspect that's your problem.  When you have a great graphics card like the GeForce 1080, it's tempting to push it to the limit.  Still, you're overdoing it. Start moving some of those sliders to the left, beginning with the Avatar Maximum Complexity slider.  There's no reason to have it higher than about 300,000, especially if you are going to hang around in regions with a lot of overdressed, high kTris avs.  Your poor card is running out of cache, if nothing else.  (As an aside, you are also exposing yourself to griefers with graphics crashers. One of the big reasons the LL introduced that slider was to give us a way to block deliberate overloads like that.)  Try dropping the max number of non-imposter avs, too.  And in a crowded place like Big Daddys, drop your draw distance by a half or more.  There's no reason to have it set to see things a full region away when you are inside a club.

  • Like 2

Share this post


Link to post
Share on other sites
  • 1

Popular clubs and shopping areas can be a real bear, and avatars put the heaviest load on your graphics system.  I have a GeForce 1070 -- just one step below your card -- and I have lag issues in crowded spots like everyone else.  Mesh avatars and mesh outfits have only made things worse. There's far too much complexity around us.  Keep trying to work with lower slider settings. Also, consider the possibility that your Internet connection may be part of the problem.  Get off of wifi if you can.  Many people have no trouble at all, but Linden Lab neither recommends nor supports wireless connections.  Reboot your router too, and check your ping and packet loss figures.

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

If you are only crashing in busy places, it's probably an out of memory crash, which is a common problem on any 32bit viewer.

Try out the LL 64bit Project viewer: http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Project_Alex_Ivy/5.1.0.503537

or the Firestorm 64bit viewer: Choose the " For SL & Opensim 64bit" version at http://www.firestormviewer.org/windows/

Are you still crashing on the 64bit viewers?

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

@storcker Binder

Your likely problem is the NVIDIA driver. 378.92 works well. There is something in the 381.65 that creates problems. For many they crash at login. 

The problem seems to be in NVIDIA's Shadowplay/Share. It doesn't matter if you use it. So, try disabling it.

Regardless of your settings, you shouldn't be crashing with your hardware. The viewers are working for lots of other people. The connection sounds awesome but, check your connection to the SL servers, not just the Internet.

If you have changed your Max Bandwidth setting, set it to 1,500. This is a UDP protocol only setting. It tells the SL server how fast to send you UDP data. The Firestorm team has tested the setting extensively. Over 1,500 on even a great connection causes more problems.

Test your memory chips.

Get the free app Memory History and see how much memory your system is using per app. Make sure you are not running out. A viewer using up all memory is the most common cause of crashes.

If you changed you Avatar Complexity to Unlimited, bump it back a notch to eliminate overly complex avatars and objects from crashing your video card. Griefers and novice designers build mesh that can overload a video card, even the best in the case of griefers. In one of the combat games I played some loved to wear video crashers into battle just to mess with us.

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

The LL 64bit viewer still clamps texture memory to 512MB max.
Firestorm 64bit should automatically set texture memory to 2048MB on your card.

32bit programs running on a 32bit OS can only use a max of 2GB total memory before they will crash. SL viewers will reserve ~512MB memory for textures so you'll crash out at around 1.5-1.7 GB memory use.

32bit viewers running on 64bit OS are built with LAA (Large address aware) so they can use ~4GB memory max.  Again ~512MB is reserved for texture memory so you will crash at around 3.5 gig memory usage.
It's pretty easy to hit 3.5 gig memory on a busy region with lots of high poly mesh & large textures, which EATS into memory.

A 64bit viewer really has no memory limit.  The 64bit viewers should be happily still running at over 4+ gig total memory usage.

  • Like 1

Share this post


Link to post
Share on other sites
  • 1
13 hours ago, Rolig Loon said:

...As an aside, you are also exposing yourself to griefers with graphics crashers. One of the big reasons the LL introduced that slider was to give us a way to block deliberate overloads like that....

I somewhat disagree with Rolig here.  A complexity setting of 350K should protect you just fine against graphics crashers.  (350K is the highest setting other than "Unlimited".)  Graphics crashers have insanely high complexities...in the millions.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

CPU: Intel(R) Core(TM) i7-3960X CPU @ 3.30GHz (3309.86 MHz)
Memory: 64709 MB
OS Version: Microsoft Windows 10  (Build 14393)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 1080/PCIe/SSE2

Windows Graphics Driver Version: 22.21.0013.8165
OpenGL Version: 4.5.0 NVIDIA 381.65

RestrainedLove API: (disabled)
J2C Decoder Version: OpenJPEG: 1.5.2
Audio Driver Version: FMOD Ex 4.44.61
LLCEFLib/CEF Version: 1.5.3-(CEF-WIN-3.2526.1347-32)
LibVLC Version: 2.2.4
Voice Server Version: Vivox 4.6.0017.22050

Packets Lost: 0/2,959 (0.0%)
April 19 2017 07:38:15

Edited by storcker Binder

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Rolig Loon said:

I know you say that you have experimented with some of the settings, but you have still shoved some important sliders to maximum, so I suspect that's your problem.  When you have a great graphics card like the GeForce 1080, it's tempting to push it to the limit.  Still, you're overdoing it. Start moving some of those sliders to the left, beginning with the Avatar Maximum Complexity slider.  There's no reason to have it higher than about 300,000, especially if you are going to hang around in regions with a lot of overdressed, high kTris avs.  Your poor card is running out of cache, if nothing else.  (As an aside, you are also exposing yourself to griefers with graphics crashers. One of the big reasons the LL introduced that slider was to give us a way to block deliberate overloads like that.)  Try dropping the max number of non-imposter avs, too.  And in a crowded place like Big Daddys, drop your draw distance by a half or more.  There's no reason to have it set to see things a full region away when you are inside a club.

Really appreciate your fast response Rolig.

 

I have made the following changes below and will see if this resolves the issue. I read a lot of threads with issues with crashing but none seems to be very similar to mine. I noticed this in high impact area's only and though it may be something graphics related due to the intense amount of users. I'll update soon if I still have the same issues.

part 2.PNG

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Rolig Loon said:

Popular clubs and shopping areas can be a real bear, and avatars put the heaviest load on your graphics system.  I have a GeForce 1070 -- just one step below your card -- and I have lag issues in crowded spots like everyone else.  Mesh avatars and mesh outfits have only made things worse. There's far too much complexity around us.  Keep trying to work with lower slider settings. Also, consider the possibility that your Internet connection may be part of the problem.  Get off of wifi if you can.  Many people have no trouble at all, but Linden Lab neither recommends nor supports wireless connections.  Reboot your router too, and check your ping and packet loss figures.

I can understand that Rolig, I put my settings down a little further and it fixed the issue for now. I'm using a ethernet connection (cat 6) on 350MBps connection.

Share this post


Link to post
Share on other sites
  • 0
Just now, Nalates Urriah said:

Your likely problem is the NVIDIA driver. 378.92 works well. There is something in the 381.65 that creates problems. For many they crash at login. 

The problem seems to be in NVIDIA's Shadowplay/Share. It doesn't matter if you use it. So, try disabling it.

Thanks Nalates,

 

I don't use Shadowplay and have it disabled always due to not needing it. I'll see about going back to my prior driver of 378.92 see if this helps.

 

I don't crash on login, it's only in high impact area's with a lot of people I noticed and it's not instantly but after a few minutes. I did as Rolig said and this has helped a lot on these locations in terms of crashing at random.

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, Whirly Fizzle said:

If you are only crashing in busy places, it's probably an out of memory crash, which is a common problem on any 32bit viewer.

Try out the LL 64bit Project viewer: http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Project_Alex_Ivy/5.1.0.503537

or the Firestorm 64bit viewer: Choose the " For SL & Opensim 64bit" version at http://www.firestormviewer.org/windows/

Are you still crashing on the 64bit viewers?

Thank you Whirly,

I will give this ago now. I know on all the viewers i have tried the max i can put for memory is 512mb although I am using an 8gb GPU & 64GB RAM

 

I shall give this a go and see how it goes.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Just now, Nalates Urriah said:

@storcker Binder

Your likely problem is the NVIDIA driver. 378.92 works well. There is something in the 381.65 that creates problems. For many they crash at login. 

The problem seems to be in NVIDIA's Shadowplay/Share. It doesn't matter if you use it. So, try disabling it.

Regardless of your settings, you shouldn't be crashing with your hardware. The viewers are working for lots of other people. The connection sounds awesome but, check your connection to the SL servers, not just the Internet.

If you have changed your Max Bandwidth setting, set it to 1,500. This is a UDP protocol only setting. It tells the SL server how fast to send you UDP data. The Firestorm team has tested the setting extensively. Over 1,500 on even a great connection causes more problems.

Test your memory chips.

Get the free app Memory History and see how much memory your system is using per app. Make sure you are not running out. A viewer using up all memory is the most common cause of crashes.

If you changed you Avatar Complexity to Unlimited, bump it back a notch to eliminate overly complex avatars and objects from crashing your video card. Griefers and novice designers build mesh that can overload a video card, even the best in the case of griefers. In one of the combat games I played some loved to wear video crashers into battle just to mess with us.

Thanks for the reply Nalates, I have set the setting in preferences to 3,000 which is the max it'll allow me to do in Catznip, on the SL Viewer i had it set to 10,000 but the same issue throughout. I must say, with changing the complexity it has made a huge difference, but  I was surprised this would cause such an issue with the setup. I'll try setting it exactly to 1,500 to see if this fixes the full issues i am having.

I've checked my memory and it's not all being used by any of my applications ram wise I am using 5% at most and for my GPU it's not using much around 25-30% with everything I have running. I've changed form 300,000 complexity to 64,000 which has caused the crashes to be less within the major area's I have went too.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Whirly Fizzle said:

The LL 64bit viewer still clamps texture memory to 512MB max.
Firestorm 64bit should automatically set texture memory to 2048MB on your card.

32bit programs running on a 32bit OS can only use a max of 2GB total memory before they will crash. SL viewers will reserve ~512MB memory for textures so you'll crash out at around 1.5-1.7 GB memory use.

32bit viewers running on 64bit OS are built with LAA (Large address aware) so they can use ~4GB memory max.  Again ~512MB is reserved for texture memory so you will crash at around 3.5 gig memory usage.
It's pretty easy to hit 3.5 gig memory on a busy region with lots of high poly mesh & large textures, which EATS into memory.

A 64bit viewer really has no memory limit.  The 64bit viewers should be happily still running at over 4+ gig total memory usage.

I've installed the 64bit SL Viewer and don't see the issues occurring. I have went through and made small changes in my graphics, advanced and network settings to assist within the game preferences. Appreciate the help.

Share this post


Link to post
Share on other sites
  • 0
Just now, Whirly Fizzle said:

Great!

Honestly with your system you should be just fine in pretty much all locations on Ultra graphics.

That's what I thought, I do a lot of mesh creation and graphics development on this machine which can be high impact but nothing really bad. I was surprised with this issue. From what everyone has said and what I have read via multiple forum threads, I believe it may be due to using 32bit viewers as most I have mentioned above as using are default 32bit and running out of memory in specific locations due to this.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, Lindal Kidd said:

I somewhat disagree with Rolig here.  A complexity setting of 350K should protect you just fine against graphics crashers.  (350K is the highest setting other than "Unlimited".)  Graphics crashers have insanely high complexities...in the millions.

I have it set back to 350k now on a 64 bit version of SL Viewer and had no lag or crashes since doing so.

 

I believe the major issue was using 32 bit instead of 64 bit with the settings.

 

By lowering the settings on 32bit, it made it usable but not beneficial for myself and the setup I am using.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...