Jump to content

help: mesh hitbox dosent fit to the meshs form

Recommended Posts

i builded a floorpart (with blender 2.78) and the hitbox dosent work like it should.

the hitbox ignores the red and blue faces completly and only formes a simple cube aroudn the hole thing so anytime trying to sand on the blue floorpart the av is hovering.

what do i have to do to get a workin hitbox for that floor?



Share this post

Link to post
Share on other sites

You have to make and upload a physics shape that you assign to the model in SL.  Then you need to make the model itself shape type PRIM instead of CONVEX HULL so that the indentations in your model are navigable.  It's the same exercise you would go through if you were designing a building with doorways that you need to be able to walk through.

  • Like 1

Share this post

Link to post
Share on other sites

You might want to look up PHYSICS MODEL in the archives as there is tons of info on that as well as walking through doors (another physics issue that comes up often). The term "hitbox" isn't used here -- at least I  haven't heard it in nine years :D so.  that might be confusing to some folks. 

You can test the idea simply over at the beta grid (free) by using Medium or High physics in the physics choices, analyze and then upload. In world change the physics type to PRIM (in the FEATURES tab).  Test and see how that works.  Making your own physics model may lower the land impact though, so looking into that method would be good. In some (a few) cases the uploader does an OK job with physics models. Others your REALLY need to make your own.  

Share this post

Link to post
Share on other sites


The ‘Hitbox’ is usually called the Collision or Physics mesh.

To have correct collision surfaces for your model you need to do 2 things :

          1: Tell the mesh uploader where you want to have the collision surfaces.

          2: When your model is rezzed inworld, set the Physics Shape type to Prim.

You can tell the mesh Uploader to use your High Lod model for Physics. This may be Ok sometimes but usually this will cause the final LI cost to be higher than necessary. Best is to create a simplified model and use that for Physics.

To do that, in your 3D modeling programme, make a copy of your Landscape Object and simplify it as much as possible. Only have geometry where you need to have collision surfaces. Then save it as a separate .dae file. (Landscape_Phys.dae) The fewer triangles/quads you use in this model the lower will be the Physics cost. One rule you have to follow is that the Bounding box dimensions  (X, Y and Z) of your physics model must be the same as the Bounding box dimensions of your visual (High LOD model).



Upload your Landscape.dae model as usual and then open the Physics tab of the mesh Uploader.

In Step 1 of the Physics tab upload the Landscape_Phys.dae file.

Don’t touch any of the other options in the Physics tab !

Hit the Calculate  button then Upload.




Rezz your model on the ground then Edit it.

Open the Features tab and change the Physics Shape Type from Convex Hull to Prim.


Now it should be walkable :)


Edited by Aquila Kytori

Share this post

Link to post
Share on other sites

I quite like 'hitbox' for Set of Collision Planes.  Anything to help the tired fingers.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...