Jump to content

HUD with media script doesn't work for some people.


OxfordLennox
 Share

You are about to reply to a thread that has been inactive for 1619 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello, I created a HUD with a media script inside. It works perfectly typically when worn as HUD or rezzed. But some people told me they only see a black screen and can't make it to be worked.

- One of them updated his Flash player and he is trying it in a script allowed land, he says it still doesn't load.

Hud doesn't have a video stream, just connecting to an outer web page, an easy script. I can't understand why only a few people can't make it worked for themselves, what may cause this problem?

Thanks kindly.

Link to comment
Share on other sites

@OxfordLennox  Can you please post the script, or at least tell us how the script works?

While I don't normally play guessing games, I infer from your saying "Hud doesn't have a video stream, just connecting to an outer web page, an easy script"  that you may be using shared media to play the video.  It that's the case, then have you established that the problem isn't simply that the people who can't make the HUD work don't have their preferences set to allow shared media to play for them?

  • Like 2
Link to comment
Share on other sites

Hud doesn't have a close option. It's a simple prim, simple script. Here is the product if anybody wants to give a try. In same location 4 people wear it at the same time, and just one of them can't use it. It's being an headache since I can't find anything wrong.

https://marketplace.secondlife.com/p/Gacha-Locator-HUD-Giver-Display-Touch-for-Free-copy-in-folder-FREE/8832135

Link to comment
Share on other sites

11 minutes ago, Rolig Loon said:

It sounds like Innula has probably identified your problem.  That object is nothing more than a prim that is set to use Shared Media (Media On A Prim -- MOAP).  It won't work for any user unless the user has set her own Preferences to allow the viewer to display streamed media.

None of those are ticked on mine, but it works when attached automatically. https://gyazo.com/9592a0c816ec9b1eb8c6bef8a859cb2f

Link to comment
Share on other sites

Your HUD is working fine for me on both the 32bit & 64bit versions of Firestorm release.
I'm using Windows 10 64bit.

64bit: Firestorm 5.0.1 (52150) Dec 10 2016 14:44:37 (Firestorm-Releasex64) with OpenSimulator support
32bit: Firestorm 5.0.1 (52150) Dec 10 2016 12:21:33 (Firestorm-Release) with Havok support

3ca7a69a547c445191ba32b67e751145.png

  • Like 1
Link to comment
Share on other sites

All I can think of is those who can't get the HUD working have general media fail - usually caused by their antivirus software blocking slplugin or llceflib_host from running.
Ask those that can't get the HUD to work if they can see http://gachalocatorhud.weebly.com/ in the viewer's internal web browser (CTRL+SHIFT+Z).

Also ask if the contents of the following windows populate:

  • FS: Avatar -> Choose an avatar, LL: Me -> Choose an avatar
  • FS: Avatar -> Profile -> Web tab, LL: Avatar -> Profile
  • World -> Destinations
  • Content -> Search -> Websearch.

Also ask them what operating system they are using.  Linux can be iffy with media,.

If they have media autoplay disabled, they will probably need to click on the HUD for it to load the web page too.

 

  • Like 1
Link to comment
Share on other sites

I tested first simple version of it and it worked without problems, but the one labeled LARGER TO FILL FORMS just appeared as a narrow beam. Then I tried the simple one and the default one again and now they also appeared as narrow beams not showing any content - detaching and attaching any of them did not help. So it seems, something is wrong in your script.

Just making a media prim with an URL to http://gachalocatorhud.weebly.com/ works without problems. And unless you do need to collect some kind of information internal in SL in your HUD, do you need a script to show the web-page?  Sometimes keep it simple is a better solution :-)

 

 

Link to comment
Share on other sites

5 hours ago, Rachel1206 Resident said:

Just making a media prim with an URL to http://gachalocatorhud.weebly.com/ works without problems. And unless you do need to collect some kind of information internal in SL in your HUD, do you need a script to show the web-page?  Sometimes keep it simple is a better solution :-)

 

 

I just want people to teleport by the hud, that's all. (= And thank you all for kind answers. One of the people told me their shared media is turned off and when turned on it seems to be worked. I think yeah this is solved. Problem is found. You are all awesome helps!

  • Like 2
Link to comment
Share on other sites

5 hours ago, Rachel1206 Resident said:

I tested first simple version of it and it worked without problems, but the one labeled LARGER TO FILL FORMS just appeared as a narrow beam. Then I tried the simple one and the default one again and now they also appeared as narrow beams not showing any content - detaching and attaching any of them did not help. So it seems, something is wrong in your script.

 

Are you using Mac? Some Mac users had some people with the hud as internal viewer, so I had to add extra buttons to the page to search in page. Can you please show me a photo?

Link to comment
Share on other sites

11 minutes ago, OxfordLennox said:

Are you using Mac? Some Mac users had some people with the hud as internal viewer, so I had to add extra buttons to the page to search in page. Can you please show me a photo?

No, I am using Windows 10 64-bit (Build 14393), viewer Firestorm 5.0.1 (52150).

Attached picture shows how the HUD looks for me using Attach HUD to->center. Tried to click it, if it would open, nothing to do.

20170411_hud_problem.png

Link to comment
Share on other sites

I think the problem with the HUD alignment is that it's not constructed so that the lesser x axis of the root prim (face 4 if it's a regular box) is facing the user's screen.   You have the lesser y axis facing the screen. 

The reason for this is that ZERO_ROTATION is the default rotation for HUDs, so you want to be looking, by default, at the back of the root prim.

This is the most important thing there is to know about HUD-building, to my mind.   It's the only way to be sure that HUDs are correctly positioned on all types of screens.   If you ignore this precaution something always goes wrong sooner or later.    What Rachel describes is an example of this -- her HUD has attached itself at ZERO_ROTATION, I am sure.

Edited by Innula Zenovka
  • Like 1
Link to comment
Share on other sites

@Whirly Fizzle   I still can't get the HUD to work in FS, though it works OK in the regular viewer and Catznip both.

Using 

Firestorm 5.0.1 (52150) Dec 10 2016 14:44:37 (Firestorm-Releasex64) with OpenSimulator support
OS Version: Microsoft Windows 10 64-bit (Build 14393)

I tried all your tests, and everything loaded as usual.

On a related note, why is Allow media to auto-play checked but greyed out for me in FS?   That is, I can't seem to stop media from autoplaying, should I want to.    5d33c9a154d1896c782881fb8d93ea0a.png

Link to comment
Share on other sites

19 hours ago, OxfordLennox said:

Interesting. I think something caused it to rotate. Can you please try to rotate it? Or what does happen when it is rezzed?

Ok, I can rotate it 270 degrees around the Z, it will show correct.

I normally make a HUD with content to be displayed on face 4 and where face 4 is facing west, when rezzed on ground. When the HUD is attached it displays correct with face 4/content.

Edited by Rachel1206 Resident
  • Like 1
Link to comment
Share on other sites

2 hours ago, Innula Zenovka said:

@Whirly Fizzle   I still can't get the HUD to work in FS, though it works OK in the regular viewer and Catznip both.

Using 


Firestorm 5.0.1 (52150) Dec 10 2016 14:44:37 (Firestorm-Releasex64) with OpenSimulator support
OS Version: Microsoft Windows 10 64-bit (Build 14393)

I tried all your tests, and everything loaded as usual.

On a related note, why is Allow media to auto-play checked but greyed out for me in FS?   That is, I can't seem to stop media from autoplaying, should I want to.    5d33c9a154d1896c782881fb8d93ea0a.png

This is a recurrent bug in Firestorm. Try to hold your mouse over the speaker symbol top right and toggle the check boxes you see.

  • Like 1
Link to comment
Share on other sites

4 hours ago, Rachel1206 Resident said:

This is a recurrent bug in Firestorm. Try to hold your mouse over the speaker symbol top right and toggle the check boxes you see.

Hmm that bug should be fixed on the latest release.  I'll poke at it & see if I can reproduce it.

Old bug report is at: FIRE-15057 - "Allow media to autoplay" & "Allow Audio to autoplay" preference options show greyed out/lit up when they should not be.

  • Like 1
Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1619 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...