Jump to content
Sign in to follow this  
Suki Hirano

How to prevent holding pose from getting overridden?

Recommended Posts

I uploaded a holding object pose at priority 5, which theoretically should make sure it's not overridden by anything. But the pose is still getting overridden whenever I sit, turn, or use poseballs. Why is this? Does it have something to do with the animation only activating when I'm in standing state? How do I set it to override EVERYTHING to make sure my holding object pose is always active?

 

Thanks.

Edited by Suki Hirano

Share this post


Link to post
Share on other sites

Dids you drop this pose in an AO as a stand? If so, when the AO detects that you turn or sit etc, it changes from the stand pose to a different one, thats kinda what AO's are supposed to do, to kave that holding pose work consistantly, you'd want it in a seperate attachment (or a chile prim of the ao) with its own short script that gets anim permissions and  starts the anim when attached. You might also need to remake the pose, so it only anumates the arm/arms doing the holding, if you made it as a full stand with leg posze as well, you've spend a lot of time sliding around like a greased statue.

 

Share this post


Link to post
Share on other sites
3 hours ago, Klytyna said:

Dids you drop this pose in an AO as a stand? If so, when the AO detects that you turn or sit etc, it changes from the stand pose to a different one, thats kinda what AO's are supposed to do, to kave that holding pose work consistantly, you'd want it in a seperate attachment (or a chile prim of the ao) with its own short script that gets anim permissions and  starts the anim when attached. You might also need to remake the pose, so it only anumates the arm/arms doing the holding, if you made it as a full stand with leg posze as well, you've spend a lot of time sliding around like a greased statue.


 

No it's not in an AO, it's in an attachment. Yes I only posed the arms, not rest of body, so I can walk around normally.

 

Update 1: something weird I noticed is if I try to set priority 5/6 in bvh upload previewer, set it to loop, and playback, whenever I turn/sit on couch/poseball the playback itself would pause. This is different from setting it to priority 1/2 where the playback itself won't pause, but obviously get overridden on my avatar. So the problem is not the anim getting overridden, it's pausing whenever I turn/sit.

Update 2: while scripts might solve the issue, I found it's possible to accomplish this without scripts as I just checked one of Marine Kelley's cuff poses. I turned off my AO to make sure no anims are playing, then played one of her anims, it's priority 6 in animation explorer, and it's not getting overridden by anything. It's doing this without help of any scripts as I simply just doubled clicked the anim object.

Edited by Suki Hirano

Share this post


Link to post
Share on other sites
55 minutes ago, Suki Hirano said:

Update 1: something weird I noticed is if I try to set priority 5/6 in bvh upload previewer

Priority 6 is the highest priority. This can only be done using the .anim format, not bvh, and definitely not using the uploader.

Share this post


Link to post
Share on other sites
Just now, Medhue Simoni said:

Priority 6 is the highest priority. This can only be done using the .anim format, not bvh, and definitely not using the uploader.

I tried uploading priority 5 but same thing happens.

Share this post


Link to post
Share on other sites
3 minutes ago, Suki Hirano said:

I tried uploading priority 5 but same thing happens.

As I was explaining, animation above priority 4 must be uploaded using the .anim format, which currently can only be made in Blender, using the Avastar addon. The SL uploader can not upload animations above priority 4. Priority 6 is the highest priority using the .anim format.

Edited by Medhue Simoni

Share this post


Link to post
Share on other sites
Just now, Medhue Simoni said:

As I was explaining, animation above priority 4 must be uploaded using the .anim format, which currently can only be made in Blender, using the Avastar addon. The SL uploader can not upload animations above priority 4.

Ah I see. So even if it shows priority 5/6 in bvh uploader preview, as well as animation explorer after I upload it, it's really 4?

Was this a recent change? Because long time ago I remember the priority 5/6 hack (editing anim.ini or the bvh preview xml file) actually made them priority 5/6, that's how creators were able to create their restraint poses.

I tried creating an anim version of my bvh as well through Blender Avastar, however after I export the anim my avatar's entire body is stiffened, seems the .anim that was exported set every single bone in the body to priority 6, despite most of them being neutral at 0,0,0, where this is simply ignored if it was .bvh file. Is it possible to do this with .anim format? Maybe set the bones that I don't want to animate as priority 0 or -1?

Share this post


Link to post
Share on other sites
11 minutes ago, Suki Hirano said:

Ah I see. So even if it shows priority 5/6 in bvh uploader preview, as well as animation explorer after I upload it, it's really 4?

Was this a recent change? Because long time ago I remember the priority 5/6 hack (editing anim.ini or the bvh preview xml file) actually made them priority 5/6, that's how creators were able to create their restraint poses.

I tried creating an anim version of my bvh as well through Blender Avastar, however after I export the anim my avatar's entire body is stiffened, seems the .anim that was exported set every single bone in the body to priority 6, despite most of them being neutral at 0,0,0, where this is simply ignored if it was .bvh file. Is it possible to do this with .anim format? Maybe set the bones that I don't want to animate as priority 0 or -1?

I'm sure there is a hack to change the bvh or anim, but I've never used it.

In Avastar, you don't need the bones that are set to zero in the dopesheet, or action editor, at all. You eliminate the bones entirely, which results in those bones not in the animation, not being controlled by the animation.

Share this post


Link to post
Share on other sites
3 minutes ago, Medhue Simoni said:

So even if it shows priority 5/6 in bvh uploader preview, as well as animation explorer after I upload it, it's really 4?

Yes, Exactly!

Share this post


Link to post
Share on other sites
On ‎3‎/‎28‎/‎2017 at 8:52 AM, Medhue Simoni said:

I'm sure there is a hack to change the bvh or anim, but I've never used it.

In Avastar, you don't need the bones that are set to zero in the dopesheet, or action editor, at all. You eliminate the bones entirely, which results in those bones not in the animation, not being controlled by the animation.

By removing the bones, do you mean simply removing them in edit mode or just making sure they're not in action editor? I checked action editor but it still didn't work, when I upload the anim I'm still stuck in the T-pose. Now I can't even get the pose to play at all for some reason, even though I clearly see it in Blender... it's as if the .anim is only uploading the first frame (t-pose), and ignoring every single frame after that.

As you can see in below image only the joints affected by the holding object pose are in the action editor, everything else is blank.

Untitled.png

Edited by Suki Hirano

Share this post


Link to post
Share on other sites

You don't need a Tpose in the anim format.

You remove the bones from the Action Editor, which is an option under the Dope Sheet button. Just select the bone in the Action Editor, and then type x, to delete it.

Here, I'm animating only the right arm, the right finger bones, and also the hand attachment point.

1d29474f1a93b9d1eb60cf9eb8b9bea4.png

Edited by Medhue Simoni

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...