Jump to content

Strange Issues With Firestorm


You are about to reply to a thread that has been inactive for 1738 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

So ever since I got my new graphics card I've been noticing some strange issues I have though this only seems to happen with the Firestorm Viewer.

My first main issue is that no matter what I do I cannot get anti aliasing to work, I've tried setting it from 2x all the way upto 16x with no change whatsoever. I have a work around where I can manually set it to work through the Nvidia control panel but that can be a pain.

The next issue is whenever I take pictures inworld I can see the depth of field working perfectly inworld but once I take the image and save it poof no depth of field whatsoever. I've tried doing the save in different resolutions with no change at all.

This is my PC Info: 

CPU: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz (2993.21 MHz)
Memory: 16348 MB
OS Version: Microsoft Windows 10 64-bit (Build 14393)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 960/PCIe/SSE2

Windows Graphics Driver Version: 21.21.0013.7866
OpenGL Version: 4.5.0 NVIDIA 378.66

Is this something to do with my GPU, my CPU? My Memory? I'm at a complete loss on what the heck is causing all these issues.

My last and final issue is more well internet related I think. I've noticed even without having shadows on I can lag in certain places but when I have shadows on no matter where I go my FPS drops quite a lot. I'm talking from 60fps all the way to 7fps. I'm not sure if that's something to do with my internet, where I am located in the world, my ping etc etc. If you need to know details about my speeds, ping etc etc let me know.

Has anyone heard of anything like these issues happening before?

I'd truly appreciate any help as I'm getting a little fed up with these issues lol.

Link to comment
Share on other sites

Anti aliasing problem

Do you have Advanced Lighting Model (ALM) enabled under Preferences -> Graphics -> General?
AA behaves differently when ALM is enabled & disabled.
If you enable ALM and then relog - does anti aliasing then work for you?

If you have ALM enabled then disable ALM, AA will be broken unless you relog or enable ALM again.
The AA setting of 2x, 4x etc only works when ALM is disabled.  When ALM is enabled, the AA setting is fixed & the value you set for AA in preferences has no effect, AA is either on or off.
Also note that 16x AA won't work well on a lot of cards, kit's best to avoid that setting.

DOF problem

Is DOF still missing in your saved snapshots if you take the shot at the current screen size?
DOF does not scale with the resolution of the snapshot, so if you take a snap at a higher resolution, the DOF effect in the saved shot will be reduced.

Lag with shadows

Your system should be capable of running shadows without too much of a performance hit.
Check that you don't have your shadow settings pushed up too high in phototools - that can really case a nasty performance drop.
Top menu bar of the viewer -> World -> Photo & Video -> Phototools
Under the Light (and DOF/Glow for good measure) tabs, click all the D buttons to set those settings back to default & see how your shadow performance is then,

 

 

Link to comment
Share on other sites

Hi Whirly thank you so much for your responses

Ok so I tried turning of ALM and I have AA but as soon as I enable ALM again my AA goes away. Think I'll have to just stick to doing my AA manually

Ok DOF problem now I feel really really dumb because when I lower it to my current screen size I have DOF and if I go bigger it looses the DOF but it's still there. I guess I was saving my images way to high resolution lol.

Ok so my lag issue isn't happening when I had shadows on at the moment lol. I checked my Phototools tab though and everything is set to default, I clicked the D though just in case on those tabs.

Link to comment
Share on other sites

Thanks.

Hmm yeah I see what you mean - the avatar outline is pretty jaggy on the ALM enabled image.
Does this still happen if you keep ALM enabled but disable depth of field?
When ALM is enabled & DOF is disabled, does AA also fail on objects rezzed inworld or is it just the avatar details that look jaggy?

You said the problems only happen on Firestorm.
Which other viewers have you tried?
If you have not already tested on the LL viewer, can you give it a try?  You can download the LL viewer here: https://secondlife.com/support/downloads/

You should still see the DOF scaling problem on the LL viewer.  As far as I'm aware no viewer scales DOF with screen resolution.
I'm more interested if AA is working ok for you on the LL viewer when ALM is enabled.

Link to comment
Share on other sites

Well checking this by the looks of it enabling ALM and disabling DOF I still have jagged edges but not as bad

adf1763873333ad243ce45b390968cac.png

again with DOF on objects, disable it and I have jagged edges.

72e6a061a5318ec364d4cf870dbcd6da.png

I just checked the main viewer and it seems I have jagged edges issues all with that as well. So it is with the other viewers, I thought it was just Firestorm. I haven't actually checked with Catznip or Singularity but I'm assuming if I'm having the issue with the main viewer it'd be the same with those as well.

Edited by Belinda Millet
Link to comment
Share on other sites

OK, completely off the wall thought... You said you use an nvidia card, nvidia config utilities have options for AA, specifically if the nvidia utilities should set it or if it is controlled by the application, have you checked what settings you have, might have been altered by a recent driver upgrade or something, worth a quick check just to eliminate a possible suspect.
 

  • Like 1
Link to comment
Share on other sites

Hi Klytyna!

Ok so with nvidia I used the control panel to fiddle with the settings. Go into the manage 3d settings and then change the program settings for firestorm.

So it looks like this. I've had this issue since I got the card which was about just over 6 months ago, I've just always had to let the control panel handle everything otherwise no AA lol.

67276409f9d36fa2b89d95b43f6ee574.png

Link to comment
Share on other sites

Belinda. 

My experience with a GTX980Ti is that AA in FS out of ALM is just plain broken.  I tried using the Nvidia control panel to set up FS when ALM is off and it (FS) just does not recognise the setting.

! know that using the same setting in Antialiasing that ALM uses (FXAA) in the Nvidia control results in blurred text so that's a "no-no".

I don't know what causes it but it's been like this for several iterations of FS and another Nvidia GPU (GTX580).  So what's going on Whirly?

Link to comment
Share on other sites

THe force AA settings despite app option has always had problems with user interfaces, not just with SL but across the board, see, a game engine uses AA on the world render, then layers an un-aa user interface over the top, so its clear, but... forcing AA via the nvidia control panel does AA on the whole damn screen including the UI, hence blurred text etc. The AA detects those nice crisp edges of the letters and blurs them,

If you are getting no AA whicvh alm on despite stomping on the viewer with the  card control panel, try unstomping ? Set to 'let application decide' and if that fails, try a non FS viewer, say Black Dragon, as I can't imagine nirans letting ALM kill their AA settings, nirans obsesses over graphics quality to a degree that puts FS to shame. if FS really is broken or worse SL codebase is broken (which would mean its copied to other third party viewers) then nirans' Black Dragon may become your photo viewer while FS gets relegated to 'no AA general play' viewer
 

Link to comment
Share on other sites

I'll try setting it to let the application decide just in case but I don't mind seeing the blurred text lol, I never really notice the blurryness to it.

I'll have a look at Black Dragon and see how that one looks, I tried it once a long time ago I do remember the interface was something to get used too lol.

Link to comment
Share on other sites

OK, again just my experience.  Having wisely given up using the forcing of AA settings on FS, "let the application decide" "should" work, in FS it doesn't.  Dunno why but it just doesn't!

I'll have a look at Black Dragon but I used one of Niran's earlier iterations and to be perfectly frank I was NOT impressed.  Again just me, nothing untoward, just a preference.

I'd REALLY like to know why this is because there are a few situations where I do not use ALM even with my 980Ti (I need the frame rate as high as possible since I am moving rapidly and while the sim may not refresh at more that 45FPS, I need the instantaneous control that a high FPS gives me (ping and lag notwithstanding).

Edited by Ayesha Askham
Link to comment
Share on other sites

  • 2 weeks later...

Ok bit late I know lol but I finally got around to trying Niran's viewer and btw that viewer is awful to navigate but I found I'm still having the same issues with my AA, it seems it doesn't matter which viewer I'm using I have no AA unless I manually set it via Nvidia Control Panel.

Link to comment
Share on other sites

  • 8 months later...

I know this is an old thread, but to clear the air. When you take snapshots with SL, shadow blurring and DoF effects do not scale when you scale the image. That is why in your larger size snapshots they are still there but become less the larger you make your image. The only way as you've discovered to get what you see, is to snapshot at your current screen size. Which unfortunately does not lend itself well for when it comes to editing. Because its nicer to have a larger image to work with

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 1738 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...