Jump to content
Sign in to follow this  
Ruud Carpool

Slow FPS with excellent computer.

Recommended Posts

Hello people,

Whenever I start up Secondlife in any viewer the lagg I have is horrible! sometimes I can count up to 10 seconds for another frame to come up, I think my maximum is at about 5 frames per second but I am very lucky when I have that. My computer is 100% fine and I can run anything on full settings and I mostly have even more than a 100 FPS with large games like the Total War series.

I tried everything I can to fix it, but still I did not find a solution which even helps to get a few more frames per second...

Anyone else has this problem? and have you found a cure? would love to know if someone did...

My system specs(the ones I know):

  • Motherboard:Asus P8H67-M PRO iH67, SATA600, USB 3,0 RAID
  • Processor:Intel Core i7 2600 3.40 GHz 8MB Box
  • Memory:2x4GB
  • Graphics Card:XFX PCI-e Radeon HD6950 2GB 2xDVI/HDMI/2xDP
  • Hard Drive:2TB
  • OS: Windows 7 Home Premium 64 Bit
My drivers are up to date.

Share this post


Link to post
Share on other sites

Hi Ruud!

When I had this problem, I increased my bandwith under Preferences, and it seems to have fixed the problem. But be careful, if you are an AT&T subscriber, they are limiting your monthly bandwith, so be careful not to allow SL to take to much.

Goodluck!

Kolby

Share this post


Link to post
Share on other sites

that isn't a Crossfire system is it? we had another thread where Crossfire doesn't play well with SL... everything acts normal EXCEPT the frame rate in that setup.... if it is, disable crossfire and try again.

if it's not, it might help to know what you network stats and frame rate look like.

you can find those by opening the advanced and debug menus (preferences advanced). and then pressing atrl+shft+1. at the top of that new window you'll see your framerate (it should be well over16 normally, in your case it should be running in the 30's I would think), and farther down you'll see items for network bandwidth, and more importantly, packet loss and ping time.

Share this post


Link to post
Share on other sites

Can you give us the system info from About Second Life in the help menu?  That'll tell us everything we need to know about your computer's configuration.

Share this post


Link to post
Share on other sites

From your specs I think you are running a system with ATI Crossfoire enabled, I had the same problem a few days ago, the only viable solution I could find was to disable crossfire when I play in SL, SL doesn't seem to play well with ATI crossfire setups for some reason. Now that I run with crossfire disabled I get my usual smooth running SL again, though at a slightly lower frame rate than other things run at...but it's still 25+ with Ultra settings so not too bad.

 

Share this post


Link to post
Share on other sites

Things which might also help for anyone to find the problem,

It isn't the game itself.. but the viewer(any viewer). Login screens are as slow as after logging in.

I dont have the latest update on my driver and cannot even install it, whenever I try it I only get a blackscreen..

Share this post


Link to post
Share on other sites

I'm not so quick to fault the viewer, but rather the drivers provided by the OEM for Windows.  How does the same machine perform under Linux?

Share this post


Link to post
Share on other sites

I am no computer expert, never tested that out and OEM=Original equipement manufacturer? anyways.. the computer is fully made out of components I all ordered seperatly(well someone else did it for me...). The software was also ordered there.

Share this post


Link to post
Share on other sites

 


Ruud Carpool wrote:

I am no computer expert, never tested that out and OEM=Original equipement manufacturer?

 

Yes.

 


Ruud Carpool wrote:

anyways.. the computer is fully made out of components I all ordered seperatly(well someone else did it for me...). The software was also ordered there.

I'm pretty sure you didn't design and build your own graphics adapter and write the drivers for it yourself.  I suppose it's possible, but that'd be extremely exceptional.

 

Share this post


Link to post
Share on other sites

This sounds a lot like the exact same problem I have been having.

Here are my specs:

CPU: Intel Pentium Pro/2/3, Core (Unknown model) (3333 MHz)
Memory: 12279 MB
OS Version: Professional  (Build 7600)
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Radeon HD 5900 Series
Windows Graphics Driver Version: 8.17.0010.1041
OpenGL Version: 4.0.10151 Compatibility Profile Context

libcurl Version: libcurl/7.20.1 OpenSSL/0.9.8j zlib/1.2.3
J2C Decoder Version: OpenJPEG: 1.4.0.635, Runtime: 1.4.0.635
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.5.2

I made another thread about this too where I give all the details of my situation but one thing I would like to say right here is that I KNOW that this system can run Second Life because it has done it many many times before.

Share this post


Link to post
Share on other sites

Fix

Hitomi Heron(and anyone else who might have the same problem I had),

A friend of me found a simple fix that you need to do everytime when starting up Second Life.

Whenever you start it up you just wait for it to get into the login screen, then you press ctrl-shift-escape to open up 'Task-Manager'. There should be a few tabs on the top of which one is called 'Processes', Click this one and look for the Second Life viewer process. Right click on it once you found it, and select the affinity option and a new screen should pop-up in which there are several processors selected. Deselect all but one, and now Second life should run smooth if you have the same problem as I had..

It really worked well with me, I now got the Hz that I usually have with other games and programs.

Share this post


Link to post
Share on other sites

 


Ruud Carpool wrote:

Whenever you start it up you just wait for it to get into the login screen, then you press ctrl-shift-escape to open up 'Task-Manager'. There should be a few tabs on the top of which one is called 'Processes', Click this one and look for the Second Life viewer process. Right click on it once you found it, and select the affinity option and a new screen should pop-up in which there are several processors selected. Deselect all but one, and now Second life should run smooth if you have the same problem as I had..

 

 

You're kidding me, right?  It's 2011 and Windows still doesn't do multiple threads correctly?

 

Share this post


Link to post
Share on other sites

It seems so, though when there is to much around me in Second Life I will still get a little lag.. Does this have to do with the 'not enough processors' part?

Share this post


Link to post
Share on other sites

 


Ruud Carpool wrote:

It seems so, though when there is to much around me in Second Life I will still get a little lag.. Does this have to do with the 'not enough processors' part?

No, I run on an older machine, a laptop no less, and still pull framerates that are from merely usable in high traffic locales to fully vehicle-ready on the highways and railways.  However, my choice of OS doesn't include a fundamentally broken scheduler, which likely helps.

 

Share this post


Link to post
Share on other sites

Hey There, I aslo got FPS problem in SL on some places where friends of me with a slower PC is running 60 fps and I got 10 or less with a PC which is just running great on other new games :x.

 

Maybe someone can help me pleeaaase : ((((

 

Manufacturer: Gigabyte Technology Co., Ltd.

Processor: Intel® Core i7 CPU 920 @ 2.67GHz (8 CPUs), ~3.3GHz

Memory: 12288MB RAM

Hard Drive: 1 TB Total

Video Card: NVIDIA GeForce GTX 580 Phantom

Monitor: HP w2207

Sound Card: Lautsprecher (2- Realtek High Definition Audio)

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_gdr.101026-1503)

Motherboard: abit Fatal1ty FP-IN9 SLI

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...