Jump to content
LeslyWolfy

AO screwed up my default walk animation

You are about to reply to a thread that has been inactive for 83 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Am not sure if am posting at the right place!  (excuse my english! )

Am having a bit of a problem, the other day I bought what it seems.. a faulty AO, after turning it off, my default walk animation seems choppy and lags everytime, I have a beasty computer and a nice internet conection, so thats not a problem, all the other animations work smoothly, turning,jump,fly, those seem fine, except for my walk animation, I also tried to using other walk animations!... but seems to me that it still playing the default choppy walk animation.. I tried restarting, uninstalling, clearing cache and all the other fixes but no luck.., am using the newest version of firestorm btw AND people notice my walk animation work fine, but I still can't use other walk animations..

Share this post


Link to post
Share on other sites

I'm not totally sure what the problem is, but it sounds like a common bug that I've seen related to using the llsetanimationoverride script function. If you take off that AO, and relog, then you should be fine.

Share this post


Link to post
Share on other sites
Posted (edited)

I am seeing that some issue with some bento tails and wings now :/

Though in my case the issue was an incompatibility between the firestorm AO (which I didn't turn on intentionally) and the wings. Disabling it removed the issue for me.

image.thumb.png.c909b48cdbdf658b97a1815e86a8d52c.png

In hindsight probably unrelated to the original issue, but I leave this here as a hint for others coming to this thread with the same problem.

... or not, I think the problem returned shortly after, or maybe I misjudged it as being solved in the first place.

Edited by Noel Loordes

Share this post


Link to post
Share on other sites
Posted (edited)

I found a fix specifically for when the issue is caused by an ZHAO-II based AO.

  • Acquire a modifiable version of the "ZHAO-II-core" script. (In my case version 7-29.1).
  • In the control(key ...) event handler, Comment out the lines
                        if ( haveWalkingAnim ) {
                            llStopAnimation( "walk" );
                            llStopAnimation( "female_walk" );
                        }
  • Replace the "core" script in the attachment with the modified one.
Edited by Noel Loordes
  • Thanks 1

Share this post


Link to post
Share on other sites
You are about to reply to a thread that has been inactive for 83 days.

Please take a moment to consider if this thread is worth bumping.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...