Jump to content

LOD issues in the upload menu and the dreaded MAV_Block_missing invalid asset error!


Isfrael Blackheart
 Share

You are about to reply to a thread that has been inactive for 2024 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Can someone please help me remedy this?

There are no ngons, it could be lower poly but is not too dense for the uploader, by any means and my materials are set correctly. I imported the item into a different scene and exported, no luck. I'm out of ideas :/

Also, screenshot below, as you can see, sometimes it does not give an error, but the LI is outrageous and no matter how much I lower the LOD values, it stays stuck at 4.8k tris/3k verts.

 

https://gyazo.com/5e85b4fb1f748c7e61018cd3f0284b9c

 

Update: the problem was that the uploader was automatically merging verts that were too close together

Link to comment
Share on other sites

  • 1 month later...
On 2/12/2017 at 0:22 AM, Isfrael Blackheart said:

Can someone please help me remedy this?

There are no ngons, it could be lower poly but is not too dense for the uploader, by any means and my materials are set correctly. I imported the item into a different scene and exported, no luck. I'm out of ideas :/

Also, screenshot below, as you can see, sometimes it does not give an error, but the LI is outrageous and no matter how much I lower the LOD values, it stays stuck at 4.8k tris/3k verts.

 

https://gyazo.com/5e85b4fb1f748c7e61018cd3f0284b9c

 

Update: the problem was that the uploader was automatically merging verts that were too close together

It means that you have no LOD meshes present and your mesh is composed of multiple materials. As far as I know , under certain conditions the uploader won't generate any LODs using fewer triangles because it wants to keep all the materials present for each LOD . I only know this because occasionally I upload test meshes without LODs and encounter this behavior. The only way to get lower land impact is to create the LOD meshes yourself rather than letting the uploader make them for you. You will need to make sure each LOD contains all the materials in the exact same order or the it will most likely fail. You could look at this Youtube LOD tutorial for second life  for starters.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2024 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...