Jump to content
Sign in to follow this  
Sylvia Wasp

Dialogue "boops"

Recommended Posts

hello, 

I am writing a linkset re-sizing script and have it all working fine but there is one truly horrible behaviour that I want to suppress.  I've searched quite a bit and can't find any references to it so I'm asking the simple question here.

- Is there any way at all to stop the dialogue from making the awful "boop" sound, every single time you click a button?  

I'm guessing not because its' something one has to suffer on every "Adjust" script as well but surely this must bother other people to the degree that someone has found a way to mask it out?  

I'm assuming that it's the default sound the menu makes when it appears and that because of the way re-sizing scripts and adjust scripts are written, that the menu is "called" or recreated after every button press?  

I find it hard to believe that many thousands of others have not been driven crazy by this maddening "boop, boop, boop" nonsense and that Linden Labs hasn't found a way to suppress it.  

thanks for any help, 

Sylvia

Share this post


Link to post
Share on other sites

I never even notice it now.  It's a "feature" of LSL.  :smileytongue:

Oh, and whether the menu reappears after a button press ... that's entirely up to the scripter.  Generally speaking, though, most of us will make a menu reappear if it's likely that the user is going to need to make other choices.  People tend to get testy if they are forced to keep re-opening a menu every time they want to make a choice.

Share this post


Link to post
Share on other sites

Thanks Rolig, 

Sadly, I suspected as much, but I was hoping someone had come up with some fancy script magic to stop it.  

When SL dialogues are used for adjusting and resizing scripts, the buttons need to be pressed dozens of times in succession so it makes sense to make the menu re-appear.  

The noise, along with the visible screen redrawing of the menu is enough to give one a migraine, but if it's all we have then it's better than nothing I suppose. 

 

Sylvia

Share this post


Link to post
Share on other sites

anyone can mute the "boop" sound in their preferences...

if they don't want to hear boops, they won't :)

in Firestorm viewer its .. Avatar > preferences > sound & media > UI sounds 2 > script dialogs (uncheck)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...