Jump to content
Sign in to follow this  
Jasmin Helstein

bumpy ends after bending a sculpt ?

Recommended Posts

Hello everyone

I am trying to make cylindrical shaped sculpts in Wings3D. The straight ones are perfect but as soon as i bend them the ends become bumpy. In SL they become bumpy that is,  after i've bended them they are still perfectly flat in Wings3D. I've tried bending the cylinder without the edges, then rotate the edges separately and move them into place but that has the same result.

Is there anything I can do to prevent this from happening or is it normal ?

Thanks

Share this post


Link to post
Share on other sites

Some pictures might help. One thing I have seen is that when you change the shape, you can end up changing the bounding box of the over all sculpt. Since you have only 256 steps along any axis of the bounding box, if you stretch one axis too much, a change in, say, the x-axis of 1 between two vertices can result in very strong visual step. That might be what you're seeing, but it depends on how you're bending the shape, I would think.

Share this post


Link to post
Share on other sites

This problem is directly related to the fact that the vertices of sculpted prims only have 256 possible locations along their bounding-box axes. This is so because the color channels are only 8 bit wide and thus can only contain numbers from 0 up to 255. Lets make an example. Here you see 3 cylinders made with a 3D editor:

endcap-2.pngendcap-3.pngendcap-3.png

You now clearly see (click on image for details) how bad the endcaps can get when you do not take the sculptie grid into account.

Please also note that the problem gets more and  more apparent when the object bounding box gets longer and longer in one dimension (see the leftmost object). This is so because the 256 possible locations are uniformly distributed along the bouding box dimension. And thus the longer the dimension is the wider is the gap between 2 allowed locations along the grid. And the more apparent the problem shows up at the ends.

Your best option to avoid this problem: Follow the sculptie grid when you do your modelling.

Share this post


Link to post
Share on other sites

 


Jasmin Helstein wrote:

I have done that allready, for nice edges you should do that anyway and the straight sculpts do look perfect. The rotating is what couses the bumps i think.

You should consider to bake sharp edges into your textures instead of using collapsed edge-loops. Here is a more indepth article about why the edges do not look sharp by default, and why collapsing edge-loops make sharp edges:

http://blog.machinimatrix.org/3d-creation/vertex-lighting-in-sl/

Instead of collapsing the edge-loops i propose to bevel them. mathematical streight edges are one of the reasons why Second Life sometimes looks like made of Lego-bricks ;-)

Share this post


Link to post
Share on other sites

I've never seen anything like a grid :smileysad: but maybe it helps if i look better. I don't think it will work for what i'm making right now though as that definately needs flat surfaces. So ... i have to find an other way of doing it i suppose.

Thank you verry much for your explanation Gaia, it makes it a lot clearer to me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...