Jump to content

Objects I cannot see that others can

You are about to reply to a thread that has been inactive for 2582 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I find there are objects I cannot see that others can. When I visited the SAIS Village sim I found myself standing over water. From there I could see no walls on the land, just windeows, doors, fireplacess, and a few but I suspect not all, avatars. In later IM conversation with someone I met there then I found out I was standing on a large ship I never saw. There also had to have been a dock that I also never saw, because I saw other avatars walk over water too and from where I was standing. I have not experienced this at any other sim.

Now I have similar problem on a much smaller scale with a set of bondage gear that are included with my membership at Serenity Lost. The wrist and ankle cuffs I can see. The elbow cuffs and blindfold I cannot. So I went to the Serenity Lost Safe House to find out if others can see them. They could so I thought at the time I have a viewer issue. But later I found I still cannot see these items in the Linden Labs Viewer.

In Firestorm I am able to open the editor on these bondage items I cannot see by left clicking on the item's listing in Inventory and selecting Edit. The Edit window opens, and the location of the item is shown by the red, green. and blue 3D cursor that displays the item's 3 axis. If in the Edit window I checkmark the "Show Highlight" checkbox I am able to see the item in highlight.

What has gone wrong here? Why is it that only I am unable see these items when not highlighted?

I am using the 64 Bit Firestorm viewer version 5.0.1 (52150) in Firestorm mode in Ubuntu 16.04.1 LTS with 16GB Memory.

Graphics Card info:

      description: VGA compatible controller
       product: GK104 [GeForce GTX 760 OEM]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:31 memory:fc000000-fcffffff memory:d0000000-d7ffffff memory:d8000000-d9ffffff ioport:e000(size=128) memory:fe000000-fe07ffff

Link to comment
Share on other sites

I normally find restarting the viewer downloads stuff that has decided not to rezz. But this sounds different.

If the Linden Viewer  and firestorm are sharing your cache, then it is worth clearing it and letting it rebuild. It may be that something has got cirrupted in there.

You could also try checking the bandwidth allocation you have given to the viewer. You might think more is better on that slider, but that isn't necesarily so as the higher you put it the more errors you will get. Try turning that setting down and seeing if that helps. Firestorm recommend 1000kbs for ADSL, it may be that even lower is better for you. I run mine around 500kbs (my internet is not much more than 2mbs).

Note that textures are delivered now by html so that setting doesn't throttle texture download speed.... infact turning it up high can throttle textures because it is reserving internet speed for other core SL internet traffic.

Link to comment
Share on other sites

Objects & Sculpts LOD was set at 2. Changing it to 4 did not solve the problem.

Here are more details Firestorm configuration:

CPU: AMD FX-4350 Quad-Core Processor (1400 MHz)
Memory: 16014 MB
OS Version: Linux 4.4.0-59-lowlatency #80-Ubuntu SMP PREEMPT Fri Jan 6 21:04:05 UTC 2017 x86_64
Graphics Card Vendor: nouveau
Graphics Card: Gallium 0.4 on NVCF

OpenGL Version: 3.0 Mesa 11.2.0

RestrainedLove API: RLV v3.1.4 / RLVa v2.1.0.52150
libcurl Version: libcurl/7.47.0 OpenSSL/1.0.1i zlib/1.2.8
J2C Decoder Version: KDU v7.8
Audio Driver Version: FMOD Ex 4.44.61
LLCEFLib/CEF Version: 1.5.3-(CEF-OSX-3.2171.2069-32)
LibVLC Version: 2.2.3
Voice Server Version: Vivox 3.2.0002.10426

Settings mode: Firestorm
Viewer Skin: Firestorm (Grey)
Font Used: Deja Vu (96 dpi)
Font Size Adjustment: 0 pt
UI Scaling: 1
Draw distance: 128 m
Bandwidth: 1500 kbit/s
LOD factor: 2
Render quality: Medium (3/7)
Advanced Lighting Model: No
Texture memory: 512 MB (1)
VFS (cache) creation time (UTC): 2017-1-20T19:5:51
Built with GCC version 40702
Packets Lost: 0/5487 (0.0%)
January 20 2017 21:13:07 SLT


Link to comment
Share on other sites

I have seen this phenomenon plenty of times using all of the linux viewers: Singularity, Cool VL Viewer, Firestorm, Kokua, and even the only half-working LL official viewer.

In Cool VL Viewer there is a menu option called "reset vertex buffers" (Advanced > Rendering > reset vertex buffers) that instantly renders all things that did not get rendered when first entering a region. Singularity has a similar function called "refresh vertex buffers" under its Advanced menu but I do not recall exactly which submenu it can be found. As for the v3/4/5 UI based viewers, I have not found a similar function. It might be there but might have a different name.

Sometimes I have also found that switching to wireframe mode then back to normal view will render everything.

This has been a problem with linux viewers I have used for about three or four years now. I have discussed this a couple of years ago with the Singularity viewer team but they could not replicate what I was seeing. Sadly, I have no coding knowledge so I was unable to even know where to begin to look in the source code but I suspect it is a rendering issue (if refreshing the vertex buffers seems to always work). With LL having dropped official support for linux in May 2015, relying upon third party vendors to provide fixes, this may have to be presented to the viewer project team for fixing.

It matters not whether I have used the opensource Mesa drivers (radeon, radeonsi, amdgpu for AMD or nouveau for NVidia) or proprietary fglrx or AMDGPU-Pro for AMD. The problem persists.

Link to comment
Share on other sites

After the prim bonus restarts I had a similar problem, but which also involved crashing. A Lindend came out to check, said all my four sims were fine. I kept testing and narrowed the problem to one sim -- after entering that sim, mesh content  in it and any other sim I subsequently entered, vanished. And shortly thereafter I crashed. This was after I restarted all of them multiple times. I got another Linden to come look, and she performed some operation on the affected sim and fixed it.

Link to comment
Share on other sites

  • 2 weeks later...

This was not a problem that is specific to a single sim. I had the same problem not just at SAIS but also at Serenity Lost. There were walls. floors. and roofs on buldings I could not see. In these buildings's upper floors I could see beds, other furniture, and avatars suspended in air. I finally got tech support from Serenity Lost staff that allowed me to fix it for both sims.

Because I have easily enough disk space tech support reocmmended that in my Firestorm viewer I go to  Avatar => Preferences => Network & Files => Directories (tab) => Cache size (slider) and move this slider all the way to the right so it is set at 9984MB. Part of the problem was I did not have a large enough cache,

Recommended also was to go to Avatar => Preferences => Graphics => General (tab) => Draw distance and set this to 1024 meters. The reason is to reduce lag by having everything pre-rendered as I move about the sim. I set mine to 512 meters because I rarely go to multi region sims, and a region is 256x256 meters. Then I am assured everything is rendered as few times as necessary.

I was then told to clear cache by Avatar => Preferences => Network & Files => Connections (tab) => Clear Browser Cache (menu button) and restart Firestorm.

After doing all of the above the visibility problem was solved. I was able to see everything in both sims.



Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2582 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...