Jump to content

MAV_BLOCK_MISSING?


Infektchus
 Share

You are about to reply to a thread that has been inactive for 2738 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hey!

 

I've been working on a body for a tank, but when I try and upload it i keep getting the error MAV_BLOCK_MISSING.

 

here are some snapshots of how i have the upload set up.

 

https://gyazo.com/7da159b0098b26c6e3e88b6e1fc02fe6

https://gyazo.com/ec50c26af162e0ecfbb27fd1d5e12e34

https://gyazo.com/a042914a9b3bc414f49190732963376d

https://gyazo.com/7c34dedc345235a2bdbec9177ceda21f

Link to comment
Share on other sites

In this case I suspect it's because the mid and low models are too complex.

Think about this: At the upload size and with default mid graphics, the Medium LoD model will be displayed at viewing distances between c. 13 and c. 55 m. The Low LoD model will be used for distances between c. 55 and c. 110 m. I know I've been preaching against LoD butchery on many occasions on this forum but it's important not to throw out the baby with the bathwater here. Those two models are crammed full of little details that are never going to be noticeable or even visible at the relevant distances. There's also something funny going on with the Lowest LoD model, it shouldn't have 112 triangles when the limit is set to 0. Something between 3 and 12 would be reasonable, not much more than that.

All those excessive triangles add a lot of LI and a lot of lag and are the most likely reason why you get the dreaded MAV block error.

The solution: create separate LoD models. In this case you want to make them all since obviously the uploader can't even manage to make a proper "zero model" for this build.

Link to comment
Share on other sites

Using a full LOD setting for the LOW version of a 5 meter item seems pretty strange and a not great practice.

I can't really see your physics model showing in the NICE CLEAR SCREENSHOT (ty) but are you trying to use the same full model for the physics?  That's a little confusing. 

What happens when you try to upload that same model using the default settings and a CUBE as your physics model?

 

That would be a good test.   [NOTE: that WOULD be a test and not a finished product LOL.  ]

Link to comment
Share on other sites


Chic Aeon wrote:

I can't really see your physics model showing in the NICE CLEAR SCREENSHOT (ty) but are you trying to use the same full model for the physics?  That's a little confusing.


The second screenshot shows the physics tab: custom physics model analyzed to five hulls. Seems a little bit lavish but not that much and certainly not big enough to trigger any kind of error.

Link to comment
Share on other sites

OK. I can see the text that states the info but the second screenshot example mesh window looks just like the first screenshot to me, nothing like my physics windows look. that is what I always look at (the model) not the text info :D.   Assume it is a viewer difference why it doesn't look like mine with various colors and such after analyzing. 

Link to comment
Share on other sites


Chic Aeon wrote:

OK. I can see the text that states the info but the second screenshot example mesh window looks just like the first screenshot to me

Oh, that's because physics preview is switched off.

Yes, it would have been interesting to see the physics, 57 vertices and 5 hulls for this shape seems a little bit inefficient. It's hard to see how it can cause the error though. Unlike triangle lsit, hull physics are quite robust and five hulls should never cause any problems except possibly a slightly bloated physics weight.

Link to comment
Share on other sites

Ahhhh.   It never even dawned on me that someone would turn the physics preview OFF.   That little hint has saved lots of faulty uploads for me when I forgot to apply roation or something  before export LOL.    OK. Not a viewer thing. Thanks. No, I didn't think it was the physics either, I just wondered why I couldn't see it :D.   

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2738 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...