Jump to content

Transparent issue


Beatricesss
 Share

You are about to reply to a thread that has been inactive for 2094 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

transparent issue between 2 object that attach in the same area.

So for example I create 2 objects, Object A = Hair Object B = Hat

So I "wear" the hair and then I "add" the hat. Now the issue is the hat can see throught the hair.

How can I tell the mesh that the hat is on the top not inbetween?

It isn't supposed to see throught or transparent. how do I fix this?

Link to comment
Share on other sites

Sounds like you have uploaded the texture for the hat with an alpha channel, even though it doesn't require any alpha. This usually happens when the PNG format is used to save out the texture. Make sure your texture doesn't have an alpha channel!

You can check in-world if the texture has an alpha channel. If you select the face of the hat, under the texture tab, there is an alpha mode drop down menu. If this isn't greyed out, and you are able to change the alpha mode, then your texture has an alpha channel.

You can set the texture to alpha mode None there, which will prevent the hat suffering from alpha sorting issues. The alpha mode Masking will prevent the sorting issue as well. Useful for textures which have some transparent areas. It's either fully transparent, or fully opaque though. For semi-transparency it has to be the alpha blending mode. Which has the downside of the alpha sorting problem.

To get the memory consumption as low as possible, it's best to upload textures without an alpha channel (if they doesn't need any), instead of setting the texture to alpha mode none in-world.

  • Like 1
Link to comment
Share on other sites

This is the good old alpha bug and it's a problem with OpenGL (and I think DirectX too) so it's not Second Life specific.

With two alpha textures overlapping each other, the render engine have problems determining which is the closest one and it often gets it wrong. This is especially a problem if the center of the two objects with alpha textures are close to each other  since the distance between an object and the camera is always calculated from the center of the object, not from the nearest surface.

One possible solution is to use alpha masking rather than alpha blending. That fixes the alpha bug but it does have some other disadvantages so it may not always be a good option.

Edit: Arton is right of course: does the hat need alpha at all? If not, simply remove it and the problems is solved.

  • Like 1
Link to comment
Share on other sites

There is also a bug in Blender if you are using Blender that changes your RGB file to a RGBA file (with alpha) when you aren't paying attention :D

 

I asked about that awhile ago an no one had an answer and it is still with me, so I am calling it a bug.  So if you rebake something to the same texture the texture you are baking to can turn to alpha mode. Sometimes this is obvious as it looks alpha in the UVimage area panel and sometimes you don't know until you get inworld. 

 

You CAN make sure before exporting (I do this by habit now) that the texture will be without alpha channel by watching this box at the bottom of the image saving screen. You can of course change an alpha texture to a non alpha texture by exporting again through your GRAPHICS program  and choosing "no alpha" or whatever your graphics program has for that option. 

 

 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2094 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...