Jump to content

firestorm took over as default viewer


Dorafaye
 Share

You are about to reply to a thread that has been inactive for 466 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

i only got firestorm a month ago and used it a little. last time was last week and i am heavy sl viewer user. so suddenly firestorm takes over as default when i link through the secondlife website destinations search. how do i get sl viewer back as default? this is w yosemite and opera. have had no probs til now.

Link to comment
Share on other sites

Cerise is right. I'll expand a bit on that answer.

What you are seeing happen when clicking an SLURL is the computer deciding how to handle a server connection using the protocol named secondlife. You normally see URL's cause the computer to use the HTTP:, HTTPS:, FTP:, or mailto: protocols handled by your web browser. In Windows 10 in settings you can chose which browser to use for most URL's. (Settings->System->Default Apps->Web Browser)

At the bottom of that page is an option to select: Choose Default Apps by Protocol. When you install a viewer it is changing this App by Protocol value for the protocol secondlife: telling the computer to use a SL Viewer when it sees a SLURL. Unfortunately the Lab and third party dev's do not add the protocol to Win 10 as MS recommends. So, we have no user-friendly way to change it from the settings page. Thus the recommendation to reinstall the Linden viewer to switich to it as the default handler requires we reinstall the viewer or dig into the registery and change it.

There is a second level where the SLURL can be redirected, that is within the web browser. You can tell your web browser to use a specific app for a protocol. The browser will then stop using the Windows value and use the one you set. It will no longer matter which viewer you install last. The Browser will stay with your explicit browser setting.

I haven't checked to see if Edge and IE will hold a protocol setting. They are made by Microsoft and typically have only used the Windows value.

Google for how to set your browsers protocol.

 

Link to comment
Share on other sites

  • 4 weeks later...

So nobody follows the official Win10 method? Is it different from the method used by previous versions of Windows? Is the last-installed-viewer approach something that works on all Windows versions?

(Yes, it may be different in Linux, but since the Linden viewer just doesn't run at all on my machine, I could care less.)

Link to comment
Share on other sites

  • 3 years later...

I know this thread is old, but it's the first thread i found when googling, so it might help others in the future...

Also had this issue, where it would open FS although i had just recently installed Black Dragon.

To fix it i had to run regedit, go to:
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\secondlife\shell\open\command
and edit the path to the viewer it has to use. It works without restart and is applied on the spot.

You can also check if there is a key present under
HKEY_CURRENT_USER\SOFTWARE\Classes\secondlife\shell\open\command
and edit that but that wasn't the case for me.

Normally going to the Windows Settings and choosing a default app per protocol should do the job but yeah...

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 466 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...