Jump to content

What did I do wrong?


You are about to reply to a thread that has been inactive for 2509 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I tried to upload a mesh+texture(dae file) on the preview grid, However I got an error message saying " texture is empty. Upload_InvalidAsset" (I use tga I need alpha for it.). So...I end up upload just the mesh without texture.


Another problem they import the wrong scale(too small) isn't it supposed to have the same scale as when I export from Maya??


Also how do I tell it to wear it in certain part ONLY (without rigged) for example I upload a shose how do I make it attach to the right place?


Thanks in advance!

Link to comment
Share on other sites

Don't use Maya but: 


You can set the scale (as well as SEE what the size of the object will be) a in one of the upload tabs, Upload Options. 


To set an attachment place of an UNRIGGED item you Wear or Add to an avatar, change rotation and size if needed, detach and REATTACH again to make sure it is sticking in the right spot. You of course need to choose an attachment point when you attach (like head or pelvis).  


I am not sure as I have never tried to upload the texture ON the mesh. It may have worked once, but from posts here I think it does not work now. So uploading mesh and THEN texture (or the other way around) is the typical method for lots of people. 


Good luck.

Link to comment
Share on other sites

Thank you, So if I scale my object manually and put it back in my inventory and set it for sale, all those scale won't set back to original right? (for example original  was  0.1,0.1,0.1 now is 0.4,0.4,0.4)

Also if I set my mesh to full perm what's happen to the next owner when they sell to another will I still get money from his sale? or no this is just like giving away that's all?

Link to comment
Share on other sites

Once you resize something inworld it stays that way.


If you make something full perm and sell it then you "normally" have an End User Liscense that the person buying is supposed to follow (no guarantees). You do NOT get money from resales withing Second Life. Once you sell something it is gone.


And just in case what you are uploading was NOT MADE BY YOU --- that would be against the Linden Lab Terms of Service, so no downloading free stuff from sites and uploading here.   https://www.lindenlab.com/tos

Link to comment
Share on other sites

About the Scale:

I do not know exactly what is going on in Maya, but i have the impression something is wrong with the "assets" header in the Dae file.  here is a typical assets header:

      <author>Blender User</author>
      <authoring_tool>Blender 2.78.4 commit date:2016-11-28, ...</authoring_tool>
    <unit name="meter" meter="1"/>

Within the Assets header you find one entry named "unit". This entry has an attribute name and an attribute meter. 

From the Collada 1.4.1 specifications it says:


    • name: The name (xs:NMTOKEN) of the distance
      unit. For example, “meter”, “centimeter”, “inches”,
      or “parsec”.

      This can be the real name of a
      or an imaginary name.


    • meter: How many real-world meters in one
      distance unit as a floating-point number.

      For example, 1.0 for the name "meter"; 1000 for the
      name "kilometer"; 0.3048 for the name "foot". For
      more information, see “About Physical Units” in
      Chapter 6: COLLADA Physics Reference.

So if the numbers exported are meant to be in the centimeter scale, then the meter attribute must be set to 0.01 (one number unit maps to 0.01 meters) If the numbers are meant to be in meter scale the meter attribute must be set to 1.0 (one number unit maps to 1.0 meters)

I suspect that the Maya exporter either sets the scaling wrong in the asset header or it scales the exported numbers wrong. So what you can do as a test is:


  • open the collada file with a text editor
  • find the unit entry
  • - if your imported object is a tiny: replace the meter value by its value devided by 100
  • - if your imported object is a giant: replace the meter value by its value multiplied by 100
  • Import again and see if it works for you

Also i believe that you can specify the export units in the maya exporter. Maybe you can figure out if changing the export settings creates the correct number values on export.

Link to comment
Share on other sites

  • 1 month later...

I know its not ultra recent but some Maya User may find it helpful.


The fbx_dae exporter from Maya has a certain setting regarding the size, which is left on automatic mode. When you build something in Maya, the standard size which is used is centimeters. They can be found under "Window -> Settings/Preferences -> Preferences -> Settings" and there you can change the output of the units used to build with.The non interactive creation polygons have a size of 1x1x1 centimeters while the ones in SL are on 50x50x50 cm.

To avoid size differences without doing "huge" calculations while you export your creation, just do not automatically be that convenient to leave settings as they are. When you export your fbx_dae file to create a COLLADA one, under the advanced tab, there is a sector called "Units". Uncheck the Automatic one so it is turned off and set it to its equivavalent Centimeters. This should avoid that you have to resize anything inside of Second Life, so you also know for a fact your Prims and Land Impact before you upload something.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2509 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...