Jump to content

uploading a whole rigged mesh avatar with avastar Issues (Blender 2.78a)


oot3doo
 Share

You are about to reply to a thread that has been inactive for 2122 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

Hello everyone!

I have finished rigging the avatar, it is one piece nothing is split up. I tried uploading the avatar to Secondlife with firestorm, but the upload with skin weights tab wasn't available to check, after reading up a few fixed I found that I need 26 bones rather than the 19 that avastar has (From what I have seen in my Dae file by opening it with Notepad++) So I changed the value from 19 to 26 and added the bones to the list of the other mbones. Then, I tried to upload that same DAE file, the upload with skin weights was checkable, so I selected it and tried to calculate upload fees but unfortionately as I was calculating the fees I got an error, saying my mesh had Zero bones? I figured it was because the bones I added in the DAE file (Via TXT) did not exist in the 3d version, So I went into avastar and selected the (Show extra) option, Which revealed the skull, eyes & toe bones. I exported that version and now the upload with skin weights is not checkable anymore, Please help this problem is getting rather irritating!

Link to comment
Share on other sites

Hi;

First i want to add some general remarks:

 

  • You do not need to have all 26 bones in the skeleton. Avastar takes care during export that the correct bone set is exported so that the SL importer accepts the collada file. So this can not be the reason for your trouble.
  • Editing Collada files is surely the best way to get into serious issues. Please please please... do not do that unless you know exactly what you do. Please...
  • The Rigging Display panel (or Rigging panel) is only good for display a subset of the Bones. It has no influence on what is actually exported. So i can ensure you that Avastar always exports the correct boneset (as noted above).

Now lets see what could cause your issue:

 

  • It depends on which version of Avastar you use. Is it Avastar-1.7-3 (the recommended version) or Avastar-2.0-24 (the beta version for testing the Bento Bones) ? With Avastar-2.0-24 you might need to export to "SL Legacy" depending on the viewer that you use foir import.
  • Which viewer do you use? Did you try with the SL Default Viewer ? This should normally work for Files exported by Avastar (to SL Legacy if you use avastar-2.0-24). For Firestorm and other viewers upload can sometimes be an issue.
  • How many different Materials are on your Avatar? More than 8 materials might make an issue (although it should work nowadays)
  • How many faces (triangles) does your character have, and ...
  • And how are the triangles distributed over the used materials? Having more than ~21844 triangles on a Material is troublesome (should work but all so often it does not)
  • Then do you have mesh objects which are separated into small unconnected sub meshes? Like hair strains, mesh eye lids and such? Those can (not necessarily) make trouble as well.
  • One very odd issue can be if you have unintentionally duplicated parts of your mesh resulting in a bunch of duplicated vertices. The SL Importer does not at all like those meshes. -> Take care you have no duplicate verts in your meshes.
  • Another issue can happen when you have a bunch of super tiny small triangles in your mesh. This can make the SL Importer choke as well as it can get into trouble with the physics of the mesh (yes...)

You see there are all so many possible issues that can cause trouble. However Avastar should warn you if your mesh has problems. Since obviously the tool did not complain in your case, i am very interested in taking a look into your blend file so i can understand what Avastar overlooked here.

You could also make a test as follows:

 

  • Create a new Avastar character, select the head, upper body, and lower body
  • Export this mesh to collada and see what the SL Importer says to this one. This should always work. It never failed to our knowledge. If you get trouble then something is wrong with your viewer.

If you decide to give us the chance to take a look at your blend file, then please do not hesitate to open a ticket in our ticket system or take a look at our support page where you find a bunch of options for getting help.

Link to comment
Share on other sites

Hello! Thank you for Responding. I Haven't solved the issue just yet but I'd like to answer a few things that were listed on what you wrote.

 

I am using avastar 1.7-3 I WAS using 2.0-24 before reading this, I just switched over.

Editing the Collada did create more issues, I'm glad I had a backup, Thank you for letting me know to not do that again x.x

I am using the Latest version of Firestorm

I have no materials on the avatar, It is untexted (Assuming this is like M&B and materials contain textures (This is my first project :P) ) 

There is no separate meshes, the avatar I am Trying to rig is ONE single mesh

The Highest level of Triangles for this avatar is 9577, And the Vertice count is 6305, I can upload it fine to Secondlife Unrigged.

 

&& Im not too sure what exporting as SL Legacy is, Is it Required even though I have switched to 1.7-3? 

Thank you in advance :)

 

Link to comment
Share on other sites

I know for sure that the plain simple Avastar Mesh can be transferred to Second Life without any issues. So there must be something going wrong with your installation. Please can you post the Collada file that Avastar created from the simple Avastar export?

You can either use a file service of your choice or (preferred) create a ticket in our ticket system.

thanks.

Link to comment
Share on other sites

Here is the link to my Simple avastar DAE

 

https://mega.nz/#!wxsXzL4J!26HnWyttm4v2dE8ej4UEXZ9eqv2sos5LozCWtLdVWt0

 

The way I installed avastar is  Blender>UserPreferences>Add-ons>Install From File> And then I placed the avastar Zip in there and seleced install

But I'd like to add  that I did install the beta 2.0 version first, and then tried to overwrite it, SO I went directly into my blender directory and deledted the avastar 2.0 folder and added the 1.7 one.

Link to comment
Share on other sites

While your downgrade method might work its not the best idea to fiddle with addons that way. I strongly recommend that you do a serious Add-on cleanup. Please do this now and follow this to the letter:

 

  1. Open Blender and then open the user preferences -> Add-ons Tab
  2. Select the Avastar Addon
  3. Disable the Avastar Addon (Do not delete or remove it for now)
  4. Store user preferences
  5. Restart Blender and get back to the Avastar add-on panel
  6. Now Remove the Addon (There is a button to do a complete remove)
  7. Store user preferences
  8. Restart Blender
  9. Now Install the Avastar-1.7.3 Addon (the current release version)
  10. Enable the Addon
  11. Store user preferences
  12. Restart Blender
  13. Be Happy (hopefully)

Remark: While it is not strictly necessary to restart Blender all the time, it is still the cleanest way to do it. Blender tends to throw errors at you when you disable/remove/install/enable the Avastar Addon in one go :matte-motes-sick:

Regarding your dae file: Its empty. Avastar did not export anything. I wonder how that can happen. I must admit that i have never seen before that Avastar is even capable to export a collada file without any mesh in it. SO that is a novum :matte-motes-nerdy: 

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2122 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...