Jump to content
  • 0

i have a very weird problem...i cant get the stream in one sim...the rest are fine no matter what i


roxrox14
 Share

You are about to reply to a thread that has been inactive for 2130 days.

Please take a moment to consider if this thread is worth bumping.

Question

4 answers to this question

Recommended Posts

  • 0

Freya might be right, but that wouldn't explain why you can get the stream in some regions but not others. She is right, though, that streaming media are not processed by the viewer itself. I suspect that what's happening is that your viewer and your streaming music processor are competing for bandwidth. If you have limited available bandwidth and if your Maximum Bandwidth setting (in Preferences) is set too high, your viewer is demanding almost all of the available bandwidth and leaving none for the stream.

The way to test my guess is to reduce the Max Bandwidth setting to something like 800 kB/sec or less. That will possibly produce more lag if you are on a busy region with a lot of avatars, but at least you'll hear the music. You might also try reducing your draw distance or taking other steps to keep the viewer from hogging too much bandwidth.

Link to comment
Share on other sites

  • 0

I disagree a bit with Rolig on this one.

Your viewer's Max Bandwidth setting only affects the UDP protocol, the data stream for scene updates. Textures, prims, mesh, and avatars all download via HTTP protocol, which is an error correcting and self-throttling protocol. HTTP and your Operating System (OS) will find the fastest possible speed for the connection and adjust dynamically as conditions change. The only settings that affect the viewer's use of HTTP are in the Debug Settings. Unless you understand the HTTP protocol leave the setting alone.

Anything in a scene that changes will send a UDP message. Other than those messages the viewer uses very little bandwidth... well once the scene has downloaded. All the load comes form downloading things and avatars.

The viewers Max Bandwidth should be set at 80% of your download speed or 1,500, whichever is smaller.

If you watch your Viewer Stats (Ctrl-Shift-1), you'll see the amount of data moving via UDP. If you are alone (no other avatars) you'll find the UDP load very lite <100Kbps. In busy regions with numerious avatars you'll see it move up to 500+/-K but seldom reach 1Mbps.

So, unless you have a REALLY weak Internet connection, it isn't a problem from your connection choking from overload.

Since your viewer works on some regions and not others, I suspect the problem is on their side, not yours.

You can try to get the viewr to reconnect by turn the media stream off and on.CLick the Play/pause and Speaker icons in the upper right of the viewer screen.

For your side of things you can test and find the problem (if any), I suggest you get the Firestorm Viewer and install and try it. By default it will block all third party data providers (music and video) and ask if you want to allow that source. Since they show you the source, note it so you can check it via your Internet Browser. Then allow it and see if it works in Firestorm. If it works in one viewer and not another make multiple trys. If one viewer consistently fails, then come back and we can dig into the tech details to find the problem. Otherwise, we are just guessing.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2130 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...