Jump to content

Can't upload objects with Skin Weights?


Krystal Silverweb
 Share

You are about to reply to a thread that has been inactive for 4350 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I'm trying to upload a rigged mesh with just Skin Weight checked, but the Upload button always gets grayed out when I check Skin weights. There are no other error messages and I can't figure out why it's happening. Do you need all 21 required bones in the weight list of the mesh for only Skin weights to work?(I don't have Joint positions in my mesh so it's not checked). I thought just joint positions needed all bones?

Does anyone else have this problem?

Last night I was able to upload, and the upload button did get grayed out, but I clicked on the Defaults button and they Upload came back on...this time it's not working.

 

edit: Ah..seems like it does need all 21 bones from the skeleton. There should be an error message in the uploader to alert you of the problem. Well, correction, the HIGHEST lod needs all 21 bones. Seems you can get away with the other lods not having them all?

Link to comment
Share on other sites

Actually the model I tried uploading last night did have the 21 bones, however it happened that the Upload button got grayed out until I pressed "Defaults". And in fact that happens now too...sorry I just made all this really confusing lol. And it is until I figured out what's going on :P

 

Ok, so I think I found a bug... You upload the highest lvl mesh that has 21 bones. You then upload other LOD's that do not have 21 bones. You check Skin Weights. The Upload button grays out until you hit Defaults.

Link to comment
Share on other sites

  • Lindens

Krystal:

If you wouldn't opening up a Jira regarding this issue I'll look into it - as the valid rig check should only be used if you decide to upload joint positions. Details aside it's probably a bug. Also make sure to either attach the asset or email it to me (prep@lindenlab.com).

 

Thanks!

 

-prep

 

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hello I have the same problem. I did a dress mesh in C4D r12 i have the ALL AVATAR bones rigged with the dress. In C4D if i rotate or move part of the avatar skeleton, the dress reacts/deform etc as it should be. then i try uploading in SL Aditi grid and i have no problem uploading dress as mesh object but when i try uploading it with skin included the "calculate weight" etc disappear. I really want to try mesh at least 1 time, i'm freaking out...so have somebody a solution?

thanks

Mijn

 

edit: i try uploading https://jira.secondlife.com/secure/attachment/50990/mh_avatar_boneheat.dae

and this works! but not my models...i really don't understand what i'm doing wrong...

in the collada files i have to include my mesh model with skin weight tag and also all 26 bones? becasue the file over dont have bones but just the model

  • Like 1
Link to comment
Share on other sites

  • 4 months later...

I see the date on this post, but thought I'd respond anyway! I've tried rigging mesh in Maya, Blender and C4D. Cinema 4D is a program I use frequently for work anyway, so I am really familiar with this product. The Collada exporter on C4D is fine for SL meshes, but not for rigging. The bones C4D uses do not translate into working bones for SL.

 

This means that you will have to just use C4D to make your mesh(and UV map) and try using Blender or another software program to rig your mesh with.

Do not try exporting a DAE file rig from C4D to another software program either, this won't work. Just export the Mesh and bind it to a rig in Blender or Maya.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 4350 days.

Please take a moment to consider if this thread is worth bumping.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...