Jump to content
Sign in to follow this  
Chic Aeon

Texture Plane Turns to RGBA after first bake

Recommended Posts

This has been happening since I installed the original 2.78. I thought it was one of the many bugs that got fixed in 2.76a, but it is back again.  Is there a setting I am missing somewhere?

 

Here are steps to reproduce.

I open a new startup file and make a new texture to bake to in the UV Editor. That texture has NO alpha channel. None of the textures used in the node set up have an alpha channel.

The first time I save that file  -- either a blank texture or one after the first bake -- it saves as RGB (no alpha) which is what the default is.

 

If I rebake (often as I am switching lighting) the save method switches to RGBA.

 

Now I KNOW that I can simply pay asttention and click that RGB button EACH time before I bake, but this can't be "the plan". It makes no sense.  If I forget I have to rebake which can sometimes take awhile at 400 or save the texture again in my graphics program with no alpha channel. It is doable certianly, but there must be a better way :D

 

I just repeated these steps using the default cube and a solid white texture as the texture image for the node set up on the first bake. Then I kept the same node set up but changed the image texture to a solid orange (again no alpha channel) and it did exactly the same thing.

 

Any techie hints are appreciated.

Share this post


Link to post
Share on other sites

The render settings cause this to happen.

If the preset allows for Alpha textures to appear ( Set to RGBA ) you can, if you have black Surfaces in the Texture create an Alpha by accident.

 

Heres what to do.

 



Share this post


Link to post
Share on other sites

Thanks. I knew how to fix it that way but didn't know how to make it STICK. So I will look at my presets again but I think I have them correct. But the ODD thing is that it doesn't do it all the time and is just it seems when I rebake to the SAME texture plane that I had previously baked to (so rebaking onto a texture named "cart2" for example). If I make a NEW texture plane and bake to that then it doesn't do the alpha channel thing.

 

Just putting that in here for posterity :D.  

Share this post


Link to post
Share on other sites

Yeah thats what i meant too. Here when is set this paramenter as shown, even when rebaking, it never ever generates an Alpha Channel.

 

Are you sure that, when you bake onto the same texture, you had set the "clear" option in the baking panel?

 

Share this post


Link to post
Share on other sites

Yes, clear is set.

No, there are no alpha channels in the textures I am using in the image textures (Cycles Nodes).

Yes, the combined texture always bakes perfectly the first time (well it bakes CLEARLY with no alpha channel - if it baked as I wanted it there would be no need to rebake :D)

 

I only change lighting (lamps in the 3D viewport) or brightness and contrast (nodes) or make similar changes. The next bake often (not always as far as I can tell) turns alpha. Sometimes you can see this clearly in the UVimage editor Viewport -- other times it isn't obvious at all. If I forget to LOOK and CHANGE to RGB from RGBA on the button, then I get a texture inworld that appears at first to be RGB but actually has an alpha channel and hence some issues.  I know I can turn off the alpha channel in the texture panel but the texture takes longer to download so THAT'S not good :D.

 

Yes, this is still happening.  Eventually I guess I will learn to CHECK each time, but so far I forget now and then.  This doesn't seem to be planned behavior

 

PS. This did not happen with the original 2.78 release or any time before on earlier releases. It has only been happening with 2.78a.  

 

Share this post


Link to post
Share on other sites


Chic Aeon wrote:

PS. This did not happen with the original 2.78 release or any time before on earlier releases. It has only been happening with 2.78a.  

 

Nah, this has been happening to me too for quite awhile and I never knew what was doing it. One of those small things that get missed (not covered in tutorials, etc) that drive you mad wondering where your background went after bake. I hate, hate, hate that.

So glad I came across this topic to solve this issue. (will try it later)

Share this post


Link to post
Share on other sites

OK. But so far we have no answers LOL.    It isn't like a margin setting or anything that I typically CHANGE from the defaults (for me anyway) and I have been using Cycles for almost two years now I think so that shouldn't be it either. A mystery. 

 

 

Share this post


Link to post
Share on other sites

Just adding a screenshot showing that while the RGB choice in the sidebar is active before baking it is obvious (this time but not always and I can't figure out what the differences are that cause that visusal change) that the texture it is baking to is transparent. All same textures used including the SAME texture to bake to. NO changes by me except lighting. The baking before this gave a regular RGB texture with NO tranparency.

 



Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...