Jump to content

Dissolving edges in Blender 2.78


ChinRey
 Share

You are about to reply to a thread that has been inactive for 2173 days.

Please take a moment to consider if this thread is worth bumping.

Recommended Posts

I've finally got around to updating Blender to 2.78 and I notice dissolve edges doesn't work as it used to, somnetimes it deletes vertices too.

Take this for example:



 

If I dissolve the edge at one of the corners:



 

I end up with this:



 

Is this a bug or is there some setting I overlooked when I updated?

Link to comment
Share on other sites

its a bit tricky: The Dissolve function has options which get available in the operator redo panel right after you have called the operator:

 

  • Open the Tool Shelf
  • Scroll down to the bottom of the tool shelf.
  • Disable the option "Dissolve Verts"

And all is good:



Link to comment
Share on other sites

Tried, assuming this is a plane. You get the result you show if you leave the "Dissolve vertices" option checked in the tool properties. (It seems to be checked by default). If you uncheck it, the vertices remain, and you have a concave six-sided n-gon. I saw no differences between 2.77a and 2.78 here.

ETA ...as Gaia said :matte-motes-confused:

Link to comment
Share on other sites


Drongle McMahon wrote:

I saw no differences between 2.77a and 2.78 here.

Oh, I skipped 2.77... and 2.74 and 2.75 and 2.73 and 2.72.

Anyway, thank you both Gaia and Drongle!

Next question is of course: is it possible to swtich "dissolve vertices" option off permanently? It's getting rather annoying.

Link to comment
Share on other sites

Like most (all?) tool options, it's sticky during one session - so once you've turned it off, it stays off until you turn it back on - but I didn't see a way to keep it off between sessions. I usually have to toggle it on and off for different uses. So I don't really mind that it has a default. Mostly, if it's off, I end up with lots of extra vertices in the middle of what should be clean edges. So I prefer the on default.

Link to comment
Share on other sites

It took me a moment, but here is a way how you can make this behave nicer. Below i added a screenshot from the User preferences window for easier navigation  :matte-motes-sunglasses-3:

 

  • Open the Input user preferences
  • Type "dissolve" into the search field
  • In the Mesh section open the Dissolve Selection that is assigned to CTRL X
  • The option Dissolve Verts is greyed out (see image) Ignore this and just ENABLE the option
  • Now the field is no longer greyed out.
  • DISABLE the option again. Now the option is no longer greyed out and it is disabled as before.
  • Save User Settings

Now you can dissolve the edges by clicking CTRL X and the dissolve works as you want. This setting is permanent.
[Edit]: And it looks like X -> Dissolve now also works as desired.



Of course you can also modify the keyboard shortcut for CTRL Delete in the same way.

Blender is not complicated, its just not easy to describe :matte-motes-evil:

 

Link to comment
Share on other sites

"Blender is not complicated..."

I think you just demonstrated the converse. Thepreferences choices are just too many and varied for me to risk getting into, especially as I would certainly forget what changes I had made. My brain is already well past overflowing with the unchanged defaults. :matte-motes-sour: Still, that does show again how powerful it is for those who can make more effort than me.

Link to comment
Share on other sites

You are about to reply to a thread that has been inactive for 2173 days.

Please take a moment to consider if this thread is worth bumping.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...